Jump to content
nkey

Task Force Arrowhead Radio

Recommended Posts

Here's some pictures to help.

Configure -> Controls

2014-10-17_00001_thumb.jpg

Configure Addons -> Select TFAR from dropdown menu

2014-10-17_00002_thumb.jpg

Share this post


Link to post
Share on other sites

Thanks for informing us of the update :cool:

Updated version frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Bug: There is a hot-micing (or hot-miking) bug when using Push-to-Talk in TeamSpeak with Voice Activation enabled.

Fix: Just disable the Voice Activated Push-to-Talk option in TS and this fixes the issue.

Sharing this tip so others with similar problem find it helpful!

Share this post


Link to post
Share on other sites
Bug: There is a hot-micing (or hot-miking) bug when using Push-to-Talk in TeamSpeak with Voice Activation enabled.

Fix: Just disable the Voice Activated Push-to-Talk option in TS and this fixes the issue.

Sharing this tip so others with similar problem find it helpful!

It's not that easy I'm afraid.

The hot mike issue is cured for the short range radio but persists with the long range radio, and isn't related to Voice Activation (which I have off).

Press your LR tangent key (like, I have it on "HOME") then press ALT to look around. Release HOME key and your tangent will be stuck even though you have released the key. For short range it stops when you release the key, for long range it doesn't.

Share this post


Link to post
Share on other sites

Whats the difference between "Transmit Alt" and "Transmit Additional"?

Share this post


Link to post
Share on other sites
Whats the difference between "Transmit Alt" and "Transmit Additional"?

Additonal -for addititonal channel, Alt - just second binding for same transmit.

Share this post


Link to post
Share on other sites
Here's some pictures to help.

Configure -> Controls

http://snakebiteink.co.za/arma/pictures/2014-10-17_00001_thumb.jpg

Configure Addons -> Select TFAR from dropdown menu

http://snakebiteink.co.za/arma/pictures/2014-10-17_00002_thumb.jpg

this is what i get:

th_arma32014-10-1715-54-12-10_zpsc391aac7.png

bindings aren't listed in my game (localization italian), how can i change bindings without switching my game into another language?

thanks in advance

Edited by Simon1279

Share this post


Link to post
Share on other sites

As stated by nkey earlier here, you need to be inside a mission to get the TFAR key bind option showing. To me it seems like you are at the start menu after getting into the game.

Share this post


Link to post
Share on other sites

Here iam back again, we have still the issue that after respawn our players can no longer use TFR. We found today out that it has something to do with the CSE 0.7.1 Modules.

If there is one CSE Module on the map TFR stops working. Any solutions?

Share this post


Link to post
Share on other sites
Here iam back again, we have still the issue that after respawn our players can no longer use TFR. We found today out that it has something to do with the CSE 0.7.1 Modules.

If there is one CSE Module on the map TFR stops working. Any solutions?

Hm.. Will check that.

Share this post


Link to post
Share on other sites

Me and my friends use TS3(TFAR), when host lag one second during in our local server game, and our TS3 crash the same time.

Ts3 and FAR are Latest version. poor English pardon me.

Share this post


Link to post
Share on other sites
Here iam back again, we have still the issue that after respawn our players can no longer use TFR. We found today out that it has something to do with the CSE 0.7.1 Modules.

If there is one CSE Module on the map TFR stops working. Any solutions?

Do you have the CSE nametags enabled?

Hm.. Will check that.

If it has nothing to do with the nametags, it's probably due to fn_setVolume_f.sqf, which is used for being unconscious:

private ["_setVolume"];

_setVolume = [_this, 0, false, [false]] call BIS_fnc_Param;

if (_setVolume) then {

2 fadeSound 1;

player setVariable ["tf_voiceVolume", 1, true];

player setVariable ["tf_globalVolume", 1, true];

player setVariable ["tf_unable_to_use_radio", false, true];

if (!isnil "acre_api_fnc_setSpectator") then {

[false] call acre_api_fnc_setSpectator;

};

} else {

2 fadeSound 0.3;

player setVariable ["tf_voiceVolume", 0, true];

player setVariable ["tf_globalVolume", 0.1, true];

player setVariable ["tf_unable_to_use_radio", true, true];

if (!isnil "acre_api_fnc_setSpectator") then {

[true] call acre_api_fnc_setSpectator;

};

};

[[_setVolume],"setVolume"] call cse_fnc_customEventHandler_F;

Please let us know if the API has changed so we can fix the issue.

(Member of CSE Team here :D)

Edited by janus0104

Share this post


Link to post
Share on other sites
Me and my friends use TS3(TFAR), when host lag one second during in our local server game, and our TS3 crash the same time.

Ts3 and FAR are Latest version. poor English pardon me.

Will you able to test with debug version of plugins (I'll send to you) and upload TS dump?

---------- Post added at 16:13 ---------- Previous post was at 16:12 ----------

Do you have the CSE nametags enabled?

If it has nothing to do with the nametags, it's probably due to fn_setVolume_f.sqf, which is used for being unconscious:

Please let us know if the API has changed so we can fix the issue.

Hm.. API is not changed...

Share this post


Link to post
Share on other sites
Hm.. API is not changed...

Weird... if he has nametags on, this code is also running (used to display an animation above people's head when they talk):

#define ACTION_PUSH_TO_TALK_PRESSED (inputAction "PushToTalk" > 0)

#define ACTION_TFAR_RADIO_ACTIVE [] call {if (!isnil "TF_tangent_lr_pressed") then {(TF_tangent_lr_pressed || TF_tangent_sw_pressed || TF_tangent_dd_pressed)} else { false };}

#define ACTION_ACRE_RADIO_ACTIVE [] call {if (["acre_api"] call cse_fnc_isModLoaded_F) then {[player] call ACRE_api_fnc_isBroadcasting} else { false };}

private ["_unit"];

_unit = [_this,0,objNull,[objNull]] call BIS_fnc_Param;

if (_unit != player) exitwith {};

if ((["task_force_radio"] call cse_fnc_isModLoaded_F)) then {

waituntil {!isnil "TF_tangent_lr_pressed"};

};

waituntil {

if (ACTION_TFAR_RADIO_ACTIVE || ACTION_PUSH_TO_TALK_PRESSED || ACTION_ACRE_RADIO_ACTIVE) then {

if !(_unit getvariable ["CSE_TALKING", false]) then {

_unit setvariable ["CSE_TALKING", true, true];

};

} else {

if (_unit getvariable ["CSE_TALKING", false]) then {

_unit setvariable ["CSE_TALKING", false, true];

};

};

!(alive _unit)

};

_unit setvariable ["CSE_TALKING",nil,true];

Those are the only two places CSE interacts with radio addons. It could of course simply be a side effect of how death/respawn is manipulated by CSE... But then we have to dig deeper^^

Edited by janus0104

Share this post


Link to post
Share on other sites

pardon me nkey if this has already been answer before, but what version of TS3 are officially supported by TFR 0.9.5?

teamspeak plugin folder in the archive have no differentiation between <3.0.14 and >3.0.14 anymore?

thank you.

Share this post


Link to post
Share on other sites
pardon me nkey if this has already been answer before, but what version of TS3 are officially supported by TFR 0.9.5?

teamspeak plugin folder in the archive have no differentiation between <3.0.14 and >3.0.14 anymore?

thank you.

Will add support for older version soon.

Share this post


Link to post
Share on other sites

nkey: We'll try to figure out the CSE Issue, might be fixed already on our git, will let you know :)

Share this post


Link to post
Share on other sites

Wow nice update but i have a Problem...

I have not Change my Keys or other only the Update 1.2 gb arma3 update...

and today 1 or 2 h after it. coming now Problems the SW Transmit have Buged. Always if i send with Capslock and this Buttum Leave are in the right side still in Green "Send" if i the crtl or other Key press stop it to send. I leave the crtl key or other and agian still send for me looks like "Autosend"

how can i this trun of? or are it a new bug? whatever i have not idea sorry...

Share this post


Link to post
Share on other sites
Here iam back again, we have still the issue that after respawn our players can no longer use TFR. We found today out that it has something to do with the CSE 0.7.1 Modules.

If there is one CSE Module on the map TFR stops working. Any solutions?

Same here, but we don't use CSE-Modules. We use the Userconfig-Version of CSE...

Share this post


Link to post
Share on other sites
Same here, but we don't use CSE-Modules. We use the Userconfig-Version of CSE...

The CSE server extensions? Could you send me your userconfig file (enabledModules.hpp i believe it's named) in a PN or so?

Share this post


Link to post
Share on other sites
Wow nice update but i have a Problem...

I have not Change my Keys or other only the Update 1.2 gb arma3 update...

and today 1 or 2 h after it. coming now Problems the SW Transmit have Buged. Always if i send with Capslock and this Buttum Leave are in the right side still in Green "Send" if i the crtl or other Key press stop it to send. I leave the crtl key or other and agian still send for me looks like "Autosend"

how can i this trun of? or are it a new bug? whatever i have not idea sorry...

Not sure I get you.... So, tangent stuck for some reason, right?

---------- Post added at 18:17 ---------- Previous post was at 18:17 ----------

What version of TS do we use now, still 3.14 or can we update to 3.16?

You can update.

Share this post


Link to post
Share on other sites

What script or config file do you store the .p3d to use for each LR radio? If you are OK with it I would like to attempt to put in different .p3d's for each LRR so we can have multiple for different ranks in the realism unit I am in. Cheers.

Share this post


Link to post
Share on other sites
What script or config file do you store the .p3d to use for each LR radio? If you are OK with it I would like to attempt to put in different .p3d's for each LRR so we can have multiple for different ranks in the realism unit I am in. Cheers.

Search here https://github.com/michail-nikolaev/task-force-arma-3-radio/blob/master/arma3/%40task_force_radio/addons/task_force_radio_items/config.cpp#L194

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×