Jump to content
nkey

Task Force Arrowhead Radio

Recommended Posts

How do we get the parent class name when we dont know what kind of object the radios are? 

 

Are they weapons? Vehicles? Items? Some code would be awesome, or better yet a function to do this for us cause this dynamic class name stuff is frustrating to work around.

https://github.com/michail-nikolaev/task-force-arma-3-radio/wiki/API%3A-Functions#TFAR_fnc_isPrototypeRadio

Share this post


Link to post
Share on other sites

i want to add this classname "H75th_Camelbak_Mule_RngrGrn" with the functionality to be opened as a long range radio preferably the 'tf_rt1523g_big' Anyone know how its done?  -_-

Share this post


Link to post
Share on other sites

i want to add this classname "H75th_Camelbak_Mule_RngrGrn" with the functionality to be opened as a long range radio preferably the 'tf_rt1523g_big' Anyone know how its done?  -_-

 It's pretty straight forward. Have a look at the API: https://github.com/michail-nikolaev/task-force-arma-3-radio/wiki

 

This results to something like this:

	class TFAR_Bag_Base;

	class tfw_ilbe_wd: TFAR_Bag_Base {
		author = "Raspu";
		scope=2;
		displayName="ILBE AP MARPAT-WD RT-1523G (ASIP)";
		descriptionShort = "RT-1523G (ASIP) long range radio 20km";
		picture="y\tfw_radios\addons\tfw_ilbe\data\icons\ilbe_icon.paa";
		model="y\tfw_radios\addons\tfw_ilbe\data\model\tfw_ilbe.p3d";
		hiddenSelectionsTextures[] = {"y\tfw_radios\addons\tfw_ilbe\data\model\ilbe_co.paa"};
		hiddenSelections[] = {"camo"};
		maximumLoad=240;
		mass=80;
		isbackpack=1;
		tf_encryptionCode = "tf_west_radio_code";
		tf_dialog = "rt1523g_radio_dialog";
		tf_subtype = "digital_lr";
		tf_range = 17000;
	};
  • Like 1

Share this post


Link to post
Share on other sites

Do we know if we ever going to see an update to this, with maybe some new radios. Just asking since i kinda out of the loop in terms of what is going on in this mod. Thanks. 

Share this post


Link to post
Share on other sites

Hi all,

Perhaps you could help me. I'm stuck with this problem:

I've got TFAR 0.9.8 several weeks (months) ago on TFAR server.

As i don't need long range radio, I disabled the f...king auto replace backpack. So, I changed  tf_no_auto_long_range_radio=0 for 1 in the userConfig\task_force_radio\radio_settings.hpp

Nothing hard so far.

 

Yesterday, I found the TFAR 0.9.8 (same version I guess) on Steam and I decided to subcribe it, for an eventual automatic update (all my other mods are already automatically updated on Steam).

So, my TFAR is now from Steam at Arma launcher. But, in any basic scenario I test in 3DEN, this automatic long range radio comes back!

I checked for that. My userConfig\task_force_radio\radio_settings.hpp is unchanged. I can read tf_no_auto_long_range_radio = 1.

I removed all files, re subscribe... no joy.

Furthermore, It seems the userconfig (radio_settings.hpp) is now totally useless...

 

I don't know what to do to avoid removing the mod. Please help!

Share this post


Link to post
Share on other sites

disabled the f...king

That wont get you sollution any quicker...

Just put down the TFAR module in you mission and disable the LR radio.

Share this post


Link to post
Share on other sites

Hi!

 

For building Antistasi updated while tweaking the official server in one single mission file, I want to know if it's possible to use a scripted version of the module.

 

I mean: I want to update Antistasi with an Official Server detection, and if yes, set the params in a script instead of having to add the module manually.

 

Is it possible? Now I can detect TFAR with no problem, and I have default settings for LR radios etc.. What I miss is all the TS settings.

 

Like:

 

If (TFARdetected and isOfficialServer) then

{

tsSettings = xxx; publicVariable "tsSettings";

tsPassword = yyy; publicVariable "tsPassword";

}

 

Also if that's possible, will it have to work on each client init.sqf or can be done from server + publicVariable?

 

Thanks in advance!

}

Share this post


Link to post
Share on other sites

It takes like 5 seconds to place the module and set it up, don't be so "f..king" ungrateful 

My dear, the problem is i get the TFAR backpack in all scenarios, not only when I edit the mission! So, the configuser\config_settings.hpp worked well before I had the bad idea to change for Steam "update" (same 0.9.8 version). I'm just asking for this behavior, far more clever than adding any module... on an PBOed dowloaded scenario.

Share this post


Link to post
Share on other sites

Today with 1.60 we heard dead players talk, despite they should have been in Spectator Channel ("[player, true] call TFAR_fnc_forceSpectator;");

Can anybody confirm? Not completely sure its not our fault.

Share this post


Link to post
Share on other sites

You were able to get it to load?  I get this:

Warning Message: Addon 'task_force_radio_items' requires addon 'A3_Weapons_F_ItemHolders'

Share this post


Link to post
Share on other sites

You were able to get it to load?  I get this:

Warning Message: Addon 'task_force_radio_items' requires addon 'A3_Weapons_F_ItemHolders'

TFAR was working fine for us except the beforementioned error.

Share this post


Link to post
Share on other sites

Is there any planned support for Discord instead of TeamSpeak?

 No reuqired C++ API for discord at the moment.

  • Like 1

Share this post


Link to post
Share on other sites

My dear, the problem is i get the TFAR backpack in all scenarios, not only when I edit the mission! So, the configuser\config_settings.hpp worked well before I had the bad idea to change for Steam "update" (same 0.9.8 version). I'm just asking for this behavior, far more clever than adding any module... on an PBOed dowloaded scenario.

 

config_settings.hpp is disabled for steam version because of workshop limitions. Use regular version for server.

  • Like 1

Share this post


Link to post
Share on other sites

TFAR was working fine for us except the beforementioned error.

 

Hm.. Not getting any error....

Share this post


Link to post
Share on other sites

Hm.. Not getting any error....

I have to clarify, we didnt get an error but living units could hear dead players talk and vice versa despite being switched to spectator channel as soon as they died. 

 

Found the culprit. Due to a server update (same time 1.60 dropped) we werent in serious mode anymore. So no bug at all, sorry for the inconvenience.

Edited by nomisum

Share this post


Link to post
Share on other sites

Today with 1.60 we heard dead players talk, despite they should have been in Spectator Channel ("[player, true] call TFAR_fnc_forceSpectator;");

 

Can confirm, have the same problem.

Share this post


Link to post
Share on other sites

Can confirm, have the same problem.

 

 

Could you confirm it works with serious mod?

Share this post


Link to post
Share on other sites

Having an issue with the Radio and the TS channel..only on Kunduz it seems..I have the enforce usage Module down.TS Channel named correctly and password is named correctly,when I enter the game it kicks me to the TFR channel as it should but then after a few seconds it kicks me back out of the TFR channel. I have Stratis set up the exact same way and it works perfect in there no issues at all. Anyone having any issues like this in other Maps?

 

 

Diesel

Share this post


Link to post
Share on other sites

Hi guys, so we have been using TFAR for almost a year without an issue but we recently moved to a Linux and its been hectic learning curve :) We currently have an error that has "Task force not installed on server". Newest version of TFAR, CBA on both server and users. No errors on the RPT. Just wondering if I am doing something super stupid? Any help would be appreciated.

 

Command line: ./arma3server -name=server -config=server.cfg -par=startupparameter.txt 1>>"arma3server_$(date +%s).rpt" 2>>"arma3server_$(date +%s).rpt" -exThreads=1 -world=empty -filePatching -mod=@cba_a3\;@hlcmods_core\;@hlc_ar15\;@hlcmods_fal\;@hlcmods_g3\;@rds\;@rds_rhs_comp\;@rh_pdw_a3\;@rh_pistol_a3\;@rhs_afrf3\;@rhs_usf3\;@ryanzombies\;@sa_pmc\;@sma\;@task_force_radio\;@fhq_accessories\;@l_mount\;@xeno_taru_pod_mod\;@ace3\;@asr_ai3\;

Share this post


Link to post
Share on other sites

Hi, Maybe someone can help me out. But it seems the server is connecting to team speak then disconnecting. I get an error in game that says "waiting for the unique radio from server" then i get renamed in teamspeak to my game name and the plugin on teamspeak says "Task Force Radio Status (0.9.8):Connected Y Play Y P:0.9.8 A: 0.9.8" after the waiting for the unique radio from server has gone away the status changed to "Task Force Radio Status (0.9.8):Connected Y Play N P:0.9.8 A: 0.9.8"

 

My server rpt is http://pastebin.com/UJhvGTiU

 

Any help would be much appreciated. Thank you

Share this post


Link to post
Share on other sites

Right after many hours of testing, Ive found its not teamspeak. it has to do with sides im using the exile mod, if there a way to set the frequency's for resistance side (Independant)

Share this post


Link to post
Share on other sites

Hi, Alright scrap them last 2 questsions. I got it to work on exile but now im faced with a new problem, my team speak client log is giving me the error of 

task_force_radio	Info	can't center client : invalid clientID	

I also cant hear my friend when he talks, and he cant he me when i talk. did i do something wrong?

Share this post


Link to post
Share on other sites

Is there a way to have two radios in a vehicle? i am trying to make a command vehicle that has 2-3 radios if possible

Share this post


Link to post
Share on other sites

On Arma 3 1.62 RC the menu gets wonky because TFR adds stuff to the menu. This should be removed or adjusted before Apex launches July 11th if anybody is around to work on it.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×