Jump to content
Sign in to follow this  

Arma 3 Freeze

Recommended Posts

So, yesterday I installed Windows 8.1 on my PC.:icon_neutral:

Since then, I get randomly freezes in Arma 3. Doesn't matter if I'm playing SP or MP. No Error-Messages at all. Back on Windows 7 Pro 64bit, everything worked fine.

I tried it with different drivers from NVIDIA, changed graphic settings, tried -nobenchmarks, dev-branch..

Only things I installed so far are all drivers, Steam, Arma 3, Avira Antivir.


Windows 8.1 Pro 64bit

GeForce GTX 580 (latest driver: 331.65)

i7-2600K CPU @ 3.40GHz




It's kinda frustrating and annoying...

Do you guys have the same issue and/or can you help me?

Best regards


Share this post

Link to post
Share on other sites

I have the exact issue on Win 7 64bit Ultimate.

I can play between 1 min and 1 hour before my screen freezes, artifacts of random color pixels appear, and I get a crash to desktop, however the game is still running and I have to force it to close via task manager.

I've had issues every since the game came out of beta.

Arma 3 is the only game I have issues in.

I also have an EVGA 580GTX

i7 920 at 3.2GHz

12GB GSkill DDR3


Win7 64Bit Ultimate

Several people seem to have the same issue with 500 series cards.

Share this post

Link to post
Share on other sites

I'm already using it. Have been for some time. As I remember, it actually corrupted on install and I had to manually install from Nvidia.com

I will try wiping the whole install and rebuilding my install.

Share this post

Link to post
Share on other sites

Check temps of components, might be overheating.

If running mods/non-default missions: disable them and run vanilla, see if problems persist.

Share this post

Link to post
Share on other sites

I've recently downloaded a few new mods however when I activated them through expansions off the main menu and restarted my launcher got stuck at loading addons. I tried moving mods out of the directory one by one and it still wouldn't load so then I decided to move the userconfig folder, I restarted the launcher and it went through fine, then I exited and put the userconfig folder back and the launcher got stuck at loading addons once again, obviously the userconfig folder is the cause of the problem but how can I get it to work since I won't be able to use mods without it.

-edit: I fixed the problem there was a mod that didn't work in the mix.

Edited by Nyteblade

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this