Jump to content
Robalo

ASDG Joint Rails

Recommended Posts

Have you changed the main config as well ? Make sure class srifle_MSR_F does not have any non-JR slots (WeaponSlotsInfo).

Also, you should populate requiredaddons in cfgpatches.

Share this post


Link to post
Share on other sites

I can't as I'm not the author of the mod and don't have permission from the author. It an old mod that I'm assuming the author has forgotten. Thus the sound config and adding in joint rails compability. So I'm guessing this isn't a problem I can fix with a config file.

Share this post


Link to post
Share on other sites
I can't as I'm not the author of the mod and don't have permission from the author. It an old mod that I'm assuming the author has forgotten. Thus the sound config and adding in joint rails compability. So I'm guessing this isn't a problem I can fix with a config file.

Ok then there is another way. Hide class srifle_MSR_F with scope = 1 and make another class inherit from it with the proper slot config. Something like:

	class srifle_MSR_F : MSR_base {	
	scope = 1;
};
class srifle_MSR_F_JR : srifle_MSR_F {	
	scope = 2;
	class WeaponSlotsInfo {
		allowedSlots[] = {801, 701, 901}; 
		class asdg_FrontSideRail_msr: asdg_FrontSideRail {};
		class asdg_OpticRail_msr: asdg_OpticRail1913 {};
		class msr_MuzzleSlot: asdg_MuzzleSlot_762 {}; // has the ASDG compatible muzzle mounting system
	};
};

Share this post


Link to post
Share on other sites

Thanks I'll give it a shot :-)

Worked man, thanks for your help. The only thing is both of them show up in VA, (both of them work too) but is there a way to hide it from VA? or is that what the (scope = 1) suppose to do?

Edited by gobi42

Share this post


Link to post
Share on other sites
Thanks I'll give it a shot :-)

Worked man, thanks for your help. The only thing is both of them show up in VA, (both of them work too) but is there a way to hide it from VA? or is that what the (scope = 1) suppose to do?

Yeah that does it. If not, you might need to update JR.

Share this post


Link to post
Share on other sites

these are the versions i have installed according to PWS collection i have set up

ASDG JR 0.11

ASDG JM 0.2

ASDG Attachments 0.10

Share this post


Link to post
Share on other sites
these are the versions i have installed according to PWS collection i have set up

ASDG JR 0.11

ASDG JM 0.2

ASDG Attachments 0.10

If you are positive that your item shows up in BIS's Arsenal even though it has scope = 1 and you are using latest ASDG JR then you may be using some other mod that overwrites the arsenal function.


Small update of JointMuzzles available in first post. Fixes issues with addons that inherit from muzzle_snds_H and do not set explicit scope = public.

JM 0.2 beta

muzzle_snds_H is used as base class for most other suppressors, reverted scope change (now public) and hidden the other one, muzzle_snds_B (scope = protected).

increased audio signature reduction for all suppressors (changed audibleFire ammocoef from 0.7 to 0.5) - AI tweak.

Share this post


Link to post
Share on other sites

Release frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means soon you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Hi!

I've got a pb when I use your addon and the virtual arsenal. I can't move the camera arround the character and all I see is his back.

Share this post


Link to post
Share on other sites
Hi!

I've got a pb when I use your addon and the virtual arsenal. I can't move the camera arround the character and all I see is his back.

Works just fine here. Are you on dev branch ?

Share this post


Link to post
Share on other sites

Hi!

If I remember correctly, in the Virtual Arsenal, you use the left mouse button to move around your character... Since I install your addon, it acts like the right mouse button...

What's dev branch?

Edited by RiMaP-P90

Share this post


Link to post
Share on other sites
Hi!

If I remember correctly, in the Virtual Arsenal, you use the left mouse button to move around your character... Since I install your addon, it acts like the right mouse button...

What's dev branch?

What you're talking about, use left button to move the scene, right to rotate. No way this addon will change that.

Share this post


Link to post
Share on other sites

I'm using a different computer right now... That's why I don't remember... Yesterday, I tried ardvarkdb's MK18 Mod 1 and I update your mod.

I'll try to reinstall arma 3, maybe I did something wrong with another addon.

BTW, I'm in Arma 3 1.28.

Share this post


Link to post
Share on other sites

If I use VTN and ASDG + hlc weapons the AK weapons of VTN dissapear. The VTN Atachments doesen't fit with the other weapons too unfortunately. Has anyone a solution or idea how to fix it ?

Share this post


Link to post
Share on other sites
If I use VTN and ASDG + hlc weapons the AK weapons of VTN dissapear. The VTN Atachments doesen't fit with the other weapons too unfortunately. Has anyone a solution or idea how to fix it ?

ASDG is not a mod, but a team tag. Which mod are you talking about exactly ? JointRails can't make weapons disappear. For the second thing, sure, VTN devs or someone else would have to make a JR compatibility config for VTN.

Share this post


Link to post
Share on other sites
ASDG is not a mod, but a team tag. Which mod are you talking about exactly ? JointRails can't make weapons disappear. For the second thing, sure, VTN devs or someone else would have to make a JR compatibility config for VTN.

Ok, thanks. I'm talking about Veteran Mod:

http://forums.bistudio.com/showthread.php?184579-Veteran-mod-%28VTN%29-announcement-and-WIP/page32

I already asked them and it seems like they dont., ... looks like it's on my own.

Share this post


Link to post
Share on other sites

I noticed for with JM addon, that the stock muzzles are removed on MK20 weapons. It seems the weapons falls on the 7.62 attachment instead of the 5.56 standards. This breaks missions built with this setup. Any ideas on workarounds or if this can be addressed? Thanks for your work!

Share this post


Link to post
Share on other sites
I noticed for with JM addon, that the stock muzzles are removed on MK20 weapons. It seems the weapons falls on the 7.62 attachment instead of the 5.56 standards. This breaks missions built with this setup. Any ideas on workarounds or if this can be addressed? Thanks for your work!

JM doesn't do that on it's own. Mk20 weapons are configured when you use JM to use the 5.56 suppressors.

Share this post


Link to post
Share on other sites
JM doesn't do that on it's own. Mk20 weapons are configured when you use JM to use the 5.56 suppressors.

Sorry should have listed the mods i ran. In this case i ran, CBA, ADSG_JR and Attachments. Maybe its an issue with JM+Attachments? I'll do more playing around but when i disabled JM only it restored the suppressors as i expected...

Share this post


Link to post
Share on other sites
Sorry should have listed the mods i ran. In this case i ran, CBA, ADSG_JR and Attachments. Maybe its an issue with JM+Attachments? I'll do more playing around but when i disabled JM only it restored the suppressors as i expected...

There is no issue, tested with CBA, ASDG JR, JM and Attachments and all is well. Cleanup your addons and grab latest versions.

Share this post


Link to post
Share on other sites

Hey man,

So i went ahead and redownloaded all of the following:

CBA

JR

JM

Attachments

Ran tests and i am still having some issues. First thing i show below is vanilla setup. Attachments work as expected. 5.56 attaches for correct weapons. 2nd load i launch these mods only. What i notice is that the MK20 weapon had the correct 5.56 attachment, BUT its a different model then vanilla. Then on the MX weapons, it has an attachment of a 7.62 suppressor.

Hope this helps explain what i am seeing

Share this post


Link to post
Share on other sites

Nothing wrong there. Read JM notes in first post.

Share this post


Link to post
Share on other sites

Stupid me. Well i guess why i feel something is going wrong is in a mission of mine that i am building i got all units with suppressors. However for some reason the GL unit is dropping the suppressor even though they are all setup with the same code. I guess i'll just warn the players about it. Appreciate the info and happy new year!

Share this post


Link to post
Share on other sites

Hey team,

if your like me, you love RHS optics and attachments (easy laser/light??) but you were sad that they weren't ASDG JR compatible. Well shed no more tears!

Download this pbo and you can use the great stuff from RHS with anything else thats ASDG JR compabtible.

As a bonus, I've also made it so that the M2010 can accept optics other than RHS ones!

enjoy!

https://mega.co.nz/#!IFZ32aiQ!9qdt2A...vfjqSDFLNwysmc

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×