Jump to content
Tom_48_97

Poseidon: advanced text editor for Scripts & Configs

Recommended Posts

280_e9a7d1447ff598e8.jpg

Today is again a patch day! Thanks to your feedback on the last release candidates, I was able to fix most of the issues and even to make two additions :rolleyes:

Since, it's more a fix than a release (as states the version number), no need to write a wall of text about it, so, enjoy yourself with this version :cool:

Change log:

WARNING: A fresh install is required because of some issues from the previous release.

  • Added: Ability to open Arma 3 log directory (Top menu >> Logs)
  • Added: Shortcut to open the current file into a new tab (ctrl+shift+c)
  • Fixed: Installer dependencies
  • Fixed: Bad definitions in SQF language configuration
  • Fixed: Installed version was incorrect
  • Fixed: Mikero tools were not working on some OS (with very specific conditions)

Full change log: http://tom4897.info/projects/poseidon-tools/changelog/

0.78.1 => 0.78.6 - Release Candidates - Hot fixes

Known issues:

  • The installer will mark the version to install to 0.78.6, just ignore it.

Download:

Share this post


Link to post
Share on other sites

As promised, here's my latest bug report :D

This error comes up whenever I right-click in poseidon. It comes up and then my right-click works for a period of 10-20 seconds, then another right-click causes it to error again and so on.

It's been this way since this build.

Share this post


Link to post
Share on other sites

This error generally occurs when Tortoise is not present or misconfigured. First step is to check it (Preferences, Tortoise, Settings), hereafter, my configuration file as example:

{    "svn_tortoiseproc_path": "C:\\Program Files\\TortoiseSVN\\bin\\TortoiseProc.exe",
   "git_tortoiseproc_path": "C:\\Program Files\\TortoiseGit\\bin\\TortoiseGitProc.exe",
   "hg_hgtk_path": "C:\\Program Files\\TortoiseHg\\thgw.exe"
   "git_tgit_path": "C:\\Program Files (x86)\\Git\\bin\\git.exe",
   "cache_length": 5,
   "enable_menus": true,
   "debug": false,
   "use_workbench": true
}

Share this post


Link to post
Share on other sites

So if my tortoise settings look the same as yours, I would want to comment them out to remove the error? (Since I don't use tortoise SVN).

Edit: Yeah, that fixed it :)

Edited by SilentSpike

Share this post


Link to post
Share on other sites

280_e9a7d1447ff598e8.jpg

After the TECHREP 17, it's now time to update your "Poseidon Tools" :)

Change log:

WARNING: A fresh install is needed.

  • Added: Config properties needed for animations
  • Added: Config properties needed for sounds
  • Added: Config properties required to implement the FFV feature
  • Added: Most of the properties needed for interfaces
  • Changed: "class" keyword is case sensitive and must be in lowercase
  • Changed: Scrollbar aspect
  • Changed: Scroll speed increased (+20%)
  • Changed: Binary files are now openned as Hexa file (temporarly)
  • Changed: Minimap, improved view of the current view
  • Changed: Status bar is more thin than before
  • Changed: Color of the inactives tabs
  • Fixed: typeOf was missing from the Arma 3 script commands

Full change log: http://tom4897.info/projects/poseidon-tools/changelog/

Download:

Edited by tom_48_97

Share this post


Link to post
Share on other sites

Release frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Traceback (most recent call last):
 File ".\sublime_plugin.py", line 338, in run_
   return self.run(**args)
 File ".\Arma3CommunityTools.py", line 17, in run
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 12: ordinal not in range(128)
cd D:\ArmaTyökansio\työkalut\Poseidon\Data\Packages\Bin & start settings.exe
Traceback (most recent call last):
 File ".\sublime_plugin.py", line 338, in run_
   return self.run(**args)
 File ".\Arma3CommunityTools.py", line 17, in run
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 12: ordinal not in range(128)
Traceback (most recent call last):
 File ".\sublime_plugin.py", line 338, in run_
   return self.run(**args)
 File ".\open_log.py", line 12, in run
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 15: ordinal not in range(128)
Traceback (most recent call last):
 File ".\sublime_plugin.py", line 338, in run_
   return self.run(**args)
 File ".\open_log.py", line 12, in run
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 15: ordinal not in range(128)
Traceback (most recent call last):
 File ".\sublime_plugin.py", line 338, in run_
   return self.run(**args)
 File ".\open_log.py", line 30, in run
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 15: ordinal not in range(128)
Traceback (most recent call last):
 File ".\sublime_plugin.py", line 338, in run_
   return self.run(**args)
 File ".\open_log.py", line 12, in run
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 15: ordinal not in range(128)

I keep getting these errors when i am trying to open something external such as the arma 3 logs or even the internal settings.

What gives ?

Share this post


Link to post
Share on other sites

"\xF6" is the "ö" you have in your installation path and is the problem. If you change your installation path for something without this character, it should work ;)

Share this post


Link to post
Share on other sites

I've just bumped into this wonderful looking tool, but my Avast is crying Win32:Evo-gen [susp] when downloading from Armaholic. The direct download comes through, but I cannot unzip it. Is this known, is this my problem, or am I doing something wrong (if there is anything that can be done wrong in downloading a file.. .:) )

To be more specific the install.exe makes Avast mad.

Edited by zapat

Share this post


Link to post
Share on other sites

I believe avast just doesn't play nice with unknown exe files, heard reports of behavior with other 3rd party tools for various games. If I remember correctly you can report the file to avast so they can confirm it's clean.

Share this post


Link to post
Share on other sites

You can report it, Spike but it takes them months to action anything you send them.

Meantime, this is new? I was wondering if this is how folders are supposed to look in the sidebar?

eqdRboI.png

Share this post


Link to post
Share on other sites

Hello,

I have downloaded v0.80 and try to update/install some utilities with the Community-Updater but it always ends up in a error message:

System.Net.WebException: Timeout für Vorgang überschritten

bei System.Net.WebClient.DownloadFile(Uri address, String fileName)

bei Microsoft.VisualBasic.MyServices.Internal.WebClientCopy.DownloadFile(Uri address, String destinationFileName)

bei Microsoft.VisualBasic.Devices.Network.DownloadFile(Uri address, String destinationFileName, ICredentials networkCredentials, Boolean showUI, Int32 connectionTimeout, Boolean overwrite, UICancelOption onUserCancel)

bei Microsoft.VisualBasic.Devices.Network.DownloadFile(String address, String destinationFileName, String userName, String password, Boolean showUI, Int32 connectionTimeout, Boolean overwrite, UICancelOption onUserCancel)

bei communty_updater.downloadMgr.download(String source, String destination, Boolean ui)

bei communty_updater.downloadMgr.getFile(String source, String destination, Boolean showUI)

bei communty_updater.updateTools.Proceed(String toolName, CheckBox checkBox)

bei communty_updater.updateTools.init()

bei communty_updater.dialog_upd.Timer_start_Tick(Object sender, EventArgs e)

bei System.Windows.Forms.Timer.OnTick(EventArgs e)

bei System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)

bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

What is wrong here? :confused:

Share this post


Link to post
Share on other sites

Sorry Tankbuster, I had not seen your message, this was fixed on the fly the same day of the release but I guess you've re-downloaded the latest version :)

R1CO, this issue comes from the server, currently, I'm hosting Armaholic mirrors and Arma3.fr infrastructure, then, the server is often overloaded. I'll work on a solution as soon as I have some time to do so ;)

Share this post


Link to post
Share on other sites

Today I was able to perform an update with the community updater. Thanks for your awesome work! :)

Share this post


Link to post
Share on other sites
Sorry Tankbuster, I had not seen your message, this was fixed on the fly the same day of the release but I guess you've re-downloaded the latest version :)

I haven't but I will get it again this evening. Many thanks, Tom :)

Yep, looks much better now, thanks.

One further question, why does the community updater say that the server version of Poseidon is 'not available'?

Edited by Tankbuster

Share this post


Link to post
Share on other sites

You're welcome.

Regarding the community updater, it's because the installer of Poseidon is not handled (yet, one day... perhaps), it'll be downloaded if you populate your local depot, but not installed.

Share this post


Link to post
Share on other sites

280_e9a7d1447ff598e8.jpg

Poseidon 0.82 is out!

Change log:

WARNING: A fresh install is required because of some issues from the previous release.

  • Added: some data have been move to "%userprofile%\Documents\Poseidon Tools\", called PTDocs
  • Added: Hot backup feature (ALT+SHIFT+B). It creats a copy of the current file into PTDocs\Exports\ (each backup is unique)
  • Added: Export to HTML (ALT+SHIFT+P). The exported file is stored into PTDocs\Exports
  • Added: Properties for Arma configs (Sea, weather, latest additions etc...)
  • Added: Arma 3 new commands (version 1.39.129031)
  • Added: Arma 3 new functions (version 1.39.129031)
  • Added: Placeholder for user defined snippets
  • Changed: Recent Projects menu now contains the 15 last opened projects
  • Changed: Default syntax for .hpp files is now "CPP Arma" (instead of "ext format")
  • Changed: Updated version of FSM editor
  • Changed: Updated TexView 2 compiler
  • Tweaked: Regular expression used for Arma 3 Functions
  • Tweaked: Loading of some modules
  • Tweaked: Status bar information
  • Fixed: Missing "Do" in the ForSpec snippet
  • Fixed: Some snippets had an incorrect format
  • Fixed: "Step" in the ForVar snippet
  • Fixed: Some snippets were available from wrong file-types (e.g. basic CfgSounds from config files)
  • Removed: Links to the french documentation (because it's no longer available)

Full change log: http://tom4897.info/projects/poseidon-tools/changelog/

Known issues:

  • The installer will mark the version to install to 0.80, just ignore it.

Download:

Edited by tom_48_97

Share this post


Link to post
Share on other sites

Hy Tom,

Thank you for to work on sublime text2 (poseidon), this notepad is an essential tool for working files to the game Arma 3. I quote in almost all my tutorials created to help the Francophone community (you already knew ;)). Bye job well :p

Share this post


Link to post
Share on other sites

Hi Tom,

I use eliteness to build up my mission files. Can I do that from within Poseidon? I'm guessing it would live in the external programs menu or the BI tools menu?

Tanky -Paul-

Share this post


Link to post
Share on other sites

is it possible to get Poseidon working as a plugin within sublime text 3? found this on their website:

Sublime Text 3, while still technically in beta, is the recommended version of Sublime Text to use: compared to Sublime Text 2, it's faster, more polished, and of course, has a lot of extra functionality. Download it now and give it a try!

Share this post


Link to post
Share on other sites

Well, this is true and false (oxymoron power :ill:). Firstly, true because the language definitions are supposed to be working without any change, then false, simply because the ST2 engine uses Python 2.6 whereas the ST3 uses the version 3.3.

That said, there is something in the pipe... :yay:

Share this post


Link to post
Share on other sites

I just noticed that the new Documents folder is really %userprofile%\Documents instead of the folder that was set as Documents folder in windows. Although it's not a serious problem, it can be really confusing because the Poseidon Tools folder is nowhere to be found inside my documents folder :)

Edit: Maybe this causes my options to not be properly loaded as well? When I go to Preferences > Options it shows all the correct info, but when I use file header snippet it still shows the default info.

Edited by Adanteh

Share this post


Link to post
Share on other sites

That said, there is something in the pipe... :yay:

Excellent news. Can't code without this.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×