Jump to content
tpw

TPW MODS: enhanced realism and immersion for Arma 3 SP.

Recommended Posts

20 minutes ago, AtomKrieg said:

 

Thank you! 🙂 My problem isn't running the scenarios it's just that when deleting the mod I get that before mentioned error when launching ARMA and then the game closes. When I just disable the mod ARMA runs but the scripts still run when starting the scenario. Ambient animals and civvies still spawn and such. Zombies crouch and take cover. XD 

How did you install the mod? Using the included batch script? It sounds to me like there's some TPW MODS files somewhere else within your installation. Search for tpw_ in your file explorer.

Share this post


Link to post
Share on other sites
1 minute ago, tpw said:

How did you install the mod? Using the included batch script? It sounds to me like there's some TPW MODS files somewhere else within your installation. Search for tpw_ in your file explorer.

I downloaded it from Armaholic and used the .bat to install it..... Okay... After doing some digging the mod had somehow mixed in with my Crosscom mod? I have no idea how.. But after disabling that mod everything is working normally.

Share this post


Link to post
Share on other sites

I have a question for you you, @tpw, but I'm guessing this may be an Arma issue and not necessarily linked backed to TPW, specifically...

 

Some time ago (at least 6 months), when I start a mission in 3Den, I would get an error about "tpw_fireflies" not init'ing.  Fireflies would work fine, it would just happen as the mission loaded.  Fast-forward another couple of months, and I would start getting errors about "Skirmish" or "tpw_battle" (or something like that) not initializing at mission start.  Neither of those were actually used in the mission.  Now, after the last few updates, I'll get spammed at the beginning of a mission about how multiple parts of TPW are having initialization issues.  Then all the errors will stop and the mission works normally.  Many of the errors will be about options that aren't turned on in my config.

 

It seems like TPW is trying to initialize before...something...let's call it "Arma" is ready for them to initialize.  But the functions/scripts work fine once the mission loads all the other nonsense.  I know you had a timer/sleep in the past for things to load.  Was this timer reduced recently?  I'm running a pretty powerful processor/GPU combo, but I also tend to run a bunch of other scripts on loading (mostly JEBUS), so maybe resources are running low.  Regardless, figured I'd ask here.  At the end of the day, everything loads and works, I just get spammed at the beginning of the mission.  The spamming is still worth the awesome functionality, of course.

Share this post


Link to post
Share on other sites

Thanks for the report @gatordev. I very occasionally get an error thrown by my mods, and do my best to track it down. Believe it or not I do my best to release tpw mods bug free. I haven’t seen anything like you’re describing and would be keen to know if others do too so I can address it.  I’ll have a deep dive into the code today. I have changed nothing in the initialisation routines recently. Cheers mate

Share this post


Link to post
Share on other sites
15 hours ago, tpw said:

Thanks for the report @gatordev. I very occasionally get an error thrown by my mods, and do my best to track it down. Believe it or not I do my best to release tpw mods bug free. I haven’t seen anything like you’re describing and would be keen to know if others do too so I can address it.  I’ll have a deep dive into the code today. I have changed nothing in the initialisation routines recently. Cheers mate

 

Didn't mean for it to sound like you don't strive to kill bugs.  Hopefully it didn't come off that way.  I think you know I've been a long time fan.  Thanks for looking at it.  Again, it's possible something is interacting with how my missions init (which all init the same way).  I can look at testing with just a simple mission load and see.

Share this post


Link to post
Share on other sites

TPW:  I had to reset my sounds sources from 96 to 48 to reduce the lag.

 

Now the nocturnal animal sounds (wolves, owls, etc) now sound like they are sitting on my shoulder, it's so loud.  I didn't see a volume control for nocturnal animals.

 

Could you add one?

Share this post


Link to post
Share on other sites

I have a video of the mission coming out in a few hours for a demo of what I'm talking about. Maybe you can decipher what is going on.

Share this post


Link to post
Share on other sites
Posted (edited)

EDIT: sorry i'm a fool, was accidentally replying to a comment from march...

 

anyway, love the mod as always 😄

 

*shuffles back under rock

Edited by lordfrith
duh

Share this post


Link to post
Share on other sites
On 10/3/2019 at 5:39 PM, tpw said:

Thanks for the report @gatordev. I very occasionally get an error thrown by my mods, and do my best to track it down.

 

So I'm thinking this may be a performance issue within Arma and not something specific to TPW.  I can load a simple mission (only a couple of units) with the same init file and I don't get any error.  It seems to happen when there's a whole bunch of units which have to initialize on the mission start.  I'll keep an eye on it, but I'm not sure there's something specific for you to track down, now.

Share this post


Link to post
Share on other sites

Hi TPW,

 

after version 20190928, I found at least two problems.  You added a new animation for the wounded lying on the ground, but in this case:

 

1. If you approach the wounded and apply treatment, he will not be cured. He just keeps lying on the ground and continue writhes in pain

2. If he once fell to the ground and there is no medical assistance, then he will never die, since BLEEDOUT will not act on him. It looks like this animation will be endless.

 

Share this post


Link to post
Share on other sites
8 hours ago, mickeymen said:

Hi TPW,

 

after version 20190928, I found at least two problems.  You added a new animation for the wounded lying on the ground, but in this case:

 

1. If you approach the wounded and apply treatment, he will not be cured. He just keeps lying on the ground and continue writhes in pain

2. If he once fell to the ground and there is no medical assistance, then he will never die, since BLEEDOUT will not act on him. It looks like this animation will be endless.

 

Thanks Mick, I’ll look into it

  • Thanks 1

Share this post


Link to post
Share on other sites
On 10/26/2019 at 11:55 PM, tpw said:

Thanks Mick, I’ll look into it

 

On 10/26/2019 at 11:55 PM, tpw said:

2. If he once fell to the ground and there is no medical assistance, then he will never die, since BLEEDOUT will not act on him

 

TPW I also noticed that BLEEDOUT does not work with other/old wounded animations.

I see the soldiers falling on the ground, but they never die of blood loss! 

 

my settings of FLEEDOUT:

 

// BLEEDOUT
tpw_bleedout_active = 1; // 0 = inactive
tpw_bleedout_inc = 4; // unit damage will be increased by this % every 10 sec
tpw_bleedout_ithresh = 0.85; // damage beyond which a unit will writhe around incapacitated (1 = dead)
tpw_bleedout_heartbeat = 1; // Player heartbeat visible as slight screen shake (0 = no heartbeat shake)
tpw_bleedout_selfheal = 1; // AI units will automatically try to stop their own bleeding if equipped with First Aid Kits (0 = no self heal)
tpw_bleedout_affect = 1; // All injured units will have their speed and skill lowered according to the degree of injury (0 = units'  speed/skill unaffected by injury)
tpw_bleedout_geneva = 0; // Incapacitated units are set as non-combatants so that other AI will not fire on them (0 = incapacitated units can be fired upon by AI).

 

Please return the death of a soldier from blood loss

Share this post


Link to post
Share on other sites

Hi TPW,

 

Not sure I have messed something up or I missed an option but listed below is what I have done

1. Enabled Range function on the HUD ( via TPW_MODS.hpp )

2. Trialed it but decided was making things a bit to easy so went back into the TPW_MODS.hpp and disabled it

3. Went back in game and still can see the range, for some reason it hasn't disabled for me

4. Just for a trial, I added CROSSCOM version, it to now also has range enabled.

 

Is it possible that the setting has somehow locked in my Arma3profile?

 

Cheers

 

Edit: Looks like I fixed it, deleted the TPW_MODS userconfig folder and started from scratch and now range has gone.

Share this post


Link to post
Share on other sites
On 10/26/2019 at 11:55 PM, tpw said:

Thanks Mick, I’ll look into it

 

Hi TPW!

 

Unfortunately, I continue find new issuesin the BLEEDOUT module.

If my subordinate falls after a critical loss of blood, then he will not only never die, he will also not report a wound status.

 

 

 

The problem is that if fallen soldier is unconscious, then he should not speak and have motion/injured animations.  But as we see - he continues to give answers to commander requests, have injured animation movements, but not will report about injuries!  In this case the player-commander (in the heat of battle) may not see the subordinate lying on the ground and will continue to give him orders, not realizing that the subordinate cannot fulfill them. The subordinate will answer - "Ok, I'm doing" but it will be a hoax of game.

 

Expected behavior.

 
You need to decide. If ai-subordinate fell to the ground (heavy injured) , then he should either: 

 

a) be silent and without an animation of injured movement (because he is unconscious)

b) Or if he should have injured animation (which you recently added), then he must constantly report his status - "wounded, medic, etc"!  If you you also will add screams, it will be great!

In both cases, the player-commander will understand the situation with the wounded subordinate soldier, even if it is not in sight !

If subordinate is silent, then he is killed or unconscious
If subordinate does not respond to the commander’s requests and reports a wound/screams, then he is seriously injured. - It will be realistic and logical.

You only need to choose a simpler solution.

 

PS: It seems to me a simple unconscious state would be a simpler solution. But you added wound animations and it brought a lot of problems

 

 

Share this post


Link to post
Share on other sites

Lately I've been using TPW Mods while playing Hetman War Stories scenarios. I've occasionally grabbed a parked civilian truck spawned by TPW to use as transport for my squad but the trucks often (almost always!) despawn within a couple of hundred meters of where I took them from. When this happens, I'm either dropped where the despawn took place or teleported to the south-west corner of the map. The fate of my squad varies when this happens. I've had them just disappear and I've had them be just fine or killed or wounded. Is this intentional (the despawning) and are there any adjustments I can make to my hpp file to stop this from happening? I was thinking that it might be a problem with the scenario because I recall the despawning (but not the teleporting) vehicles happening before in a few missions (can't recall which ones but I think they were all dynamic missions, as is HWS) that I've played but I've only experienced TPW spawned vehicles despawning while playing HWS scenarios. I've also asked Rydgier (the creator of HWS) if he has any idea of what could be causing the issue but haven't heard back from him just yet. Any help or insight on the issue would be much appreciated.

Share this post


Link to post
Share on other sites

Hi guys. Sorry, I’ve had a couple of months off the tools.  I’ll look into the various issues

  • Like 9
  • Thanks 1

Share this post


Link to post
Share on other sites

Since a reminder is in order:

 

16) Report rule violations

If you see a violation of these rules on the board, do not reply in the thread but send a PM to a moderator or use the "Report Post" link (next to the date/time of post) instead. Replying in the thread will be considered as spam. Reporting posts contributes to a well structured, well disciplined forum which benefits everyone.

  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×