Jump to content
tpw

TPW MODS: enhanced realism and immersion for Arma 3 SP.

Recommended Posts

Hi ! I have installed your mod for my Patrol OPS but now nobody can walk, we can run and walk backward but walk forward it's not possible. Do you know how to fix ?

Share this post


Link to post
Share on other sites
Hi ! I have installed your mod for my Patrol OPS but now nobody can walk, we can run and walk backward but walk forward it's not possible. Do you know how to fix ?

As per the 1st post:

Copy @TPW_MODS\userconfig\TPW_MODS\TPW_MODS.hpp to \your_steam_location\steamapps\common\Arma 3\userconfig\TPW_MODS\TPW_MODS.hpp. You may need to create the your_steam_location\steamapps\common\Arma 3\userconfig\ directory if it does not already exist. Please be aware that installing TPW MODS using PlaysWithSix may sometimes place TPW_MODS.hpp into the incorrect location.

Share this post


Link to post
Share on other sites

OK thank, I use the manual install and my server directory is C:\arma3server. So if i create a C:\Steam\Steamapps\common\Arma 3\userconfig its work ?

Share this post


Link to post
Share on other sites

@LeXpLoSiF: Open TPW_MODS.hpp and at the end of the file get rid of the trailing '/' charachters in the "#define" lines. This is a bug caused by the first use of the GUI that will hopefully be corrected with the next tpw's update.

Yay!

Share this post


Link to post
Share on other sites

Would it be possible that units, both AI and players, can go unconscious and just lie where they fall instead of writhing on the ground? Maybe it could be another damage level that triggers the physx to drop them if they are hit hard enough or lose enough blood. They could then awaken after they are treated with a medkit like the other thresholds.

Would it also be possible to add a configurable surrender/retreat module as well? The AGM mod allows you to capture units, but only if you have handcuffs and are lucky enough to stun them or get close, and bCombat is the only AI mod I know of that has that function baked into it.

Thanks and Happy New Year!

Share this post


Link to post
Share on other sites

bCombat has the surrender feautures you're looking for.

Yay!

Share this post


Link to post
Share on other sites
bCombat has the surrender feautures you're looking for.

Yay!

Yes, but if I wanted surrender with a different AI mod or just Vanilla Arma AI, I am currently far out of luck, and it sounds like a TPW kind of feature up there with AI suppression or ambient civilians+cars that I can't live without now =)

Share this post


Link to post
Share on other sites

@tpw: Any chance you could lend me your mod's banner? I'd like to use it as a splash screen for the GUI.

Yes, but if I wanted surrender with a different AI mod or just Vanilla Arma AI, I am currently far out of luck, and it sounds like a TPW kind of feature up there with AI suppression or ambient civilians+cars that I can't live without now =)
As far as I know tpw itself won't meddle with AI too much to avoid conflicts with AI centered mods. Besides you can use bCombat and just disable everything but the surrender behaviour.

Yay!

Share this post


Link to post
Share on other sites

The curent version of this mod doesn´t seem to work with the new Blastcore. If I have TPW enabled certain effects, like the Particle effect of the HE shell from the Merkava, don´t work.

Share this post


Link to post
Share on other sites

Try enabling one module at a time to see which one interferes.

Yay!

Share this post


Link to post
Share on other sites

I tried disabling all of them and it still happens, must be something inside TPW core.

AT night the Rain FX doesn´t work properly, I get white blobs on the ground instead of the drop effect.

Share this post


Link to post
Share on other sites
I tried disabling all of them and it still happens, must be something inside TPW core.

AT night the Rain FX doesn´t work properly, I get white blobs on the ground instead of the drop effect.

Sounds like TPWMOD is inheriting some changes done by Blastcore. Also, you are not being able to actually disable the modules or they would be, well, disabled :). Make sure you're editing the right config file.

Share this post


Link to post
Share on other sites
Sounds like TPWMOD is inheriting some changes done by Blastcore. Also, you are not being able to actually disable the modules or they would be, well, disabled :). Make sure you're editing the right config file.

Not sure what you are trying to say. I disabled all feature modules in the config, however I still get that bug whenever I load up with TPW enabled.

Share this post


Link to post
Share on other sites

Yes it must be something in the core package then.

Meanwhile, instead of studying for my finals:

1zejnk7.png

Yay!

Edited by Gliptal

Share this post


Link to post
Share on other sites

For some reason any of the modules will work for me except for civilians... I doubt any of my mods would cause this but is anyone else having this problem? Is there any way to fix it?

Share this post


Link to post
Share on other sites

Make sure you're testing in an area with houses, since civilian spawning is tied to their presence.

Yay!

Share this post


Link to post
Share on other sites

I would certainly hope that it would spawn them in houses :\ So there is no problem about this that could be technical? It's just broken for me and there's no way to fix it? (Note: tpw civs does not show as one of the active tpw mods, it is activated in the userconfig)

Share this post


Link to post
Share on other sites
I would certainly hope that it would spawn them in houses :\ So there is no problem about this that could be technical? It's just broken for me and there's no way to fix it? (Note: tpw civs does not show as one of the active tpw mods, it is activated in the userconfig)

I had this same problem. I removed RDS civilian/vehicle addon and it seems to be working now, at least on middle eastern maps like Takistan... Not too sure about other maps though or why it quit working for us...

Share this post


Link to post
Share on other sites

Anyone getting an issue with the Civs? I turned debug on and there are no civs at the start (debug hint says "Civs:0 Houses:45). Every 10 seconds or so "Civs" will increase by 1 (so eventually it will reach a normal amount of civs). Is this normal behaviour or are they all meant to spawn at once?

Tried on Altis and Takistan. Mods running:

@AllInArmaTerrainPack

@TPW_MODS

Userconfig settings:

// CIVS
tpw_civ_active = 1; // 0 = inactive
tpw_civ_delay = 5; // delay (sec) until civ spawning starts
tpw_civ_radius = 150; // radius (m) around player to check for house and spawn civs
tpw_civ_waypoints = 15; // how many waypoints to assign each civ
tpw_civ_density = 1; // how many houses per civ. 0 = ambient civs disabled
tpw_civ_maxsquadcas  = 4; // maximum number of civilian casualties that can be inflicted by squad
tpw_civ_maxallcas  = 50; // maximum number of total civilian casualties 
tpw_civ_casdisplay = 0; // what to do if casualty threshold exceeded (0 -nothing, 1 - popup message, 2 - end mission) 
tpw_civ_maxciv = 50; // maximum number of civs to spawn regardless of tpw_civ_density
tpw_civ_interact = 15; // civilian interaction radius. Civs closer than this to other civs will stop and talk (0 - no interaction).
tpw_civ_nocombatspawn = 0; // civilians will not be spawned during combat. 0 = civilians continue to spawn during combat 
//><

Share this post


Link to post
Share on other sites
Anyone getting an issue with the Civs? I turned debug on and there are no civs at the start (debug hint says "Civs:0 Houses:45). Every 10 seconds or so "Civs" will increase by 1 (so eventually it will reach a normal amount of civs). Is this normal behaviour or are they all meant to spawn at once?

Tried on Altis and Takistan. Mods running:

@AllInArmaTerrainPack

@TPW_MODS

Userconfig settings:

// CIVS
tpw_civ_active = 1; // 0 = inactive
tpw_civ_delay = 5; // delay (sec) until civ spawning starts
tpw_civ_radius = 150; // radius (m) around player to check for house and spawn civs
tpw_civ_waypoints = 15; // how many waypoints to assign each civ
tpw_civ_density = 1; // how many houses per civ. 0 = ambient civs disabled
tpw_civ_maxsquadcas  = 4; // maximum number of civilian casualties that can be inflicted by squad
tpw_civ_maxallcas  = 50; // maximum number of total civilian casualties 
tpw_civ_casdisplay = 0; // what to do if casualty threshold exceeded (0 -nothing, 1 - popup message, 2 - end mission) 
tpw_civ_maxciv = 50; // maximum number of civs to spawn regardless of tpw_civ_density
tpw_civ_interact = 15; // civilian interaction radius. Civs closer than this to other civs will stop and talk (0 - no interaction).
tpw_civ_nocombatspawn = 0; // civilians will not be spawned during combat. 0 = civilians continue to spawn during combat 
//><

That is normal. There is a delay that you can set before any civs spawn and then they spawn one by one to save on resources and avoid lag.

Share this post


Link to post
Share on other sites
That is normal. There is a delay that you can set before any civs spawn and then they spawn one by one to save on resources and avoid lag.

Hmmm, ok. I was aware you could set a delay before the civ spawn starts (tpw_civ_delay), but the delay while the civs are spawning seems a bit too long. A small town would take nearly 10 minutes to populate - so when you arrive it's a ghost town, and while you're moving through you'll gradually notice an odd increase in civs that appear out of nowhere (literally), then when you leave it's somehow a fully populated town. It's a little bit of an immersion breaker tbh. Am I doing something wrong or should I just edit the script's delay manually?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×