Jump to content
tpw

TPW MODS: enhanced realism and immersion for Arma 3 SP.

Recommended Posts

New version frontpaged on the Armaholic homepage.

=================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites
Are there any plans to add RHF units to TPW_Skirmish?

You already can mate:

By script

0 = [5,2,5,2,500,2000,1,0,0,10,"_ocp_","rhsusf_","_msv_","rhs_"] execvm "\scripts\tpw_mods\tpw_skirmish.sqf"; // US vs Russia

By addon

// SKIRMISH

tpw_skirmish_active = 0; // 1 = inactive

tpw_skirmish_enemysquad_max = 5; // Maximum number of enemy squads around player

tpw_skirmish_enemyvehicles_max = 2; // Maximum number of enemy vehicles around player

tpw_skirmish_friendlysquad_max = 5; // Maximum number of friendly squads around player

tpw_skirmish_friendlyvehicles_max = 2; // Maximum number of friendly vehicles around player

tpw_skirmish_minspawnradius = 500; // Minimum distance from player to spawn units/vehicles

tpw_skirmish_maxspawnradius = 2000; // Maximum distance from player to spawn units/vehicles. Units/vehicles deleted beyond this distance

tpw_skirmish_support = 1; // NATO units can call support

tpw_skirmish_friendlytype = 0; // 0 = user defined, 1 = NATO, 2 = FIA, 3 = AAF,

tpw_skirmish_enemytype = 0; // 0 = user defined, 1 = CAF Aggressors (CAF_AG), 2 = CSAT, 3 = AAF, 4 = CSAT modification project (CMP) arid, 5 = CMP semiarid, 6 = CMP urban, 7 = ISIS (mixed CAF_AG with shemags), 8 = ISIS 2035 (CSAT + CAF_AG clothing + shemags)

tpw_skirmish_spawntime = 10; // Time (sec) between spawning each enemy/friendly squad/vehicle

tpw_skirmish_friendlyunitstring = "_ocp_"; // Custom string to select friendly units from config

tpw_skirmish_friendlyvehiclestring = "rhsusf_"; // Custom string to select friendly vehicles from config

tpw_skirmish_enemyunitstring = "_msv_"; // Custom string to select enemy units from config

tpw_skirmish_enemyvehiclestring = ""rhs_"; // Custom string to select enemy vehicles from config

//><

These settings will use US Army Woodland camo and MSV Russian infantry, and their respective vehicles.

Share this post


Link to post
Share on other sites
tpw_skirmish_friendlytype = 0; // 0 = user defined, 1 = NATO, 2 = FIA, 3 = AAF,

tpw_skirmish_enemytype = 0; // 0 = user defined, 1 = CAF Aggressors (CAF_AG), 2 = CSAT, 3 = AAF, 4 = CSAT modification project (CMP) arid, 5 = CMP semiarid, 6 = CMP urban, 7 = ISIS (mixed CAF_AG with shemags), 8 = ISIS 2035 (CSAT + CAF_AG clothing + shemags)

Oh, cool. I guess I was expecting to see the RHS units on this list.

Share this post


Link to post
Share on other sites

I'm not sure why, but CIVS isn't showing up in the list of activated mods whenever I start a mission. I'm going to test to see if it's actually active anyways, but I'm curious why it doesn't show up in the list even after I set it to be active in the userconfig file.

Share this post


Link to post
Share on other sites
I'm not sure why, but CIVS isn't showing up in the list of activated mods whenever I start a mission. I'm going to test to see if it's actually active anyways, but I'm curious why it doesn't show up in the list even after I set it to be active in the userconfig file.

Sometimes mods will fail to show up in the list when you start a mission, but they definitely are working. Not sure why this happens. The easy way to tell if the CIV mod is working is go to a town! Or you can type hint str count tpw_civs_civarray into the debug shell which will tell you how many civs are around.

Share this post


Link to post
Share on other sites

I just experienced a bug from an earlier version.

My offroad M2 gunner got knocked down wounded in the bed, but kept firing the gun while lying on his side.

Share this post


Link to post
Share on other sites
I just experienced a bug from an earlier version.

My offroad M2 gunner got knocked down wounded in the bed, but kept firing the gun while lying on his side.

Well spotted. I'll look into this ASAP.

EDIT: TPW FALL has a check to prevent units in vehicles (including gunners) from dropping. TPW BLEEDOUT could conceivably cause injured units to writhe around in the back of a truck whilst still firing a gun. I have added in the same condition checks as TPW FALL and will test to see if this improves the situation.

Edited by tpw

Share this post


Link to post
Share on other sites

I don't know if TPW FALL is responsible for this, but when I shot an enemy who was not wearing any headgear, as he fell he suddenly sprouted a hat. Is this part of the fall animation?

Share this post


Link to post
Share on other sites
I don't know if TPW FALL is responsible for this, but when I shot an enemy who was not wearing any headgear, as he fell he suddenly sprouted a hat. Is this part of the fall animation?

I don't know about that, but it sounds funny as hell. Could we customize the type of hat? :)

Share this post


Link to post
Share on other sites

that is because of tpw fall..

If i remember correctly up to a certain distance tpw_fall uses a script like zooloo's "Ragdoll'd". Where in it an object hits the AI and knocked them down simulating a bullet ragdolling an AI...

And outside of that distance (i believe its 100m) tpw has set it up so it uses the old method of Ragdoll.. where in the script he sets the original AI invisible.. and spawns another in its place and kills it... causing a ragdoll... then removing the dead body and replacing it with the previously unit made invisible....

so what your seeing is that new ai being created in the place of the other one that is now invisible... that AI has all his original Gear.. not the same gear as the unit you just shot...

Share this post


Link to post
Share on other sites

Thanks LP, that's exactly it. The replacement unit should get the same outfit as the shot one, I'll have to look into it further.

Share this post


Link to post
Share on other sites

Any chance we could get a on/off key press to display a wind direction arrow (for throwing smoke grenades)?

Share this post


Link to post
Share on other sites

I haven't tested the entire bevvy of US helicopters yet, but the RHS UH60 is getting Russian radio traffic, interestingly! Might bear investigation.

Share this post


Link to post
Share on other sites

I'd like to modify the fall script to only allow player falls when getting shot, not for drops from a height. This is for compatibility with other mods and is just for myself - I wouldn't release it.

I can't actually figure out how to do it though. As far as I can determine, the change would need to be made in tpw_fall_fnc_hitproc (or possibly tpw_fall_fnc_fallproc), but I can't get any farther than that. Is there a way to make this change?

Edited by SSD

Share this post


Link to post
Share on other sites
tpw_fall_sensitivity = 100; // sensitivity of unit to falls (%). 50 = unit half as likely to fall over from a given height.

Just change this value to 0 or 1 or 0.000001 or something.

That should be much easier.

Share this post


Link to post
Share on other sites

that seems to have worked nicely, thanks

Share this post


Link to post
Share on other sites

TPW MODS 20141123: https://dl.dropboxusercontent.com/u/481663/TPW_MODS_20141123.zip

Changes:

[bLEEDOUT 1.17] No writhing fx if units are in vehicles

[RADIO 1.18] Fixed Russian radio protocol in US helicopters when using RHS Russians.


Thanks CMcD for the heads up about the Russian radio protocol in US choppers. Turns out helicopters are the only US vehicles that don't have RHSUSF in their classname.

Share this post


Link to post
Share on other sites

New version frontpaged on the Armaholic homepage.

=================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Any chance to return the size of the raindrops to the previous size they had before the version where you corrected the particles not showing up in trucks? I can barely notice them in current version. If not, could you post the previous parameters so I can use those for myself? I don't have any previous version to look at those values. I happen to drive a lot in my missions, and like the rain a lot, so to me that feature of your mod is very important, but with the current size it's almost gone. Anything you could do to help me get the old values will be greatly appreciated.

Share this post


Link to post
Share on other sites
Any chance to return the size of the raindrops to the previous size they had before the version where you corrected the particles not showing up in trucks? I can barely notice them in current version. If not, could you post the previous parameters so I can use those for myself? I don't have any previous version to look at those values. I happen to drive a lot in my missions, and like the rain a lot, so to me that feature of your mod is very important, but with the current size it's almost gone. Anything you could do to help me get the old values will be greatly appreciated.

Hi seba1976

I haven't actually changed the size of the droplets, only the distance around the car that they spawn. Basically when you're on foot the droplets spawn in a 2x2x2m box, when in a car it's a 5x5x5m box. Depending on the car (as you pointed out) and where it sits in relation to the box, you might only see the more distant drops, which will look smaller. The parameter is _dst, have a look in the code below:

// RAIN DROPS ON VEHICLE WINDOWS AND PLAYER GOGGLES

tpw_rain_fnc_raindrops =

{

private ["_int","_rainemitter","_drop","_lt","_sz","_dst"];

if (alive player && cameraview == "internal") then

{

_drop = false;

if (

vehicle player == player && // player on foot

{goggles player !=""} && // wearing goggles

{!tpw_rain_cover} && // not under cover

{!(underwater player)} && // not underwater

{(positionCameraToWorld [0,0,1] select 2) > ((positionCameraToWorld [0,0,0] select 2) -0.2) || speed player > 5} // either not looking down or running

) then

{

_int = 0.01 / rain; // more drops if heavier rain

_lt = 0.05; // droplet lifetime

_sz = 0.3; // drop size

_dst = 2; // max spawn distance

_drop = true; // drops only if not under cover

} else

{

// Player in car (not tank, boat, heli etc).

if (vehicle player iskindof "car_f") then

{

_int = 0.0001 / rain;

_sz = rain * 0.1; // heavier rain = bigger drops

_dst = 5;

if (speed player > 10) then

{

_int = _int / (speed player / 10); // more drops if moving

};

_lt = 0.05;

_drop = true;

};

};

// Display drops

if (_drop) then

{

_rainemitter = "#particlesource" createVehicleLocal getpos player;

_rainemitter setParticleCircle [0.0, [0, 0, 0]];

_rainemitter setParticleRandom [0, [_dst,_dst,_dst], [0, 0, 0], 0, 0.01, [0, 0, 0, 0.1], 0, 0];

_rainemitter setParticleParams

[["\A3\data_f\ParticleEffects\Universal\Refract",1,0,1],

"",

"Billboard", 1,_lt, [0,0,0], [0,0,0], 1, 1000, 0.000, 1.7,[_sz],[[1,1,1,1]],[0,1], 0.2, 1.2, "", "", vehicle player];

_rainemitter setDropInterval _int;

_rainemitter attachto [vehicle player,[0,0,0]];

sleep 1;

deletevehicle _rainemitter;

};

};

};

Share this post


Link to post
Share on other sites

tpw,

Initially posted this over in the Dev Branch section but figured out the issue went away when I didn't load your (fantastic) addon...

I haven't been able to play Arma3 for the last two weeks, so last night was my first time with Dev Branch in a while. Is anyone else having issues with AI starting off a mission in a stuck animation? They don't move/fidget/etc unless they see the enemy or get blown over by a grenade. I've also managed to get stuck when raising and lowering my rifle a couple of times quickly. Here's a pic of the issue (this is at mission start and not a capture of everyone walking):

http://steamcommunity.com/profiles/76561197968612487/screenshot/45362999603257063

AI is almost unresponsive when they are assigned to HC. It also prevents me from slow walking (SHIFT-W) while standing or walking forward while leaned left or right. I have the animation coefficient option in the config turned OFF (0), which is how I normally played in the past without this issue.

I know you can't always fix every issue that comes up in Dev Branch, but thought I'd ask to see if anyone else is having the same issue since it might matter in the next stable update.

Share this post


Link to post
Share on other sites
tpw,

Initially posted this over in the Dev Branch section but figured out the issue went away when I didn't load your (fantastic) addon...

I haven't been able to play Arma3 for the last two weeks, so last night was my first time with Dev Branch in a while. Is anyone else having issues with AI starting off a mission in a stuck animation? They don't move/fidget/etc unless they see the enemy or get blown over by a grenade. I've also managed to get stuck when raising and lowering my rifle a couple of times quickly. Here's a pic of the issue (this is at mission start and not a capture of everyone walking):

http://steamcommunity.com/profiles/76561197968612487/screenshot/45362999603257063

AI is almost unresponsive when they are assigned to HC. It also prevents me from slow walking (SHIFT-W) while standing or walking forward while leaned left or right. I have the animation coefficient option in the config turned OFF (0), which is how I normally played in the past without this issue.

I know you can't always fix every issue that comes up in Dev Branch, but thought I'd ask to see if anyone else is having the same issue since it might matter in the next stable update.

Hi Gatordev, thanks for the kind words and the heads up. I'm having no such problems using dev builds. In fact what you describe to me sounds like a common problem wherein people update to the latest TPW MODS and for whatever reason don't update their tpw_mods.hpp correctly (PW6 often seems to be a culprit). Later versions of TPW MODS actually modify (lower) the walk speeds and if your hpp is wrong it'll assign 0 to these speeds, which will result in stuck units. Please download the latest TPW MODS and manually install it and its hpp, and see if that fixes your problem.

EDIT: rereading your post, there is no way to turn off the animation speed changes other than to set them to their defaults, or to remove animspeed.pbo from @TPW_MODS.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×