Jump to content
Sign in to follow this  
GregP

Why do I keep losing control of my AI squad?

Recommended Posts

This may be a dumb question, as I'm fairly new to ARMA3, but I can't figure out why I keep losing control of my AI squad. After some indeterminate time in a scenario, I can no longer communicate with my squadmates nor do they show up on the ShackTac HUD. They're still there, but I can't give them orders. Is radio damage modeled, and maybe my radio is being taken out in firefights, thus preventing me from controlling my squad? If so, I would think I could see some kind of indication in my inventory screen that the radio is non-functional, but I don't.

Somewhat related -- anybody know what function has been bound to 'backspace'? What I mean is, I know it calls up complex commands, but how can I remap that to other key? I don't see any commands in the UI that seem to control this function.

Share this post


Link to post
Share on other sites

100 views and no comments? Is this such an appallingly dumb question that no one wants to stoop low enough to answer? :)

Or is this something that nobody else is experiencing?

Share this post


Link to post
Share on other sites

Are you sure that you are no longer in the squad, or that you are no longer in command? I have seen AI take command of the squad from you if they have a higher rank. I seems random when they decide to do it. Also the radio cannot be damaged.

Regarding backspace, it does not show any conflicts when mapped to something in the control menu, so it seems like a permanent binding. I also cannot remap 0-9.

Share this post


Link to post
Share on other sites

I see this too sometimes. All squad members who used to respond stop responding to orders, or when you give them a command (like "Attack Squad Leader" or "Move West 200 m" via the map). I think if you do "Switch to unit #" and then back "Switch to leader", it comes back (or maybe after the AI squad leader issues a command). I generally consider the AI squad members to be useless cannon fodder anyway, unless they posses specialized skills/roles - engineer, medic, AT etc. that you can "Switch to".

Share this post


Link to post
Share on other sites

It happens a lot. I usually find I have to switch to each guy in the squad and control them for a second, and then, once I return to the team/squad leader, I order regroup and all is right in the world. At least until the next bush one of them gets stuck in. LOL.

Share this post


Link to post
Share on other sites

That is some pretty odd behavior. The only things I can think that would cause it are:

A) Your squad mates are dead, and your unit hasn't seen them yet (think's they're still alive).

B) Some sort of mod is causing this behavior. I know for instance the Firefight Enhancement Mod attempts to emulate confusion, shock, and panic by having AI group members temporarily drop out and rejoin your group.

C) Losing control of your group is scripted in the mission you're playing.

Share this post


Link to post
Share on other sites

the problem is definitly on your side. i never encountered that problem, not even in the more bugged arma 2. im pretty sure mods causing that issue.thats why i play without mods and try to avoid hard scripts, often they break more then they fix.

Share this post


Link to post
Share on other sites
I can't figure out why I keep losing control of my AI squad. They're still there, but I can't give them orders.

Can you call them back or get them to report their status? Do they respond in Any way? "No can do" or "Negative" and so on.. or complete silence?

And the highest rank guy is normally always the leader, if you are the leader, AI should take over the leadership only if you start shooting your own fellows.

Edited by Azzur33

Share this post


Link to post
Share on other sites

Hmmm ... perhaps it IS the Firefight Enhancement Mod, as I am using that one. And when I say I lose control of them, I mean other than seeing them right next to me, I have no menu options to communicate with them: there are no unit icons at lower left, my ShackTac HUD disappears completely, and all the radio command menus that would normally let me communicate with them are grayed out.

Share this post


Link to post
Share on other sites

^^ it is very possible since one of the routines the mod resorts to is to temporarily remove the unit from the group.

try setting the

SS_FFIS_LOSECOMMAND = false;	//Set to false to disable panicking AI from leaving the group (May result in loss of panic functionality).

in the "\userConfig\zooloo75\FFIS.hpp" file

Share this post


Link to post
Share on other sites

I use CBA mod ... maybe thats it or its an obsolete version. I especially like the shout of "We've lost one!" by the last surviving squad member (ala Duffman) as he dies.

Share this post


Link to post
Share on other sites
^^ it is very possible since one of the routines the mod resorts to is to temporarily remove the unit from the group.

try setting the

SS_FFIS_LOSECOMMAND = false;    //Set to false to disable panicking AI from leaving the group (May result in loss of panic functionality).

in the "\userConfig\zooloo75\FFIS.hpp" file

Maybe the userconfig is deprecated because I already have that set to false and I still lose guys from time to time. Could be the Waypoints in the he also has in the config -I'll check it later

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×