Jump to content
Sign in to follow this  
PSYKO_nz

stop items being effected by Physics and gravity

Recommended Posts

hey there well the sea fort is coming along nicely how ever were having problems with a few things, we want to use containers as part of the structure how ever there effected by the game Physics and gravity etc

is there any way to turn it off so it becomes a rigid place able thing like it was in arma 2?

it would make this whole undertaking a lot easer!

thanks in advance

oh heres a wip pic of the forts

Share this post


Link to post
Share on other sites

worked perfect, thank you so much, now next question any way to spawn a sub with the scope down?

Share this post


Link to post
Share on other sites

awesome, your a legend! thank you so much!!

---------- Post added at 03:02 PM ---------- Previous post was at 01:41 PM ----------

ok next problem, sorry for being a pain in the ass, is there any way to set the spawn depth of the sub? I set it to be 5 meters under the water but it keeps floating up to just under the surface

---------- Post added at 04:05 PM ---------- Previous post was at 03:02 PM ----------

heres the armaholic wip for it

http://www.armaholic.com/forums.php?m=posts&q=24097

Share this post


Link to post
Share on other sites
ok next problem, sorry for being a pain in the ass, is there any way to set the spawn depth of the sub? I set it to be 5 meters under the water but it keeps floating up to just under the surface

How are you spawning the subs? I tried placing one in the editor and setting the elevation to -5 meters; it seemed to work fine. I assume the subs have no one in them, if so they should not move. If there are AI in the subs, you could try this:

http://community.bistudio.com/wiki/swimInDepth

Share this post


Link to post
Share on other sites

I can seem to post a new thread so I'm just going to ask here, I'm making a base with shipping containers http://images.akamai.steamusercontent . com/ugc/37498833644063584/C1DD5DCEEB38377ACE8A4AE5ABBEEA0A67AA3494/ (remove the spaces in the . com)but every time i play the mission in editor all of the shipping containers go flying because of the physics, I was wondering how do I switch it off?

I have tried to add enableSimulation like:

        class Item30
       {
            position[]={21747.2,-0.248642,11471.5};
            azimut=343.636;
            id=31;
            side= "EMPTY";
            vehicle="Land_LampAirport_F";
            skill=0.6;
            offsetY=5.78696;
            object enableSimulation false;
       };

but then the mission won't even open and my arma crashes, could someone help?

Share this post


Link to post
Share on other sites

@Austin: I didn't know "wrongness" could be scaled, but that must be the most wrong way to mod I've ever seen :D .

Don't put script stuff inside the mission.sqm.

Put "this enablesimulation false" inside the vehicle/object's initialization field in the editor.

Share this post


Link to post
Share on other sites
@Austin: I didn't know "wrongness" could be scaled, but that must be the most wrong way to mod I've ever seen :D .

Don't put script stuff inside the mission.sqm.

Put "this enablesimulation false" inside the vehicle/object's initialization field in the editor.

Hey look I'm new to all of this so bare with me :yay:

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×