Jump to content
Logitrust

ArmA 3 stops recognizing joystick as controller

Recommended Posts

Created issue on bugtrack. Vote please

Arma 3 Feedback Tracker

And it would be really great if author can edit first post to attach link there.

There is already a ticket: http://feedback.arma3.com/view.php?id=14924

EDIT: Well, I see you have commented on it as well. It's better to have one ticket for the problem, especially given devs are aware of it and it has >200 votes.

Edited by DarkWanderer

Share this post


Link to post
Share on other sites

Bottom line there is no simple fix.  I have the X55, combat rudders and Trick IR 5.  Anyone with a real solution please share other than Open the registry  . I did that once and never again.

 

 

 

Wingnut

Share this post


Link to post
Share on other sites

Same here. Having the same problem with my Saitek  X52 pro joystick and windows 8.1 and Arma 3. Anyone switched to windows 10 to see if that helps?

 

Update. I have just installed windows 10 today. Then reinstalled the latest drivers for my x52 pro followed by playing Arma 3 with my saitek X52 pro for several hours with no issues. Looks like windows 10 resolved the problem. :)

Share this post


Link to post
Share on other sites

Same here. Having the same problem with my Saitek  X52 pro joystick and windows 8.1 and Arma 3. Anyone switched to windows 10 to see if that helps?

 

Update. I have just installed windows 10 today. Then reinstalled the latest drivers for my x52 pro followed by playing Arma 3 with my saitek X52 pro for several hours with no issues. Looks like windows 10 resolved the problem. :)

 

Can anyone reinforce that this is indeed the case? I'd like to know if Windows 10 makes a difference before buying a stick and pedals

 

Cheers

Share this post


Link to post
Share on other sites

Still a problem for me after all this time, can't believe this has not been fixed. Xbox controller F.l.y. 5 and X52 all disconnect when trying to change a control setting. Win 8.1 and Win 7. Such a pain.

Share this post


Link to post
Share on other sites
Guest Interinactive

Sigh

 

What area of this game isn't plagued with issues?

 

I bought a Thrustmaster Warthog 2 months ago and it's been fine. Up until tonight.

 

I can still bind buttons in game, but nothing happens when I go into the game itself, the game simply doesn't recognise my controls. Nothing changed since the last time I played. No new mods or anything. FFS.

Share this post


Link to post
Share on other sites

i have also the problem, throttle of my x-55 works all the time, but the stick doesn´t. i would be happy to use my stick also in arma.

i also have trackir5.

 

please look into this, we really need a fix !

Share this post


Link to post
Share on other sites

Hey guys,

So here is my problem. I hate flying in ARMA with a mouse so i bought a thrustmaster HOTAS 4 to make flying better right. I notice on the box it says for PS4 but also compatable with PC. SOOOO, i get it home thinking it will work fine right? WRONG. I plug it in and it shows up in the controller screen. I am able to map the cyclic right, left, forward, and back. However the peddals and throttle will not respond to any re-mapping, or even in the  calibration menus. all other buttons and functions work, with exception to the throttle and rudders. Anyone elses have this problem? And is it something on my end or something bigger?

Thanks in advance.

Share this post


Link to post
Share on other sites

Still happening with my x52, windows 10 on the 64x client

Share this post


Link to post
Share on other sites

Had it happen to me three weeks ago and still haven't found a solution. I can confirm that my setup (Warthog HOTAS + MFG pedals) works perfectly fine in every other game but Arma 3 refuses to see them anymore. They don't even populate the JoysticksList in my Arma3Profile file anymore.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×