Jump to content
major_shepard

ArmA3Sync - launcher and addons synchronization software for ArmA 3

Recommended Posts

12 hours ago, al Hassan said:

Hello. Possible stupid question but here goes... I have mods installed via A3 Launcher so if I install A3Sync will A3Sync redownload them or can it find them from my HD?

 

Cheers

 

Workshop mods can be found within arma3\!Workshop folder which is an hidden folder. Just add this folder path into ArmA3Sync addon search directory.

Share this post


Link to post
Share on other sites

Hi, I was wondering if this project is open source? I was not successful in finding a git repo.

The main reason I am asking is because the launchers requires Java 7 to run and the .exe won't launch it otherwise. Going around the .exe and running it directly from the command line using other versions of java (tested mainly OpenJDK 11.0.9) works just fine.

Would it be possible to remove this limitation in the future, or is there a reason why this was implemented? AFAIK there should be no problem running it on newer JVMs.

Tested on:
openjdk 11.0.9 2020-10-20
OpenJDK Runtime Environment AdoptOpenJDK (build 11.0.9+11)

Edit: Found the SVN repo.

Share this post


Link to post
Share on other sites

The .exe file looks for available JRE/JDK in the Windows registry. If it does not found one you get the error message.

If you installed Java manually from unzipped archive, the registry is not updated and you get the error message.

The alternative way would be to embed the Windows JRE inside the application and tell the .exe where to look for the JRE folder.

Share this post


Link to post
Share on other sites

That might be it.
As I am required to change between JDK8 and JDK11 often, I am only using Environmental Variables, I do not have java related paths in registry.

Thanks for the clarfication.

Share this post


Link to post
Share on other sites

Apparently all the Downloadlinks are broken?

I need the arma3sync-console.sh version. FTP Links dont seem to work anymore

Share this post


Link to post
Share on other sites

Its a blank page for me with nothing loading.

Thanks foir the quick answer! apparently its on my end!

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×