Jump to content
major_shepard

ArmA3Sync - launcher and addons synchronization software for ArmA 3

Recommended Posts

No plan for Http.

You can connect to a ftp server with login and password with ArmA3Sync.

ftp and http servers can perfectly use the same url as long as the port is different (21 by defaut for ftp, 8080 by default for http).

If I understood correctly you can connect to a ftp server with login and password but you must have an anonymous ftp access in order to have autoconfig url to work ? I think it would be easier to set up with autoconfig url through http, less setup with an existing private ftp on admin side.

I also think you must clearly indicate in your wiki that the field "Public auto-config url" is actually meant to be used with a public ftp adress, I didn't catch that immediatly.

Despite that this is a nice tool, thank you for that.

Share this post


Link to post
Share on other sites
= Memphis007;2534773']If I understood correctly you can connect to a ftp server with login and password but you must have an anonymous ftp access in order to have autoconfig url to work ?

Exactly.

The aim of autoconfig url is to make it simple in the case you want to largely distribute access to your repository.

For example if you want organize some big game with several teams invited.

Now if you want your repository stay private use Help -> Autoconfig -> Export. It will generate and encrypted file with your repository informations that you can give to your guys whatever the manner.

Or you simply login by providing the informations (the name of the repository you give has no matter).

= Memphis007;2534773']

I think it would be easier to set up with autoconfig url through http' date=' less setup with an existing private ftp on admin side.

[/quote']

Not sure to understand. Http/ftp is the same problematic.

= Memphis007;2534773']

Despite that this is a nice tool' date=' thank you for that.[/quote']

Thanks ;)

Share this post


Link to post
Share on other sites
The aim of autoconfig url is to make it simple in the case you want to largely distribute access to your repository.

For example if you want organize some big game with several teams invited.

Now if you want your repository stay private use Help -> Autoconfig -> Export. It will generate and encrypted file with your repository informations that you can give to your guys whatever the manner.

Or you simply login by providing the informations (the name of the repository you give has no matter).

Not sure to understand. Http/ftp is the same problematic.

I have a private ftp set up for the team which is entirely private, and i won't set up any public anonymous access. But I have a webserver which can be used to access the autoconfig file. So for me it is easier to retrieve the autoconfig from my webserver rather than via ftp (like Yoma AddonSync does).

I know you can setup things manually or export the Autoconfig file but it seems less complicated userside to provide autoconfig url via http.

Edited by =[TTK]= Memphis007

Share this post


Link to post
Share on other sites

ok I see. I will try to see about it for the next version.

Now there is plan regarding ArmA3Sync for http with ZSync for the repository hosting. No promise for when it will come out ^^

Share this post


Link to post
Share on other sites

With the AiA Tweaker, it had my ToH path in the Arma1 line (I don't have ArmA1) and there's no way to delete this line, all I can do is change it to somewhere else, like My Documents.

I've put the ToH path in the correct place now but it still shows @AllinArma "Not Found", even though I do have this folder in my A3 folder (installed by PwS).

Share this post


Link to post
Share on other sites

I may be wrong but it looks like when I choose the AiA drop down before I run All in Arma 3; it's not loading all of the right AiA addons it needs to.

According to the AiA forum, it needs to load @A2OAPondFix

I can't see that being referenced in the ArmaSync Run Parameters ?

SJ

Share this post


Link to post
Share on other sites

They seem to have add @A2OAPondFix recently. Will fix it into next update.

I have tried the last 2013-11-04 update of @AllinArmA, ArmA3Sync detected it with no trouble.

Share this post


Link to post
Share on other sites

Thanks Major S.. I realised after posting that you can manually bring the @A2OAPondFix mod across, as you suggested. And if it can be added to run it as the rest of the AiA components, it would keeps the AiA implementation nice and neat.

SJ

p.s. how's LEA coming.... :P

Share this post


Link to post
Share on other sites

ArmA3Sync 1.1 Update 3

Download

Use Check for Updates in the Help menu

Changelog

- Added: AiA Tweaker: run parameter @A2OAPondFix was missing since last update of @AllInArmA.

- Fixed: AiA Tweaker: TOH path wrongly initialized.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

New release frontpaged on the Armaholic homepage.

===================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

** Note: since this is a project on which more people are working we will contact you in the future to discuss how you want this to be setup on Armaholic.

Share this post


Link to post
Share on other sites

Hi All

This is great, I loved this launcher for Arma 2 and was hoping it would be released for Arma 3. I love the idea that your adding the syncing to it so everything is in one app not having to have 6 updater as well as a launcher.

My problem is as some others have had, not being able to add groups to the addon groups window. If i right click or use the menu i get no group so acyually can't use the launcher. I'm running a fresh install of Windows 7 Ultimate 64-bit and have installed the latest java version.

C:\Program Files (x86)\ArmA3Sync>java -version

java version "1.7.0"

Java SE Runtime Environment (build 1.7.0-b147)

Java HotSpot 64-Bit Server VM (build 21.0-b17, mixed mode)

If i try to run the ArmA3Sync.bat i get an ArmA3Sync dialog box saying "ArmA3Sync is already running" and the following in a command window...

DevMode=false

Unable to create and/or lock file: lock

If i right click the batch file and run as administrator i get...

Error: Unable to access jarfile ArmA3Sync.jar

Press any key to continue . . .

If i run a command prompt as administrator and run the line from the ArmA3Sync.bat file in it i.e. "java -Djava.net.preferIPv4Stack=true -Xms256m -Xmx256m -XX:-HeapDumpOnOutOfMemoryError -XX:HeapDumpPath="/" -XX:+ShowMessageBoxOnError -Dsun.java2d.d3d=false -jar ArmA3Sync.jar" it runs Arma3Sync and I get the following in the command prompt...

C:\Program Files (x86)\ArmA3Sync>java -Djava.net.preferIPv4Stack=true -Xms256m -Xmx256m -XX:-HeapDumpOnOutOfMemoryError -XX:HeapDumpPath="/" -XX:+ShowMessageBox OnError -Dsun.java2d.d3d=false -jar ArmA3Sync.jar

DevMode=false

Connection updates repository Success

Update version = 1.1.26

If i then try to create a new group in the addon group section i see nothing added to the command prompt window, in fact the only time i see anything else is if i click the check event button in the repository (I don't have any repository details to add at the moment, i just want the launcher at the moment). When i close ArmA3Sync the command prompt is released.

I have tried uninstalling Java and re-installing it and i have tried both the 32 and 64 bit versions.

Any ideas or suggestions what could be the problem?

Regards

Ian

EDIT: After uninstalling all versions of Java and cleaning the registry i ran the ArmA3Sync app and it told me i needed Java installed and it loaded a page where i could install Java, so i installed Java again. This time ArmA3Sync worked and on checking it had only installed the 32-bit version of Java, I have since put the 64-bit version back on and it continues to work, I'm not exactly sure what solved the problem, maybe it's putting the 32-bit version on first but it now seems to be OK.

Edited by Ian-C

Share this post


Link to post
Share on other sites

Try installing the last update of Java with is 1.7.045 => http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html

Also kill any remining javaw.exe procees in the Windows task manager.

I suspect they made some mess stuff with early version of Java 7.

In next update I will block ArmA3Sync from running if Java version installed is before 1.7.025.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Major, here I am again with another idea. Someone is talking about syncing arma 3 missions over http, ftp, etc ( feedback arma3 , etc ) in order not to stress the server expecially when JIP.

Do you think this would be a cool feature for arma3sync? Sync all server missions with client in orde to prevent when JIP or join the server to send the mission with arma to every player?

Share this post


Link to post
Share on other sites

JIP does not only depends on downloading the misson from the server but also broadcasting data to all players computer's. I meant it won't completly resolve the issue with the JIP.

Now I would see the thing like this:

1. Into ArmA3Sync, the user select a server from the Join Server combo box

2. Player starts the game with ArmA3Sync.

3. ArmA3Sync download the mission to AppData

4 The game is started an it automatically join the server.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

My launcher doesnt save changes for my profile anymore (adding mods) when it used to. Ive tried creating a new backup profile with my new settings in it but that got deleted too. Basically Im losing my changes when I restart the computer. Any ideas?

Share this post


Link to post
Share on other sites

Profiles are stored into "profiles" folder of ArmA3Sync installation. Try this:

1. Create a new Profile named "A" (menu Profiles -> Edit)

2. Add groups and drag and drop addons into it

3. Close ArmA3Sync

4. Go to "profiles" folder of ArmA3Sync installation and check that A.a3s.profile is there.

5. Start ArmA3Sync and open A profile. Check everything is ok.

6. Close ArmA3Sync and restart your computer.

7. Go to "profiles" folder of ArmA3Sync installation and check that A.a3s.profile is there.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

ArmA3Sync 1.1 Update 4

Download

Use Check for Updates in the Help menu

Changelog

- Added: Task Force Arrowhead Radio installer wizard.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Thanks for informing us about the updated release :cool:

New release frontpaged on the Armaholic homepage.

===================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

** Note: since this is a project on which more people are working we will contact you in the future to discuss how you want this to be setup on Armaholic.

Edited by Foxhound

Share this post


Link to post
Share on other sites
ArmA3Sync 1.1 Update 4

Download

Use Check for Updates in the Help menu

Changelog

- Added: Task Force Arrowhead Radio installer wizard.

I just used the auto updater to install this update and now all my add-on groups seem to be gone and I can't add new ones, either by right-clicking or using the menu. I'm on Windows 7 64-bit. Any ideas?

Share this post


Link to post
Share on other sites

Hi Major - thanks for the reply. I'm already using the latest version of Java (Version 7 Update 45).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×