Jump to content
major_shepard

ArmA3Sync - launcher and addons synchronization software for ArmA 3

Recommended Posts

One tip:

When you launch arma3sync and it tells XXX repo has been updated, ecc... Why you don't put another icon: UPDATE and OK.

I tell you this because: select ok, going into repository, click check for addons, select addons, select play.. During all this steps someone, expecially less skilled with pc, sometimes missed something, maybe don't select all the addons, maybe they hit the wrong button, etc. If a repo it's updated and you want to play on a server you have to update, right? So why don't make this more easy.

In this way who isn't skilled or don't want to see what mod and pbo is changed simply click UPDATE when arma3sync tell that there's an update and the update start with all the things changed; instead the other one that want to check what's changed, etc is able to do all the steps he do now.

What do you think?

:rolleyes:

Share this post


Link to post
Share on other sites

Yes that's interesting, I will ty to add it into next version ^^

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Hi there! I have a problem with running that programm- cant add group for addons. I press Add group buttom and there is nothing created. What Im doing wrong? Thanks/

Share this post


Link to post
Share on other sites
Hi there! I have a problem with running that programm- cant add group for addons. I press Add group buttom and there is nothing created. What Im doing wrong? Thanks/

Delete old version(s) of java 32 and 64 bit, then redownload newer versions 32 and 64 bit ( is you have 64 bit ) http://www.java.com/it/download/manual.jsp

Share this post


Link to post
Share on other sites
Hi there! I have a problem with running that programm- cant add group for addons. I press Add group buttom and there is nothing created. What Im doing wrong? Thanks/

There is 2 ways to add a group:

- right click into Addon Groups panel

- or select Menu Groups -> Add group

Does both of them fail?

This issue has been reported by a couple of yours we have never been able to reproduce.

I would be very interested if you could do this:

1. Run ArmA3Sync.bat file witch is inside the ArmA3Sync installation directory.

2. Try to add a group.

3. Look into the console and tell me what it is displayed (copy/paste the content)

If ArmA3Sync.bat doesn't start, you will need to add Java to the prompt:

1. Select Start -> Computer -> System Properties -> Advanced system settings -> Environment Variables -> System variables -> PATH.

2. Prepend (example) C:\Program Files\Java\jre7\bin; to the beginning of the PATH variable.

3. Click ok 3x.

4. Execute -> cmd -> java -version

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

I saw this error in some of our clan because they were still using old version of java, when I tell them to delete and reinstall all works

Share this post


Link to post
Share on other sites

Still loving A3S. :D But I have a couple of small features request:

First, it'd be nice if there was an addon group automatically created for a downloaded repo. Many of our users play with different groups, who use different mods. If there was an addon group, that stayed current with the repo build, all they would have to do is check the box, instead of going through the changelog.

Also, there should be a way to delete mods that were deleted from the repo. As of current, we have to inform our users a mod was deleted, or they have to check the changelog.

Of course, these are just quality of life suggestions. Regardless, thanks!

Share this post


Link to post
Share on other sites

First, it'd be nice if there was an addon group automatically created for a downloaded repo. Many of our users play with different groups, who use different mods. If there was an addon group, that stayed current with the repo build, all they would have to do is check the box, instead of going through the changelog.

I am afraid not sure to understand exactly :confused:

Also, there should be a way to delete mods that were deleted from the repo. As of current, we have to inform our users a mod was deleted, or they have to check the changelog.

As it is, ArmA3Sync does not perform a strict content replication regarding addons at root of the repository.

This allow people to take addons they want on the repository without loosing they own addons.

However if you add addons inside a folder on the repository, ArmA3Sync will perform the comparison.

In the link below, all the blue colored addons inside the SOE folder would be deleted from disk if selected:

ftp://www.sonsofexiled.fr/ArmA3/ArmA3Sync/development/screens/arma3sync_tuto_client_2.png

Now I can and option for people to perform an exact repository matching.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

I guess I was a bit confusing on that first part. :)

So, say someone connects and downloads my repository. I was suggesting that it should automatically create an addon group folder for that repo, that will only have the repo addons. This would eliminate the step of the user having to create the folder, and drag the addons to the folder.

Also, thanks for the second part, I never realized that. :)

---------- Post added at 19:04 ---------- Previous post was at 19:01 ----------

Oh, also, back on the 17th, I had this issue, that you replied to:

Heya Major_Shepard. A3Sync is working out very well for my outfit. Repo management is stupidly easy, and I'm thankful for that. On that note, we're having a slight issue.

On our server(Windows Server 2008) and a single member's computer(Windows 7 Ultimate), we can't create a folder under "Addon Groups". Which in turn, means we can't enable mods through A3Sync. It's not a big deal for the server, but I'm trying to get it sorted out for the member.

I've check 10+ times to make sure everything is correct. EXE path, default mod folder, and repo paths are all correct. Also tried different locations. All mods show up in the "Available Addons" section. I've verified current versions of JRE, and tried running as admin. I'm a bit lost now. Any idea?

You're suggestion worked out on our server. And for our user, his JRE was out of date. Just wanted to say thanks. :)

Share this post


Link to post
Share on other sites

I see. In fact this mechanism already exists when synchronizing and launch addons with an event (see the wiki -> Use as Player part).

For example I could add an option like "Add a group from repository". It will popup a panel with the list of repositories, the user select the repository and it creates the group containing the all addon list. If later the user perform and update, the group would be automatically updated :)

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Oh. Well, then ignore my previous suggestions. The more I learn about A3Sync, the more I love it. Thanks Major! :)

Share this post


Link to post
Share on other sites

Hm, somehow the mod-launching doesn´t work for me. I´ve setup a different mod-folder for my mods and for some reason only the mod with the highest prio will be loaded.

My guess is a bug within the launch-parameters because the modfolder-path isn´t appended to the rest of the mods.

The pictures shows what I mean:

eeqno5qo33kv.png

Share this post


Link to post
Share on other sites

In ArmA 3 -> Configure -> Expansion. Could you check that all the mods are listed ?

The run parameters looks correct. -mod=path\@A;@B means that @A and @B are loaded from path.

Share this post


Link to post
Share on other sites

Oh, didn´t know about that path-thing, thought this was the bug.

All the selected mods are listed ingame, but the mods don´t work.

When I use a different launcher everything works fine, so I don´t think the mods itself are the culprit, must be something with your tool respectively my configuration.

Share this post


Link to post
Share on other sites

Do you run the mods in the exact same order?

Could you try investigate by adding the mod in the run parameters one by one ?

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Yep, tried the same order and still only the first mod gets loaded.

I also tried adding the mods one by one but still, only the first gets loaded.

The other launcher works fine though.

Is it a problem that my Arma is installed on my C-drive?

Share this post


Link to post
Share on other sites

Nope it's not a problem. Now as your mods appear correctly in Expansion means that they are loaded by the game.

Could you try starting without @tmr for example -mod=path\@Babe_midTex or any other? I expect there is something wrong with this mod.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

ArmA3Sync v1.1 Update 2

Download

Use Check for Updates in the Help menu

or grab the windows installer here: ftp://www.sonsofexiled.fr/ArmA3/ArmA3Sync/releases/arma3sync-installer-1-1-25.exe

Changelog

- Added: an update now button has been added on the notification panel that popup on a repository change.

- Fixed: addons from folders outside of the ArmA 3 installation directory may not launch with the game.

- Fixed: events deleted from repository after a rebuild.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Release frontpaged on the Armaholic homepage.

===================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

** Note: since this is a project on which more people are working we will contact you in the future to discuss how you want this to be setup on Armaholic.

Share this post


Link to post
Share on other sites

Is there anyway to create a repository on a remote ftp server?

Our tactical group have a limited amount of bandwidth we can use per month and we can't afford to host the mods for download from our normal server.

I tried using a free ftp host, but I kept getting errors saying serverInfo can not be found when I try getting the list of addons on the server

Share this post


Link to post
Share on other sites

Ramius86 says right.

As you don't have a physical acces to the machine hosting your ftp server, you must build your repository on your computer with all the required addons and provide the url of you remote repository.

Then upload the .a3s folder into your remote repository.

Each time you want to change the content of your remote repository you will need to repeat this process.

Also take note that ArmA3Sync repository management also works from command lines. If you can have an access like SSH on the machine you can do all the things remotely from a terminal.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×