Jump to content
major_shepard

ArmA3Sync - launcher and addons synchronization software for ArmA 3

Recommended Posts

Is it so complicated to copy-paste the autoconfig url into the Repository Edit panel and click the import button?

Of course not, but there is a thing with migrations, and it's called limiting loss of features as much as possible. I made a button available to my group in our web application which used to be a pws:// link, thus allowing to have a two-click joiin, regardless of how many servers or modpacks were already configured. I just wondered if I were able to migrate this feature as well as everything else.

I take that answer as a "No", but it would have been much less complicated to go straight to the point.

Have a good day,

Share this post


Link to post
Share on other sites

The new 1.44 update comes with some changes to BattleEye and the vanilla launcher.

Whenever you load the game with Arma3Sync, it fails to enable BattleEye correctly and you get this error everytime:

FTxPcGN.png

-EDIT: This thread has a working solution: http://forums.bistudio.com/showthread.php?190426-BattlEye-service-implementation&p=2932338&viewfull=1#post2932338

Edited by BullHorn

Share this post


Link to post
Share on other sites

That's not an error, it simply prompts you to restart with BattlEye enabled.

It would be nice if we can get a checkbox for it though, there is a command line way of starting it when the game launches.

Share this post


Link to post
Share on other sites

It's a problem because it happens every time you load the game via Arma3Sync.

Share this post


Link to post
Share on other sites

For what I understand we have to wait for BIS to add to the game the -useBE parameter to change the way ArmA3.exe starts the game.

For the time being, use ArmA3Battleye.exe as executable location if you want to skip the message.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Another problem discovered:

Arma3Sync loads mods according to their dependencies and then alphabetically - so if by chance you have mods that must be loaded in a specific order (for example, @CBA must be loaded before @AllinArmaTerrainPack) and for whatever reason it's broken (for example @CBA updated but @AllinArmaTerrainPack didn't), it will cause ARMA to fail and crash and burn.

A3S needs to allow setting the order of mod loading manually.

-EDIT: Nevermind me, it actually exists already.

Addons Options -> Addon Priorities.

Well played, sir.

Edited by BullHorn

Share this post


Link to post
Share on other sites

For some reason cant get battleye to load using the ArmA3Aync Additional Parameters launch options. (As It did in the ArmAII Launcher). When you paste or type directly in to the box it comes up italic & wont work. Anyone know why the Battleye was changed? it seemed to be working before OK.

Share this post


Link to post
Share on other sites
For some reason cant get battleye to load using the ArmA3Aync Additional Parameters launch options. (As It did in the ArmAII Launcher). When you paste or type directly in to the box it comes up italic & wont work. Anyone know why the Battleye was changed? it seemed to be working before OK.

See http://forums.bistudio.com/showthread.php?190426-BattlEye-service-implementation&p=2932338&viewfull=1#post2932338

Share this post


Link to post
Share on other sites

Could there be a "checkbox" option that will simply change arma3.exe to arma3battleye.exe and add 0 1 params?

Share this post


Link to post
Share on other sites

Seems pointless considering BI will release a fix within a few days where you add -useBE to the startup line

Share this post


Link to post
Share on other sites
Thanks for the link. The key is the o space 1 in the Addional Parameters, how did he find that!!!

BI wrote it in the first post of the linked topic. :P

Share this post


Link to post
Share on other sites

some reason that french website will not load for me at all(west coast murrica). is there another place i can learn how to make a repository? or can someone just post the instructions on the forum? itd be greatly appreciated.

Share this post


Link to post
Share on other sites
some reason that french website will not load for me at all(west coast murrica). is there another place i can learn how to make a repository? or can someone just post the instructions on the forum? itd be greatly appreciated.

Hi Khan, have you tried it with an other internet browser?

Anyway I send you a private message with the wiki details.

You can also find plenty of English tutorial over the internet ;)

Share this post


Link to post
Share on other sites

Hello All,

I am trying use this to launch my server (because I have too many mods, so I cant just use a shortcut with the -mod on). However, when I try to use " -config=server.cfg " it does not seem to use the additional parameter, so my server config is not loaded.

I also tried this, with no luck...

-config="C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\server.cfg"

Edited by Kocrachon

Share this post


Link to post
Share on other sites
Hello All,

I am trying use this to launch my server (because I have too many mods, so I cant just use a shortcut with the -mod on). However, when I try to use " -config=server.cfg " it does not seem to use the additional parameter, so my server config is not loaded.

I also tried this, with no luck...

-config="C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\server.cfg"

Look at the server RPT, pretty sure the server.cfg is broken.

Share this post


Link to post
Share on other sites
Look at the server RPT, pretty sure the server.cfg is broken.

If I do it the manual way, creating a par file or even using it in the target parameters of the icon, the config works just fine. Only time it does not work is with ArmA3Sync

Share this post


Link to post
Share on other sites

A friend of mine has been having issues with connecting to our repo. Whenever he connects he get an error stating: "failded to read /.a3s/sync connect timed out".

Basically it cannot see any files.

When I tried connecting with FileZilla i couldn't see anything either. Untill i switched to active mode instead of passive mode.

Now he could download everything without a problem. He is the only one having this issue, so it's definitely not a server side issue.

What could i do to make his A3Sync work again? Is there a way to use FTP active mode aswell? Or is their something else I need to look at (firewall, router, ISP, etc.)?

Share this post


Link to post
Share on other sites

Hey,

I am struggling with the guide a little bit.

Do you need a dedicated box to set this up right? as I am still in the Alpha stage of my server I don't want to go out and buy a dedicated box just yet.

But I want to have this setup for all my clients to easily download all and any updates I make.

Anyone have a little easier guide to setting up a Repository? Any suggested file hosters?

Share this post


Link to post
Share on other sites
A friend of mine has been having issues with connecting to our repo. Whenever he connects he get an error stating: "failded to read /.a3s/sync connect timed out".

Basically it cannot see any files.

When I tried connecting with FileZilla i couldn't see anything either. Untill i switched to active mode instead of passive mode.

Now he could download everything without a problem. He is the only one having this issue, so it's definitely not a server side issue.

What could i do to make his A3Sync work again? Is there a way to use FTP active mode aswell? Or is their something else I need to look at (firewall, router, ISP, etc.)?

connect timed out means that ArmA3Sync has close connection because time to connect exceed 30 seconds. Simply go to Edit panel of the repository -> Advanced and change connection time out to 60000ms (=1 minute) for example.

---------- Post added at 10:10 AM ---------- Previous post was at 10:04 AM ----------

Hey,

I am struggling with the guide a little bit.

Do you need a dedicated box to set this up right? as I am still in the Alpha stage of my server I don't want to go out and buy a dedicated box just yet.

But I want to have this setup for all my clients to easily download all and any updates I make.

Anyone have a little easier guide to setting up a Repository? Any suggested file hosters?

All you need is a FTP or a HTTP server to host the file. Using a dedicated server (= a machine on which you install/manage yourself the FTP/HTTP server) is the best/easiest way. If you don't have access to the remote machine hosting the FTP/HTTP server you will have to build the repository on your PC and then upload it.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites
connect timed out means that ArmA3Sync has close connection because time to connect exceed 30 seconds. Simply go to Edit panel of the repository -> Advanced and change connection time out to 60000ms (=1 minute) for example.

---------- Post added at 10:10 AM ---------- Previous post was at 10:04 AM ----------

All you need is a FTP or a HTTP server to host the file. Using a dedicated server (= a machine on which you install/manage yourself the FTP/HTTP server) is the best/easiest way. If you don't have access to the remote machine hosting the FTP/HTTP server you will have to build the repository on your PC and then upload it.

Thanks for the quick reply.

I have a FTP that my game server is on but I'm assuming that won't work right since it doesn't let me connect to it. Maybe I'm just doing something wrong lol

Any chance you could give me a quick break down on how to set it up? Feel free to message me.

Thank you!

Ghost :)

Just to add to this,

I have a Gamer server purchased that has FTP access,

I uploaded the folder on there and on my computer, I than linked the URL to that folder ftp://REMOVED/arma3/Repository

I used my login details for the FTP as well as leaving it Anonymous, and it keeps giving me a FAILED TO CONNECT message.

Not sure what I am doing wrong or will I need to go and purchase something? Sorry for all the issues :(

Edited by Ghosttownn

Share this post


Link to post
Share on other sites

ArmA3Sync 1.4 Update 3 now available

Download

Check for updates or use the Windows installer: ftp://62.210.177.238/ArmA3/ArmA3Sync/releases/arma3sync-installer-1-4-61.exe

Changelog

Fixed: Linux: Check repository command may return a wrong message.

Fixed: ACRE wizard may pop up along with ACRE2 wizard after files synchronisation finished (regression from version 1.4).

Improved: Build repository progress speed.

Changed: Starting the game with Joint Server enabled modset option is now restrive to the list of addons of this modset.

Changed: Launcher optionns: -enableHT is now disabled if cpucount is specified.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×