Jump to content
major_shepard

ArmA3Sync - launcher and addons synchronization software for ArmA 3

Recommended Posts

asdfasfefaefsd:mad: ...... I love you, i knew it was gonna be something that simple. So now if i build a new repo on my pc then up load it to the dedicated machine it should work as long as the transfer is set to binary? and would i be possible to put that on the wiki cause i sent a number of hours to get it work.

Share this post


Link to post
Share on other sites

The thing is that repository upload is not the normal/optimized way. ArmA3Sync is supposed to build the repository on the host machine.

Repository upload will come into future update.

Share this post


Link to post
Share on other sites

oh ok i understand but i dont, so i new problem came up... i can connect to the repo it shows me what mods i dont have i go to download them and i get failed to retrieve .zsync file for url. also if i were to host the repo on my pc then my teammates would have to download the files from my pc/connection?

Share this post


Link to post
Share on other sites

This is because you have built the repository with protocole FTP set from Repositories panel, it must have been set HTTP for the zsync file to be generated.

Share this post


Link to post
Share on other sites

I know you have build in support for TFR but this is a manuell way. I already sync the userconfig folder, would be cool to sync automatic the new dll stuff for TS3 with the repo just like the other stuff. ATM i sync a folder "TFR-DLL's" and the players add this stuff manual after repo update to their TS3 plugin folder. why not sign this folder as TFR dll stuff all the time and if there are new dlls your great tool copy them over?

Share this post


Link to post
Share on other sites

ArmA3Sync 1.2 Update 9

Download

Use Check for Updates in the Help menu

Changelog

Added: Build repository options: ftp://www.sonsofexiled.fr/ArmA3/ArmA3Sync/development/screens/arma3sync_build_options.png

- Set favorite servers infos to autoconfig.

- Set repository files to exclude from build (ex: empty index.hml (Apache), config.xml (IIS)).

- Set folders to exclude extra local content when synchronising (ex userconfig folder).

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Major,

Just recently, I've noticed one of the addon groups keeps disappearing from the right hand pane. It's usually the top one, which for me, is the CBA group. I waited for an update to see if that cured it, but it's still doing it.

T

Share this post


Link to post
Share on other sites

Very nice work on this software ! Thank you for this :bounce3:

Share this post


Link to post
Share on other sites
Major,

Just recently, I've noticed one of the addon groups keeps disappearing from the right hand pane. It's usually the top one, which for me, is the CBA group. I waited for an update to see if that cured it, but it's still doing it.

T

Never experienced this. What do you do exactly to make the top group disappear ?

---------- Post added at 07:31 PM ---------- Previous post was at 07:30 PM ----------

LUKI;2683590']Very nice work on this software ! Thank you for this :bounce3:

Thanks guy. Thanks for CSLA mod too ;)

Edited by Major_Shepard

Share this post


Link to post
Share on other sites
Never experienced this. What do you do exactly to make the top group disappear ?

Start the application. It's as if the contents of the right hand pane aren't 'saved'.

Share this post


Link to post
Share on other sites

Thx Major_Shepard, your support is quite nice ;)

1: Would be cool if your "online" section could scan these servers and show how many players are on them? And more important a way to sync servers with repo? We have 3 own server and some friendly clans, i want that everyone have this servers ;)

2: We have a structure like this:

Arma3\@clanpack\@orginalmod1\

Arma3\@clanpack\@orginalmod2\

Arma3\@clanpack\@orginalmod3\

Arma3\@orginalmod3

Now if someone move a mod out or in the clanpack the repo dont recognise it not anymore. I know it worked bevor and i used it but now several people report that they need to download 5GB again? (A3MP Maps...)

3: Why would i join a server with a repo? I want to join a server with a group i made out of the repo. For example i made a group for everyone called "public server" and this only loads 3 mods. So everyone only need to load 3 mods when they join the public server,

Edited by Numrollen

Share this post


Link to post
Share on other sites
Thx Major_Shepard, your support is quite nice ;)

And more important a way to sync servers with repo? We have 3 own server and some friendly clans, i want that everyone have this servers ;)

You can already do this:

- Whether you share every autoconfig url of each repository. From last update, one can attach the servers infos from the Build options. Then when importing the autoconfig url, the online panel will be automatically completed.

- Or you can share a *.a3s.autoconfig file from Menu -> Autoconfig -> export that compile every repositories and favorite servers.

Now if someone move a mod out or in the clanpack the repo dont recognise it not anymore. I know it worked bevor and i used it but now several people report that they need to download 5GB again? (A3MP Maps...)

They don't have to. Whether they have to enable the Auto-discover option or they move the addon by hands into their local repository to respect the remote repository file structure. I will see about detecting addon moving inside the repository.

3: Why would i join a server with a repo? I want to join a server with a group i made out of the repo. For example i made a group for everyone called "public server" and this only loads 3 mods. So everyone only need to load 3 mods when they join the public server,

You have to create an Event which works as a sub-modset of a repository => http://www.sonsofexiled.fr/wiki/index.php/ArmA3Sync_Wiki_English#Use_as_a_mission_maker

User can then join server with Event modset whether by setting it from the online panel or by generating the corresponding goup using the Modset button of the Addons Panel.

---------- Post added at 07:48 AM ---------- Previous post was at 07:39 AM ----------

Start the application. It's as if the contents of the right hand pane aren't 'saved'.

Looks like you have a write access restriction on ArmA3Sync installation directory. Could you run ArmA3Sync.bat and paste the console content here?

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Thanks for always keeping us up to date and sending us your latest version :cool:

New release frontpaged on the Armaholic homepage.

===================================================

We have also "connected" these pages to your account (Major_Shepard) on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

** Note: since this is a project on which more people are working we will contact you in the future to discuss how you want this to be setup on Armaholic.

Share this post


Link to post
Share on other sites

Major_Shepard okay... i will never write an request :p :D

*edit*

with today version A3S want to delete @cba_a3\rsync folder what was spammed with 1000 files but he couldnt. i deleted it manually and sync worked after that. Hmmm ... strange..

Edited by Numrollen

Share this post


Link to post
Share on other sites

No, dont know where this rsync stuff come from. but why A3S cant delete it? Error message "blah blah not found". will look at it tomorrow.

Share this post


Link to post
Share on other sites

How would someone make a custom Repository for this program?

Share this post


Link to post
Share on other sites

Hello,

doesnt work here.

We used a ftp server on our dedicated server (we used it to centralize mods) > the arma3sync dont see a folder .a3s from host players

Share this post


Link to post
Share on other sites

Something changed with the last update. I am now unable to tell folders that just have additional local content apart from folders that have updated or added content when I am syncing with a repository. Before A3S would highlight the latter by making the folder name red (all the way to the root folder of a mod). Now only the files have the colouring and I have to drill down into the individual folders to find out why I am having the ! symbol show up. Any chance of getting folder colouring restored?

The new repository options are great. Could you enhance the "Repository files excluded from build" option to take entries like "*.extension" to exclude all files that match this pattern (i.e. "a.extension" and "bcd.extension")?

Could you please comment on the requirement to have indexes enabled for the web server? Why is that a requirement and is that going to change?

Share this post


Link to post
Share on other sites

Hi Shepard...

Is there a method for setting the new build options using the CLI tools for those of us who don't have desktop interfaces on our servers?

Cheers

C.

Share this post


Link to post
Share on other sites

Just in case I haven't emphasized this enough, I absolutely love the work you are doing! Its a huge time saver.

Share this post


Link to post
Share on other sites

a great tool but i find it anoying that everytime i uncheck a mod group it unchecks all mods in that group instead of just unchecking the group but leaving the mods checked

Share this post


Link to post
Share on other sites

I've had some issues starting Arma 3 Sync. I've reinstalled Java and Arma3Sync a few times without any luck, Disabled Firewalls etc.

It basically doesn't start at all, doesn't show up in processes, doesn't do crap. Anyone know a solution for this?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×