Jump to content
major_shepard

ArmA3Sync - launcher and addons synchronization software for ArmA 3

Recommended Posts

Do you also launch other mods with AiA?

Just look at Expansions section of ArmA 3 and check that all mods are here. If yes, ArmA3Sync is ok. AiA is far for stable right now.

Share this post


Link to post
Share on other sites
Do you also launch other mods with AiA?

Just look at Expansions section of ArmA 3 and check that all mods are here. If yes, ArmA3Sync is ok. AiA is far for stable right now.

I didn't have any other mods enabled. To be honest, it took me a while (after I posted) before I even figured how to select which mods I wanted to use. AiA is easy, you have a selection pull down. May I suggest a button to add Addon Groups to your next build?

And like previously reported, there is an issue with profile names that have spaces and periods.

Share this post


Link to post
Share on other sites

Hi,

I have a problem with building a repository.

I stopped at 4. Give the path to the folder provided at step 1. Add addons into the shared folder. You can also place them into folders.

Bez-nazwy-2.jpg

How I can add the FTP shared folder location adress via SELECT button? I cant paste anything in typing field, only SELECT button works.

Can someone explain me what am I doing wrong? Or write out step 4. Thanks.

Share this post


Link to post
Share on other sites
Hi,

I have a problem with building a repository.

I stopped at 4. Give the path to the folder provided at step 1. Add addons into the shared folder. You can also place them into folders.

https://dl.dropboxusercontent.com/u/74709146/Bez-nazwy-2.jpg

How I can add the FTP shared folder location adress via SELECT button? I cant paste anything in typing field, only SELECT button works.

Can someone explain me what am I doing wrong? Or write out step 4. Thanks.

You must be on the machine hosting the FTP server (i.e be able to browse the hard disk). With the select button give the path to your "REPO" folder => c:\...\REPO

Edited by Major_Shepard

Share this post


Link to post
Share on other sites
AiA just gives me an error that I can't get past... "No entry 'config.bin/CfgVoice.Male00ENG'."

Ok, I got this error running AiA. I also got it while running vanilla Arma3. I closed A3 and A3Sync. I opened using a different launcher and I get no error.

Share this post


Link to post
Share on other sites

ArmA3Sync 1.0 Update 1

Download

Use Check for Updates in the Help menu

or grab the windows installer here: ftp://www.sonsofexiled.fr/ArmA3/ArmA3Sync/releases/arma3sync-installer-1-0-21.exe

Changelog

Fixed: game profile name with "-" and spaces characters wrongly split as run parameters.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Profile names with "-" work now, but the updated resetted some settings like mod folder and exe-path.

Share this post


Link to post
Share on other sites

New version frontpaged on the Armaholic homepage.

===================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

** Note: since this is a project on which more people are working we will contact you in the future to discuss how you want this to be setup on Armaholic.

Share this post


Link to post
Share on other sites
ArmA3Sync 1.0 Update 1

Download

Use Check for Updates in the Help menu

or grab the windows installer here: ftp://www.sonsofexiled.fr/ArmA3/ArmA3Sync/releases/arma3sync-installer-1-0-21.exe

Changelog

Fixed: game profile name with "-" and spaces characters wrongly split as run parameters.

I still get a few random %% profile names- but my proper one shows now!

So thanks for the update!

By far.... the best launcher i've used!! With AiA chucked in for good measure! :cool:

Share this post


Link to post
Share on other sites

I still get this error when I load using Arma3Sync. It doesn't happen when I load any other way. No addons or mods either way.

2013-08-25_00001_zps5389f611.jpg

Share this post


Link to post
Share on other sites
I still get this error when I load using Arma3Sync. It doesn't happen when I load any other way. No addons or mods either way.

http://i5.photobucket.com/albums/y181/djmtott/2013-08-25_00001_zps5389f611.jpg

I can't read the error, it's too small. Have you check in the "expansion" menu if everything is disabled (from the game interface)?

Share this post


Link to post
Share on other sites

Can't reproduce here with the stable branch.

@Papa: could you make a try with the dev branch launching ArmA 3 with ArmA3Sync and no addon. Then open the Mission Editor.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

@Papa: could you make a try with the dev branch launching ArmA 3 with ArmA3Sync and no addon. Then open the Mission Editor.

No problem at all on my side with the launcher and the game in dev branch, that's why it's strange.

Share this post


Link to post
Share on other sites
I can't read the error, it's too small. Have you check in the "expansion" menu if everything is disabled (from the game interface)?

My apologies. Here is a magnified version

http://i5.photobucket.com/albums/y181/djmtott/2013-08-25_00001_zpse4631a17.jpg

2013-08-25_00001_zps046de360.jpg

What happened before is that I tried AiA, and got that error. Then I just tried A3 and got that same error. So I ditched the program. So I just tried using Sync for A3 and I got the same error. So I look at the mods and some of the AiA mods are still enabled. I uncheck those and A3 works fine.

I figure I'll try AiA again to see if that works. Nope, got the error again. So I think this is a cycle, and I'd expect the mods to still be on and A3 to error too, but no. I have no idea. Sync works with A3, but I'm getting that error when I try AiA.

Share this post


Link to post
Share on other sites

When you launch ArmA 3 with AiA using ArmA3Sync, are ou able to open Chernarus in the mission editor?

Please checkout ArmA3Sync Tools menu -> AiA Tweaker and make sure the directories are correct.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

This will make life so much easier for us Server administrators :)

Major_Shepard & the Team that has made this, I want to say a thank you from me personally, and I'll also say it on behalf of the group I game with over at 16AA - As I'm sure we'll all eventually switch to using this.

I've not tried this with A2 but if this work well with it then I will gladly migrate from Yoma's Addonsync (which unfortunately is no longer maintained).

Share this post


Link to post
Share on other sites

Thanks mate. Now as we don't want to override SpiritedMachine ArmA 2 game launcher from witch ArmA3Sync is based on, no specific development will be done regarding ArmA 2.

Share this post


Link to post
Share on other sites

Very nice tool. Our community will definitely use this. Something i noticed while testing is that it downloads the whole mod pack again even though i just changed 2 files. Can this get fixed so clients only download the changes of a modpack instead of completly reloading everything?

Something i also noticed. We got a userconfig folder in our mod pack which did not got created. Instead it opened an empy error message window.

Many thanks for this.

Share this post


Link to post
Share on other sites

could you show me how does it looks like in the Download panel after a Check for Addons ? Only changed files should be marked red and deleted files blue.

Could you give a link for me to download your mod pack prior the changes and after the changes?

Edited by Major_Shepard

Share this post


Link to post
Share on other sites
could you show me how does it looks like in the Download panel after a Check for Addons ? Only changed files should be marked red and deleted files blue.

Could you give a link for me to download your mod pack prior the changes and after the changes?

Sorry, forget what i said. It seems it was a mistake on my side.

Share this post


Link to post
Share on other sites

i cannot for the life of me get my mods to show up for anyone, they show up in the FTP, they are there on the physical server location, everything else says it should be finding them. but when I make the repository, and then use the autoconfig on my personal machine to sync with my server, there are ZERO mods, funny as i added 40 mods! I'm pulling my hair out at this point, I've been fighting with it all day and tried at least 30 different things at this point.

Found this with some digging, this is what I get .

Connection to Verc's Dreamland success.

Connection updates repository Success

1.0.21

Connection to Verc's Dreamland success.

Connection to Verc's Dreamland success.

java.lang.NullPointerException

at fr.soe.a3s.service.RepositoryService.transformSyncTreeDirectory2DTO(R

epositoryService.java:838)

at fr.soe.a3s.service.RepositoryService.transformSyncTreeDirectory2DTO(R

epositoryService.java:858)

at fr.soe.a3s.service.RepositoryService.getSync(RepositoryService.java:2

40)

at fr.soe.a3s.ui.repositoryEditor.workers.AddonsChecker.run(AddonsChecke

r.java:65)

Exception in thread "Thread-7" java.lang.NullPointerException

at fr.soe.a3s.ui.repositoryEditor.workers.AddonsChecker.run(AddonsChecke

r.java:75)

Latest version.

Version in Development, build 22, works perfectly!

Edited by Kevaskous
Dev build works

Share this post


Link to post
Share on other sites

Thanks mates, indeed there is a bug now corrected with the new build 1.0.22

ArmA3Sync 1.0 Update 2

Download

Use Check for Updates in the Help menu

or grab the windows installer here: ftp://www.sonsofexiled.fr/ArmA3/ArmA3Sync/releases/arma3sync-installer-1-0-22.exe

Changelog

- Added: Addon Groups - it is now possible to add a new group folder inside his parent folder.

- Added: Launcher Options panel - no logs option added.

- Fixed: Check for Addons - an error may happen when repository has a folder that does not contain addons (example: userconfig folder).

- Improved: tree checkBox selection.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Hi, I've downloaded this tools and I've installed it both in server and local but I cannot make this works... When I put the auto config url file, it connect and in the info it show the info ( mb, how many files, ecc ) but it doesn't show me the addons in the tree and if I try to download it, it told me to select addons first or something like this... In the ftp log I've got a message that a file isn't found... I've read and follow the instruction there http://www.sonsofexiled.fr/wiki/index.php/ArmA3Sync_Wiki_English but probably I've missed something...

[EDIT]

Ok the ftp shared folder location is the root and not the mod :)

Edited by ramius86

Share this post


Link to post
Share on other sites

Could you mp me your autoconfig or login/password for the repository?

Be sure to be with build 1.0.22 (Help -> About)

Edit: fine :)

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×