Jump to content
kibot

[SP]Dynamic Universal War System (DUWS alpha0.1)

Recommended Posts

ok I find out what is a Personnal FLIR , But how i use it?

Also how I can choose where to start my "base" sorry ask so much things, i'm kinda noob in arma

Edited by aoshi

Share this post


Link to post
Share on other sites

Hey kibot, thanks for the work on this mission.

However, I tried the new version today, when I speak to the captain and order a mechanized scout unit, the unit spawns on top of the HQ and immediately blows up killing myself and the captain. I'm running the dev version, do I still need to do that for access to high command?

Share this post


Link to post
Share on other sites
ok I find out what is a Personnal FLIR , But how i use it?

Also how I can choose where to start my "base" sorry ask so much things, i'm kinda noob in arma

Google my friend^^ for a Personnal Flir. In two words : Personnal thermal camera.

http://en.wikipedia.org/wiki/FLIR_Systems

To use :

Take it from the support request (officer).

After with the mouse wheel you can chose activate or desactivate FLIR.

That's all.

Good luck.

G.B

Share this post


Link to post
Share on other sites
Hey kibot, thanks for the work on this mission.

However, I tried the new version today, when I speak to the captain and order a mechanized scout unit, the unit spawns on top of the HQ and immediately blows up killing myself and the captain. I'm running the dev version, do I still need to do that for access to high command?

I now have the same problem, I cant order a helicopter anymore because half of it spawns inside the FOB and blows everyone up :(

Share this post


Link to post
Share on other sites


I have the spawning problem as well, especially with the IFV Panther. Other vehicles like the MH9 seem to be working.
Using the DEV build, by the way.

Share this post


Link to post
Share on other sites

Im working on it, fix will be out shortly...

---------- Post added at 12:09 ---------- Previous post was at 11:51 ----------

v0.5b is out, this should be fixed now.

Share this post


Link to post
Share on other sites
Im working on it, fix will be out shortly...

---------- Post added at 12:09 ---------- Previous post was at 11:51 ----------

v0.5b is out, this should be fixed now.

Awesome, played for a while, looked at the clock and it was a few hours later than I though it would be.

This mission is great fun, I haven't had time to sit down and play it through for longer than a couple, but I'm assuming the enemy starts fielding more APCs and more infantry etc?

Share this post


Link to post
Share on other sites

This mission it's pretty awesome. The best support system i've found yet, and most important, the role experience it's just very nice.

I'm on the side of that people who thinks this would be great with some small coop integration. To set up another players as a team leader too. Perfect for small private servers, or small clans.

Thanks for this great mission, keep up the good work.

cheers

Share this post


Link to post
Share on other sites

I put the latest dev build version in my missions folder, and yet I am still spawning in water in the corner of the map. I have no mods.

Share this post


Link to post
Share on other sites

Everybody spawns in the water, but you should be teleported instantly as soon as a suitable location for the HQ has been found. I guess the scripts aren't executed properly.

Share this post


Link to post
Share on other sites
If you are running the dev build version of ArmA III, use the dev build version of the mission, you'll have access to squads with High Command.

Nice addition!! I may have to start using the DEV branch now!!! ;)

Share this post


Link to post
Share on other sites

Great Work, I feel addicted to it right now. Would like to see the AAF, too. But I read your post and your statement about the hard work it would be making it CSAT/AAF - compatible. NVM Great work!

Share this post


Link to post
Share on other sites
I put the latest dev build version in my missions folder, and yet I am still spawning in water in the corner of the map. I have no mods.

That's weird, maybe something is failing at the init.sqf

If you want to help, could you put this as the first line:

hint "DERP DERP DERP DERP";

Inside "SP_DUWS.stratis\initHQ\locatorhq.sqf"

So it would look like:

hint "DERP DERP DERP";
_foundSafePos = [center_of_map, 0,half_of_map,5,0,0.1,0] call BIS_fnc_findSafePos;
_handle = [_foundSafePos] execVM "initHQ\bluHQinit.sqf"; 

Start the mission and tell me if you see "DERP DERP DERP" appearing as a hint (top right corner of screen).

Thanks for your support guys :D.

Share this post


Link to post
Share on other sites

I downloaded this for a quick shot last night and ran into the exploding vehicle problem a couple of times. Been looking for an excuse to start getting into arma scripting so i thought I'd give fixing it a bash. Need to test it a bit more as I keep getting HQ's that are out in the open but it's 2 in the a.m. here and I need to get some sleep. Seems to work okay though. Notice that you've already fixed it but for what it's worth I thought I'd post it up anyway.

_index = lbCurSel 1502;
_vehicleList = [
 [5,  "B_MRAP_01_F"], 
 [18, "B_MRAP_01_hmg_F"], 
 [25, "B_MRAP_01_gmg_F"], 
 [35, "B_APC_Wheeled_01_cannon_F"],
 [2,  "B_Truck_01_transport_F"],
 [40, "B_Heli_Light_01_armed_F"],
 [75, "B_Heli_Attack_01_F"],
 [15, "B_Heli_Light_01_F"],
 [22, "B_Heli_Transport_01_F"],
 [35, "B_APC_Tracked_01_rcws_F"],
 [1,  "B_Quadbike_01_F"]
];

_pointsNeeded = (_vehicleList select _index) select 0;
_hqPosition = getmarkerpos str(blu_hq_markername);
_vehicleName = (_vehicleList select _index) select 1;

_maxDistance = 200;
_minRange = 10;
_sweepSize = 20;
_position = [];
_innerRange = _minRange;
_outerRange = _minRange + _sweepSize;

if( commandpointsblu1 >= _pointsNeeded ) then
{
 while{(count _position < 1) && (_innerRange <= _maxDistance) } do
 {
   _position = _hqPosition findEmptyPosition[_innerRange, _outerRange, _vehicleName];
   _innerRange = _outerRange;
   _outerRange = _outerRange + sweepSize;
 };
 if(count _position == 1)
 {
   _vehic = _vehicleName createVehicle _position;
   hint "Vehicle ready !";
   commandpointsblu1 = commandpointsblu1 - _pointsNeeded;
   ctrlSetText [1000, format["%1", commandpointsblu1]];
 }
 else
 {
   hint "The terrain around this HQ is unsuitable for vehicles !";
 };
}
else
{
 hint format["Vehicle requires %1 CPs.\nYou currently have %2 CPs !", _pointsNeeded, commandpointsblu1];
};

As it's my first stab, i'd welcome any comments.

Share this post


Link to post
Share on other sites
That's weird, maybe something is failing at the init.sqf

If you want to help, could you put this as the first line:

hint "DERP DERP DERP DERP";

Inside "SP_DUWS.stratis\initHQ\locatorhq.sqf"

So it would look like:

hint "DERP DERP DERP";
_foundSafePos = [center_of_map, 0,half_of_map,5,0,0.1,0] call BIS_fnc_findSafePos;
_handle = [_foundSafePos] execVM "initHQ\bluHQinit.sqf"; 

Start the mission and tell me if you see "DERP DERP DERP" appearing as a hint (top right corner of screen).

Thanks for your support guys :D.

I would, but I don't know where the Workshop downloads the files to. Also I have no way of extracting the .pbo assuming the Workshop downloads the .pbo instead of the folder.

Share this post


Link to post
Share on other sites
I'm assuming the enemy starts fielding more APCs and more infantry etc?

Yes, but this feature has just been added, it might require some balancing. Feedbacks are welcome.

@theirongiant: Your solution is far more elegant than mine.

Funny thing about that, is that I just released the v0.5 and then went to bed. When I woke up, I decided to check the user feedbacks and saw everybody complaining about not being able to spawn any vehicle without the mission breaking badly. So I went to "oh shit" mode and tried to fix this as quickly as I could.

So yeah, I'll probably use something like fnc_BIS_findSafePos.

But hey, I had to fix this quickly while still being in underwear in front of my computer.

Oh, and btw, using an array of CP - vehicle classname is so much more elegant than my "case 0:, case 1:..."

@JuggernautOfWar: download the mission files in the first page of the topic, and play it directly from the editor

Share this post


Link to post
Share on other sites

We need a way to cast suports with mouse target, instead of map target

also now the flir work (and it is great)

Share this post


Link to post
Share on other sites
Yes, but this feature has just been added, it might require some balancing. Feedbacks are welcome.

@theirongiant: Your solution is far more elegant than mine.

Funny thing about that, is that I just released the v0.5 and then went to bed. When I woke up, I decided to check the user feedbacks and saw everybody complaining about not being able to spawn any vehicle without the mission breaking badly. So I went to "oh shit" mode and tried to fix this as quickly as I could.

So yeah, I'll probably use something like fnc_BIS_findSafePos.

But hey, I had to fix this quickly while still being in underwear in front of my computer.

Oh, and btw, using an array of CP - vehicle classname is so much more elegant than my "case 0:, case 1:..."

@JuggernautOfWar: download the mission files in the first page of the topic, and play it directly from the editor

Yeah, there's a big difference when you've got something live, been there plenty of times before. Cheers anyway, I'm learning a lot from poking through the code but, damn, this arma scripting stuff has some funky syntax. Reminds me a bit of objective-c.

Share this post


Link to post
Share on other sites

Great mission! I realy enjoy it very much!

Only problem I have is that I cant get access to the Armory. It pops a window saying "VAS never initialized". I realize this is about the vistual ammobox system and I check the code in the .ext and its right. So I cant work out this problem.

anybody help me.thanks a lot!

Share this post


Link to post
Share on other sites
Great mission! I realy enjoy it very much!

Only problem I have is that I cant get access to the Armory. It pops a window saying "VAS never initialized". I realize this is about the vistual ammobox system and I check the code in the .ext and its right. So I cant work out this problem.

anybody help me.thanks a lot!

This isn't to do with the mission. One often gets such an issue when running VAS on a home PC and not loaded via the server.exe :x

Share this post


Link to post
Share on other sites

Nice mission!

Is there a way to change units so i can use units from mods or arma 2 units using AiA? And to add a map grid for the zones to spawn like mso? i ported to AiA takistan and i am testing right now.

Share this post


Link to post
Share on other sites
This isn't to do with the mission. One often gets such an issue when running VAS on a home PC and not loaded via the server.exe :x

oh I see.thanks!

And how i suppose to fix that? It lost a lot of fun playing without armory.

Share this post


Link to post
Share on other sites
oh I see.thanks!

And how i suppose to fix that? It lost a lot of fun playing without armory.

You should search the forums for Terox's guide on making a server. You can basically make a dedicated server but on your home pc. Instead of going on multiplayer and hitting new, by using the new .exe it'll appear like any other in the server browser if done correctly.

http://forums.bistudio.com/showthread.php?147537-Tutorial-How-to-run-ArmA3-on-a-dedicated-server

That has so much information in it and is extremely useful, even including basic config files to get the ball rolling. You can then specify which mission to play (i.e. this).

I'm not sure that DUWS is compatible with multiplayer though, but as long as it's only you joining I wouldn't see any issues.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×