Jump to content

Recommended Posts

There used to be an AI Configuration thread but it is no mas...

 

 Theres something wrong with lowering the subSkill aimingSpeed - it doesnt want to go below 0.5 even when set to zero _x setSkill ["aimingSpeed", .000000000];

 

..returns 0.5

Share this post


Link to post
Share on other sites
35 minutes ago, froggyluv said:

 Theres something wrong with lowering the subSkill aimingSpeed - it doesnt want to go below 0.5 even when set to zero _x setSkill ["aimingSpeed", .000000000];

 

..returns 0.5

setskill of 0..1 is interpolated to 0.5..1 of skillFinal.

A zero should result in minimum value of 0.5. So it's working as intended.

 

The other final ranges are:
aimingAccuracy 0..1
aimingShake 0..1
aimingSpeed 0.5..1
commanding 0..1
courage 0..1
endurance 0..1
general 0..1
reloadSpeed 0..1
spotDistance 0..1
spotTime 0..0.7

 

+ the modifier from the difficulty settings.

 

https://community.bistudio.com/wiki/CfgAISkill

  • Like 1

Share this post


Link to post
Share on other sites
On 3/17/2017 at 10:40 PM, special ed said:

SetUnitPos "UP" + Safe Behavior Bug Video

 

Units that have stance set to Up plus safe mode enabled will bug out when they go into Combat Behavior.

 

Video shows 3 examples of it happening.

 

Version 1.68.140908


Hi, thanks for report, I tried it on both internal and public versions and couldn't reproduce. They do waive weapon once (at the moment of switching combat mode) and they keep engaging. If you can, send me your mission ;)

  • Like 4

Share this post


Link to post
Share on other sites
6 hours ago, klamacz said:


Hi, thanks for report, I tried it on both internal and public versions and couldn't reproduce. They do waive weapon once (at the moment of switching combat mode) and they keep engaging. If you can, send me your mission ;)

 

 

Repro Mission

 

Link provided for reproduction mission

 

Mission is just basic, opfor unit facing player in safe behavior with stance locked up. You can radio alpha to setbehaviour "COMBAT" to the second Opfor unit that is behind the building, and at least on my end he bugs out by this method as well.

 

I have only Marksmen enabled with this test mission, nothing else, (no 3rd party addons).

 

Only other thing I can say is that my system barely meets the requirements for Arma 3, so I don't know if a lower end system may be a contributing factor to the issue.

 

Also, about half the time the opfor unit facing the player fires off a shot before he goes into the repetitive weapon up/down motion.

 

/Edit

 

In the rare case it may have some part in things, I have the game on 'regular' difficulty default preset

  • Like 1

Share this post


Link to post
Share on other sites
Quote

Units that have stance set to Up plus safe mode enabled will bug out when they go into Combat Behavior.


I can confirm exactly the same result trying to reproduce (stable, no mods). I've noticed it several times and i think that's not the only way to encounter the bug.

Share this post


Link to post
Share on other sites
On ‎3‎/‎20‎/‎2017 at 6:31 PM, rhyfelwyr said:


I can confirm exactly the same result trying to reproduce (stable, no mods). I've noticed it several times and i think that's not the only way to encounter the bug.

 

 Of course it can inherently affect a variety of unit usages, tower guards, units sent to windows in buildings, units forced to run to various positions in a given mission during combat, safe mode patrols (if one needs to keep the units in Up stance, perhaps for searching an area for an enemy, etc),  a lot of by-products really possible. Units affected by this issue that are trying to move to a position stutter at times, stoping and doing the weapon up/down thing then carry on/rinse repeat.

 There also used to be an issue with safe behavior plus Up stance with patrol units that did not even go into combat behavior yet, where they would run the weapon raised animation while walking the patrol route in safe behavior, but I don't see this issue happening any longer, although I have seen for the first 3 seconds or so when the patrol units are moving they have their weapons raised, and then lower them - hopefully the issue isn't some random thing still.

 

/Edit

 

Looks like Safe Behavior plus Up Stance is also messing up Aware behavior animation when switched to for patrols, as they continue to walk with their weapons lowered when switched to Aware. I'm not going to get into testing every possibility here, but ofc it could be possible that other issues may exist with these commands/unit states.

  • Like 3

Share this post


Link to post
Share on other sites
1 hour ago, racerx said:

I put this in another thread. I want to put it here because the BI devs are more likely to see it and it is a active thread

In how far does this relate to the topic of "AI Discussion"?

  • Like 8

Share this post


Link to post
Share on other sites
5 hours ago, Alwarren said:

In how far does this relate to the topic of "AI Discussion"?

 

Posts like his are why Devs so rarely visit the feedback threads. too much noise

  • Like 2

Share this post


Link to post
Share on other sites
On 4/4/2017 at 9:10 PM, fn_Quiksilver said:

 

Posts like his are why Devs so rarely visit the feedback threads. too much noise

Can we pretty please get it so AI can recognize holes in chain-link fences? And that they'd know enough that they can walk through them?

 

Yikes. I setup a simple scenario where I placed some boats in the water just behind the "Aeroport de Tanoa." After I walked through the fence holes (of which there are several) with my grouped AI following me, the AI can't recognize the openings so they can't reach the boats at all. :(

 

I then decided to try getting in a boat and giving the AI a "get in" order and sure enough, they say "cannot comply."

 

All because of a chain-link fence with so many holes, why even have a fence at all? I mean, either delete the fences (they have holes! Why are they even there?) or program the AI to recognize they can actually walk through the openings please!

 

 

  • Like 3

Share this post


Link to post
Share on other sites
On 4/4/2017 at 2:28 PM, Alwarren said:

In how far does this relate to the topic of "AI Discussion"?

Oh so lets ignore the post entirerly and concentrate more on looking correct and being correct and making me look stupid. Thats more important! Congrats on the number of likes you get. I bet you feel proud!

Share this post


Link to post
Share on other sites
1 minute ago, Grumpy Old Man said:

Well you're posting in the wrong forum, wrong thread and your response doesn't make you look smart either.

 

Cheers

Thats what moderators are for right? Delete the whole thing what do i care. Nobody gives a damm about it anyways. More concerned about pointing out the obvious then about the post itself...here let me give you a "like". There we go, better?

  • Like 1

Share this post


Link to post
Share on other sites

Hi.

 

In AI squad organization, if there is a vehicle in a group and if the commander of the AI group in not a commander of this vehicle (if no commander slot, then gunner if no gunner, then driver), then unexpected behavior is produced like not following waypoints e.t.c. 

Please make the AI group commander a priority over everyone else in group no matter what position/vehicle they occupy.

Share this post


Link to post
Share on other sites
5 hours ago, RacerX said:

Thats what moderators are for right? Delete the whole thing what do i care. Nobody gives a damm about it anyways. More concerned about pointing out the obvious then about the post itself...here let me give you a "like". There we go, better?

Thats what moderators are for? What..amending deliberately inflammatory posts put in the wrong section on purpose? Nothing better to do with my Sundays..

 

We also have another function-suspending people's accounts. 

  • Like 4

Share this post


Link to post
Share on other sites

Is it me or has AI pathfinding in buildings gotten worse? Example I place a wp on top floor last room 2 story building. The unit only goes to end of hallway on bottom floor. So outta curiosity I pulled out one of my old garrison scripts. Basically they would only stay on bottom floor. So I tried spawning units in every position I could gather using buildingpos and a find finding windows and doors script.... They all spawned on bottom floor. Not sure if you guys are aware of this. But figured I'd bring it to your attention. If its only me please ignore and/or delete this post with my humble apology.

Share this post


Link to post
Share on other sites

@mikey74 The way you're describing this, it sounds like a bug that really should have a ticket. Assuming you can see this with no mods/scripts and just BI assets, you should open one. 

 

 

Share this post


Link to post
Share on other sites

Yes without mods, in both stable and dev branch. Wasn't sure if it was just me. All this once worked. But yeh retested few more times wrote a few more scripts. I can make them spawn at points in buildings, but AI path finding usually gets stuck at bottom of stairs, or doing circles in the bottom of building. I tried the bug report once. Didn't pan out to well. But I'll give it another try.  Thanks. Probably shouldn't have posted all this here. My apologies.

Share this post


Link to post
Share on other sites

AI jets pilots, no matter the altitude, seem to want to map the earth. This causes jets with a waypoint from one end of the map to the other, even at 9k altitude to fly up and down, and all over the place, as if flying Nap of the Earth.

  • Like 2

Share this post


Link to post
Share on other sites

so using the new systems in place. made the showcases more interesting. particularly the gunship. normally I would have blazed through this wiped everything no sweat really. with new systems not so much.

 

there was one thing I noticed when actually taking the arti tanks out themselves. not being able to lock them with atgm( engines cold no lock) I needed to use the skyfires. it took alot and I had to angle for the rear of the tank believing it was going to net me a kill as running low on ammo by this point. the whole time I was being pinged at by the guns on the arti. if I had a human player or I was gunner i would have took out the guns way before approaching to skyfire run it.

 

just wondering if there could be an added ability to make ai gunner act more tactically human by targeting the extra threat of guns on tanks in particular to disable them. 

Share this post


Link to post
Share on other sites
On 3/17/2017 at 5:40 PM, special ed said:

SetUnitPos "UP" + Safe Behavior Bug Video

 

Units that have stance set to Up plus safe mode enabled will bug out when they go into Combat Behavior.

 

Video shows 3 examples of it happening.

 

Version 1.68.140908

@special ed Did you ever open a ticket for this? I've owned Arma 3 for years, and for the first time ever I consider the game unplayable. Just played a quick mission for the first time in a few weeks yesterday and saw this consistently. 

 

Whats bad about it is, when units do this, they get stuck in this loop. So it's pretty much target practice.

 

I'm genuinely stunned people aren't posting about this everywhere. PvE is quite literally broken, at least in the circumstances I play under (which must apparently be the perfect conditions for this to occur during nearly every firefight).

  • Like 4

Share this post


Link to post
Share on other sites
Quote

Did you ever open a ticket for this? I've owned Arma 3 for years, and for the first time ever I consider the game unplayable. Just played a quick mission for the first time in a few weeks yesterday and saw this consistently. 

 

Whats bad about it is, when units do this, they get stuck in this loop. So it's pretty much target practice.

 

I'm genuinely stunned people aren't posting about this everywhere. PvE is quite literally broken, at least in the circumstances I play under (which must apparently be the perfect conditions for this to occur during nearly every firefight).

 

 

Here's a ticket for I just made, with a vanilla repro mission and everything: https://feedback.bistudio.com/T124680

  • Like 1

Share this post


Link to post
Share on other sites
On 5/2/2017 at 2:01 AM, HeroesandvillainsOS said:

@special ed Did you ever open a ticket for this? I've owned Arma 3 for years, and for the first time ever I consider the game unplayable. Just played a quick mission for the first time in a few weeks yesterday and saw this consistently. 

 

Whats bad about it is, when units do this, they get stuck in this loop. So it's pretty much target practice.

 

I'm genuinely stunned people aren't posting about this everywhere. PvE is quite literally broken, at least in the circumstances I play under (which must apparently be the perfect conditions for this to occur during nearly every firefight).

 

only so many times you can whip a dog before it stops growling at you :) we have seen the direction BI is focusing resources (end game, argo, dayz, ylands) and stopped bothering to report AI-related issues/requests/feedback.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×