Jump to content
bangabob

Enemy occupation system (eos)

Recommended Posts

Is it possible to randomize or spread this between a few different variants, to allow for machine gunners and marksmen?

Yes you can. Look at: http://www.armaholic.com/page.php?id=26424.

You can put a script similar instead of:

 _unit addWeapon "hlc_rifle_ak47"; _unit addMagazine "hlc_30Rnd_762x39_t_ak"; _unit addMagazine "hlc_30Rnd_762x39_t_ak"; _unit addMagazine "hlc_30Rnd_762x39_t_ak"; _unit addMagazine "hlc_30Rnd_762x39_t_ak";

You must launch the script as "[_unit,2] execVM "randomize.sqf" (take care where you put the script, you must write all the addr)

The script can teach you to create your own one with the weapons.

Thx to djotacon I have "civils" armed in my missions.

Share this post


Link to post
Share on other sites

Thanks Prien - could you share an example of what your setSkill.sqf file looks like please (just the bit that triggers the script)?

Edit: NM, got it working (by putting script in the mission root folder) - awesome script! Thanks dude!

Edited by CallMeSarge

Share this post


Link to post
Share on other sites

When I do a zone for naval units and spawn light or heavy vehicles, it spawns the boats fine but never any crew/driver? Am I missing something here? I did have a view through the thread, I couldn't find any reference to it, but I didn't look over 90 pages in that much detail =P

Share this post


Link to post
Share on other sites
When I do a zone for naval units and spawn light or heavy vehicles, it spawns the boats fine but never any crew/driver? Am I missing something here? I did have a view through the thread, I couldn't find any reference to it, but I didn't look over 90 pages in that much detail =P

Make sure you have filled the crew array in UnitPools.sqf

Share this post


Link to post
Share on other sites

Ah I see, its set to look at diverpool at the moment (which is empty) and not crewpool as I was expecting. Thank you :)

Share this post


Link to post
Share on other sites
Ah I see, its set to look at diverpool at the moment (which is empty) and not crewpool as I was expecting. Thank you :)

Glad you got it sorted.

Share this post


Link to post
Share on other sites
Is there a function or a global array that contains all string values of the marker names?

Yeah

_eosMarkers=server getvariable "EOSmarkers"

Share this post


Link to post
Share on other sites

That's what I figured by looking at your scripts, but this doesn't seem to work for me (in the init.sqf):

_markers = server getvariable "EOSmarkers";

_cache1Pos = _markers call BIS_fnc_selectRandom;
_cache2Pos = _markers call BIS_fnc_selectRandom;

call compile preprocessfile "SHK_pos\shk_pos_init.sqf";
{ _x setpos (_cache1Pos call SHK_pos) } foreach [cache1];
{ _x setpos (_cache2Pos call SHK_pos) } foreach [cache2];

Share this post


Link to post
Share on other sites
That's what I figured by looking at your scripts, but this doesn't seem to work for me (in the init.sqf):

_markers = server getvariable "EOSmarkers";

_cache1Pos = _markers call BIS_fnc_selectRandom;
_cache2Pos = _markers call BIS_fnc_selectRandom;

call compile preprocessfile "SHK_pos\shk_pos_init.sqf";
{ _x setpos (_cache1Pos call SHK_pos) } foreach [cache1];
{ _x setpos (_cache2Pos call SHK_pos) } foreach [cache2];

You will have to wait a few seconds to allow EOS to complete its initialization.

Share this post


Link to post
Share on other sites

Just recently today I am experiencing an error with EOS. When it spawns in units they seem to "freeze" in place, and won't move/patrol until one of them is injured. Its very curious - maybe the new arma update? I did not have this issue with ANY of my EOS missions before, now in all of them.

I videotaped the Error in the default EOS sample/demo mission to ensure its not due to my own modifying of EOS. Here is my error video so you can see what I'm talking about:

Edit: 'm a fucking moron. left TPW mods enabled, it seems TPW causes this issue as of the latest update. Stupid me. 'll leave my original post up as is in case someone else has an issue using TPW and EOS and google/forum searches it or something.

Edited by Gfresco

Share this post


Link to post
Share on other sites

Random question. I have an EoS zone based on a marker that will expand/contract over time. Is there any way to have the zone adjust the number of infantry in the zone based on the size of the marker?

I know I can calculate that when I originally start the zone, with something like this:

null = [["MarkerName"],[0,0,0],[((getmarkerSize "MarkerName" select 0)/10),0,100],[0,0,0],[0,0],[0,0],[0,0,0],[2,1,500,INDEPENDENT,TRUE,FALSE]] call EOS_Spawn;

Though if I do that, I think that the number of infantry will never change and be based on the size of the marker when I made that first call. I want the number of infantry to adjust up or down, based on the size of the marker when the players cross spawn distance threshold. So, say for example the marker is 100m in size, the original call should calculate 10 infantry groups. But say the players go into the zone later and the marker is now 200m in size, I'd want there to be 20...

Any way to make that work?

Share this post


Link to post
Share on other sites

Man oh man, I just can't figure out how to adjust the number of groups that get respawned after caching to adjust based on the marker size at that time. I believe I've narrowed down the block I need to edit I think to this one in eos_core.sqf:

// SPAWN PATROLS
for "_counter" from 1 to _bGrps do {
if (isnil "_bGrp") then {_bGrp=[];};
	if (_cache) then {
			_cacheGrp=format ["PA%1",_counter];
			_units=_eosActivated getvariable _cacheGrp;	
				_bSize=[_units,_units];
				_bMin=_bSize select 0;
				if (_debug)then{player sidechat format ["ID:%1,restore - %2",_cacheGrp,_units];};
					};
						if (_bMin > 0) then {	
								_pos = [_mkr,true] call SHK_pos;			
								_bGroup=[_pos,_bSize,_faction,_side] call EOS_fnc_spawngroup;
									0 = [_bGroup,_mkr] call EOS_fnc_taskpatrol;
									_bGrp set [count _bGrp,_bGroup];

									0=[_bGroup,"INFskill"] call eos_fnc_grouphandlers;
if (_debug) then {PLAYER SIDECHAT (format ["Spawned Patrol: %1",_counter]);0= [_mkr,_counter,"patrol",getpos (leader _bGroup)] call EOS_debug};
											};
	};	

Basically I just want the respawning groups from the AAF Side to increase in number based on marker size (the marker will slowly get larger until the players wipe it out.)

I know I just need to plug something in like this

if (_side==INDEPENDENT) then {_groupsVariable = floor(_mkrX / 10);};

Anyone have any idea where I should plug that in and what that '_groupsVariable' should be? I've tried _bGrps and _counter with no luck.

Share this post


Link to post
Share on other sites

I'm having an issue on my Altis Insurgency map/MP mission where all of the EOS-spawned units are suddenly invincible. No matter how many times they are hit, or naded etc, they just won't die.

Everything was working just fine before, i added some new markers that seem to be OK (they show up red on the map).

Any ideas?

This problem is killing me (pun intended!) :-D

Thanks!

-Limey

Share this post


Link to post
Share on other sites
I'm having an issue on my Altis Insurgency map/MP mission where all of the EOS-spawned units are suddenly invincible. No matter how many times they are hit, or naded etc, they just won't die.

Everything was working just fine before, i added some new markers that seem to be OK (they show up red on the map).

Any ideas?

This problem is killing me (pun intended!) :-D

Thanks!

-Limey

If you're using TPW/Alive try without .

If not put your openme.sqf here .

Is there a way to reset a bastion zone ?

Deleting / Creating a new marker with the same name breaks the zone .

Share this post


Link to post
Share on other sites

hi

I have a problem when I use "bastion mode".

Throw a script error and does not create units. any idea? the mission of example does not work in either mode bastion.

Thx

Share this post


Link to post
Share on other sites

Hello. I'm trying to do a mission, with several regions in a big city. And I noticed that only units inside the houses give respawn. The Infantry Patrolling not appear

I'm using this

null = [["EOSzone1"],[10,1],[10,2],[0,0],[0],[0],[0,0],[5,1,800,EAST,FALSE,TRUE]] call EOS_Spawn;
null = [["EOSzone2"],[20,2],[20,2],[2,0],[0],[0],[0,0],[5,1,800,EAST,FALSE,TRUE]] call EOS_Spawn;
null = [["EOSzone3"],[20,2],[20,2],[2,0],[0],[0],[0,0],[5,1,800,EAST,FALSE,TRUE]] call EOS_Spawn;
null = [["EOSzone4"],[20,2],[20,2],[2,0],[0],[0],[0,0],[5,1,800,EAST,FALSE,TRUE]] call EOS_Spawn;
null = [["EOSzone5"],[10,2],[10,2],[2,0],[0],[0],[0,0],[5,1,800,EAST,FALSE,TRUE]] call EOS_Spawn;
null = [["EOSzone6"],[10,2],[10,2],[2,0],[0],[0],[0,0],[5,1,800,EAST,FALSE,TRUE]] call EOS_Spawn;

Share this post


Link to post
Share on other sites

EDIT: think i solved my problem.

i changed the difficulty the wrong way.

:(

Edited by ssglimey

Share this post


Link to post
Share on other sites

is there a variable or something after bastion waves are complete on a marker named"05" found this "EOSmarkers" not sure how to implement it thanks again

Share this post


Link to post
Share on other sites

This addon is awesome! Trying to get it working with my server, but for some reason in multiplayer, it doesn't respawn the units if you go outside the trigger and back in AFTER you attack/kill one. If you just dance on the line, it works just fine. Any ideas why it wouldn't be launching again? Thanks!

Share this post


Link to post
Share on other sites

hey all. I like this EOS so I am wondering is there a AI script/mod that works with this? it seems VCOMAI does not.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×