Jump to content

Recommended Posts

There is so much awesomeness in the changelog for me today.

•Fixed: Expensive simulations on destroyed buildings

Awesome.

•Fixed: New eventhandler gearOpened

Awesome

•Added: New command everyContainer

Awesome.

•Fixed: Damaging of helicopters by parachutes

Awesome

•Script command magazinesAmmo works also for ammo crates now

Awesome

•Parameters for weapon inertia added to config (more details once implementation is wrapped)

DoubleAwesome

•Maximum weapon inertia multiplied by the current inertia coefficient of the weapon

DoublePlusAwesome

Keep it up guys!

Share this post


Link to post
Share on other sites

Agree with DA. There is a lot of goodness in there. More functionality is really good. Also being able to squeeze every drop of power out of the engine is very welcome (disable simulations etc)

Share this post


Link to post
Share on other sites

When I click in the settings on extensions since the update to version 1.21.124479 (Development Buid) crashes the program! Do you know the problem and possibly have a solution? I have Removes all mods and it did not help

Share this post


Link to post
Share on other sites
Also being able to squeeze every drop of power out of the engine is very welcome (disable simulations etc)

Indeed. I wonder, though, if effort will be made to decouple the renderer from the simulation, as mentioned will happen with DayZ? Seems like that could provide a huge performance gain.

Share this post


Link to post
Share on other sites
If all goes well, 1.20 will be on main branch next week.

<3 good to hear. Especially seeing today's patch notes. Gonna have to 'splode some buildings tonight :)

Share this post


Link to post
Share on other sites

I was just having a blast in the fixed winged aircraft and I really like them but one thing I don't understand. We have nice collimated optics for small arms, but the HUD's in the fixed wings does not use this technique? Kind of immersion breaking for a flight sim enthusiast as myself. Is it possible that devs will put some more work into this?

Share this post


Link to post
Share on other sites

edited DEV changelog, it's InventoryOpened not gearOpened for the new EventHandler

Share this post


Link to post
Share on other sites

For anyone interested, biki's not updated yet but the inventory handler returns the following:

_this select 0 = player object

_this select 1 = object player is interacting with

For example, when opening the inventory on an offroad it returns the following:

"[p1,32219600# 164000: offroad_01_hmg_f.p3d]"

It returns a "GroundWeaponHolder" class object when there isn't an object/container to interact with. (so you can put stuff on the floor).

Edited by Das Attorney

Share this post


Link to post
Share on other sites

•Added: Support for subfolders in multiplayer scenarios

allows admins to use sub-folders in \MPMissions\ for mission pbo placement

I wonder if this will break the missionConfigFile trick we use with playSound3D to get the correct file path?

https://community.bistudio.com/wiki/playSound3D

See the notes by Jacmac and killzonekid.

Share this post


Link to post
Share on other sites

I have been trying to make a mission and spent all day trying to get one single Mora to go where I want it. It stops 10 meters away, always pulls about 10 meters to the side of it. It constantly tears down walls, soldiers etc just to avoid the waypoint. I've tried setting the behaviours, both in waypoints and with module, and there is absolutely zero change. I've seen them drive close to the waypoint, up to 6 meters away then drive around a group of trees just to get near the waypoint.

On open terrain they work almost correctly.

But I think I discovered the problem. The vehicles don't want to go anywhere near bushes. Even the small dead ones. If my Mora has no problem driving down the length of a wall, but bushes? It's crazy.

Does anyone else have issues like that? I found a slight workaround but it's not a big difference. I place a marker at the waypoint and I tell the vehicle to move to markers.

Wasn't there a fix for vehicle waypoints a couple updates ago?

Thanks

Share this post


Link to post
Share on other sites
When I click in the settings on extensions since the update to version 1.21.124479 (Development Buid) crashes the program! Do you know the problem and possibly have a solution? I have Removes all mods and it did not help

Same for me.

Share this post


Link to post
Share on other sites
When I click in the settings on extensions since the update to version 1.21.124479 (Development Buid) crashes the program! Do you know the problem and possibly have a solution? I have Removes all mods and it did not help

Some of my Team-members have noticed this too.

Edited by Muecke

Share this post


Link to post
Share on other sites

I know this thread is a few weeks old but I wonder if there has ever been a solution to this problem. I have made missions where his exact thing happens. Usually the AI leader gives anyone (not just AT) a target, but the soldiers run in the opposite direction. I've seen some go as far away as a few miles away. If I team switch to them, I see their target is back where the action is. He has no reason to run away. And they have been in sight of the unit they are supposed to kill.

Today I noticed it and found 2 runners. One was the squad leader with no reason to run away.

It's worse because when they do run away they usually ignore orders to move somewhere or come back.

Sometimes this game just makes it hard to play. I can't tell how many missions I spent a very long time creating just to have something as stupid as runaway soldiers or ai walking through walls and vehicles, Or just AI not doing basic easy stuff. And that mission becomes completely unplayable.

Can't bi or someone make some kind of script or module or code that makes AI check their targets at intervals. Like a time limit before their targeting gets reset or or walking past a certain distance will reset target so they come back.

Share this post


Link to post
Share on other sites
When I click in the settings on extensions since the update to version 1.21.124479 (Development Buid) crashes the program! Do you know the problem and possibly have a solution? I have Removes all mods and it did not help

Same for me.

Share this post


Link to post
Share on other sites
I was just having a blast in the fixed winged aircraft and I really like them but one thing I don't understand. We have nice collimated optics for small arms, but the HUD's in the fixed wings does not use this technique? Kind of immersion breaking for a flight sim enthusiast as myself. Is it possible that devs will put some more work into this?

I did not find any suggestions for parallax free HUD in feedback tracker, so I created one. Please vote if you care :D

http://feedback.arma3.com/view.php?id=18954

Share this post


Link to post
Share on other sites
When I click in the settings on extensions since the update to version 1.21.124479 (Development Buid) crashes the program! Do you know the problem and possibly have a solution? I have Removes all mods and it did not help

Fixed in rev 124685

Share this post


Link to post
Share on other sites

I noticed that Dev Updates get smaller and smaller , is there a specific reason for this? Maybe you got less people working with Arma or something else?

Share this post


Link to post
Share on other sites
I noticed that Dev Updates get smaller and smaller , is there a specific reason for this? Maybe you got less people working with Arma or something else?

They are on data lock until Stable gets updated

Share this post


Link to post
Share on other sites
They are on data lock until Stable gets updated

Oh ok I didn't know that. Thanks :)

Are we getting a stable update this week?

Share this post


Link to post
Share on other sites
Oh ok I didn't know that. Thanks :)

Are we getting a stable update this week?

If it goes right, we will have one this week.

Share this post


Link to post
Share on other sites
If all goes well, 1.20 will be on main branch next week.

Yeap ;). It should be on main branch this week if all "goes well".

Edit. Didn't see the post above :|

Share this post


Link to post
Share on other sites

Hi, not sure if this is the right room for build feedback but since the last couple of builds (124689) I've noticed a performance graphical degredation, admittedly I've created a mission with a huge load of addons - walls, fencing etc but it was ok but now I have a definite update stutter when flying over stratis. Have you guys made some sort of change that could cause this ? Anyone else notice anything ?

Thanks

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×