Jump to content

Recommended Posts

This is quite a big problem and I already noticed that from the start. Arma2 runs much better at night compared to Arma3.

I hope this can be somehow solved :(

Edited by Nikiforos

Share this post


Link to post
Share on other sites

Only losing about 4 frames between day and night...that said, night appears to have an odd HDR problem of its own.

The sky has several visible lines going through it, clouds have a sharp gradient and everything around, even the gun appears to have low res HDR defects of some sort. (Note, clouds and sky during daytime have a fully smooth gradient, no lines or 'jumps' observed)

NightOvercast_zpsb743a0ff.jpg?t=1366989953

NightClear_zpsf466f938.jpg?t=1366989951

Second image slightly exaggerated courtesy of photobucket...encourage you to go ingame and check for yourself.

Edited by NodUnit

Share this post


Link to post
Share on other sites

Same issue with dynamic lighting. At midnight my FPS dies, but at dawn/dusk (when the lights are still on) dynamic lighting is great and has little impact on performance.

Share this post


Link to post
Share on other sites
in relation to backward compatibility (removed script commands) , we are internally looking into it and if possible we will try come up with some solution

Please don't worry about backward compatibility. Screw the hackers!

Share this post


Link to post
Share on other sites
Same issue with dynamic lighting. At midnight my FPS dies, but at dawn/dusk (when the lights are still on) dynamic lighting is great and has little impact on performance.

That's interesting, and I can report the same. At 3:15am on the editor default date, it's still pretty dark, street lights are lit, and I'm getting no hit on performance.

Share this post


Link to post
Share on other sites

Anyone else having problems joining servers (shows green in MP lobby) using 0.55.104588? I get to the game lobby but are kicked with a "Session lost" after 5-10 seconds, I tested several green servers and same thing?

/KC

Share this post


Link to post
Share on other sites
That's interesting, and I can report the same. At 3:15am on the editor default date, it's still pretty dark, street lights are lit, and I'm getting no hit on performance.

dawn/dusk performance is in between for me (again, looking down on airfield):

day: 50+ fps

dawn/dusk: 30-40 fps

night: <20 fps

Share this post


Link to post
Share on other sites

There is tooooo much FPS drop at night on the latest dev build! in the daytime I have about 50 fps but at night only 20 or less! It nealy is not playable!

I5 2550K and HD 5870

NO AA and NO POST PROCESS, VIEW DISTANCE IS 2500M

Share this post


Link to post
Share on other sites

I noticed the helicopters handle really nice now (tested with AH-9 and MH-9). Am I imagining things or just getting better? Was able to do some really precise landings (with joystick, no auto-hover) where previously 50% landings were kind of rough. The AH-9 flight model feels a bit twitchy compared to MH-9 tho. They do have almost identical air frame (and probably close mass) so I wonder why. In any case, really enjoying MH-9 FM right now :)

Although that annoying bush/foliage LOD problem is still present. I think it might not even be related to foliage only as I have seen helicopter model LOD states changing the same way.

Share this post


Link to post
Share on other sites
Please don't worry about backward compatibility. Screw the hackers!
Pretty much this, would be nice to see the engine actually advance without having to be hindered by legacy support.

Share this post


Link to post
Share on other sites

such thinking it would also break the concept of being able use, utilize and play A1, A2, OA, TOH content (both ours and community) inside Arma 3

so instead of rushed stopgap it needs some well though out solution (like compatibility mode (by default off)) or similar ...

Share this post


Link to post
Share on other sites

I believe that Kremator and I both meant that we were perfectly willing to lose said A1/A2/OA/TOH content for a tightened security framework; I'm not blind to the fact that the current changes also means that some people have to revise their mission creating.

Edited by Chortles

Share this post


Link to post
Share on other sites
There is tooooo much FPS drop at night on the latest dev build! in the daytime I have about 50 fps but at night only 20 or less! It nealy is not playable!

I5 2550K and HD 5870

NO AA and NO POST PROCESS, VIEW DISTANCE IS 2500M

Same here. Getting really bad performance drops of about 20-30 fps which make the game unplayable. Dynamic lightsources are visible for a very long range.

Regarding the backwards compatibility, it should definitely have a reasonably high focus as it's a massive pool of potential and content for the new engine!

Share this post


Link to post
Share on other sites

Doesn't said backwards compatibility rely in not changing the engine so much, which is how we got to these past few days' problems in the first place? (I'm not just talking about BIS_fnc_MP here.)

Share this post


Link to post
Share on other sites

OK so it would mean people writing their missions to work with Arma3 (then into Arma2/TOH etc) but so be it.

Share this post


Link to post
Share on other sites

Also unplayable for me. Day: 40 fps @ 4000m Viewdistance. Night: 9 fps @ 4000m. Max playable viewdistance at night is 300m.

I also found a (very) small bug in the editor:

unbenannt-2etjua.jpg unbenannt-3ewkx6.jpg

This pixel error is visible on every background color and always stays at the same place.

Share this post


Link to post
Share on other sites

I have to report that I also have a huge fps drop on the newest beta patch. The dynamic lights are superb, but from around 40+ fps i got around 15. I5 3570 and H7870.

Share this post


Link to post
Share on other sites

Yep, night is bugered

Changing dynamic light quality makes very little change.

Looking for ticket...

Share this post


Link to post
Share on other sites

Using latest Dev branch/bianaries, not a techy but so much better than -server an mostly all in all noticeable hickup in Agia Marina an upon enemy contact but on my end I nvr dropped below 20 fps for me thats a drastic improvment:yay:

http://steamcommunity.com/profiles/76561198011868995/home

Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130318-1533)

BIOS: BIOS Date: 01/25/13 20:22:53 Ver: 04.06.05 Processor: AMD FX-6100 Six-Core Processor (6 CPUs), ~3.3GHz

Memory: 4096MB RAM

Available OS Memory: 4060MB RAM

Page File: 5078MB used, 3038MB available

DirectX Version: DirectX 11

Card name: NVIDIA GeForce GTS 450

Manufacturer: NVIDIA

Chip type: GeForce GTS 450

DAC type: Integrated RAMDAC

Device Key: Enum\PCI\VEN_10DE&DEV_0DC4&SUBSYS_14523842&REV_A1

Display Memory: 2752 MB

Dedicated Memory: 978 MB

Shared Memory: 1773 MB

Current Mode: 1280 x 1024 (32 bit) (75Hz)

Monitor Name: Generic PnP Monitor

Share this post


Link to post
Share on other sites

Can someone explain to me how to set a dynamicilly spawned unit/vehicles Init with out using setVehicleInit?

Am i correct that compileFinal replaces processInitCommand? I really am NOT a good scripter so this news really cuts deep!

I just realized that All of my missions use UPSMON.. Now i know that I am not the only person to use it. And the thought of how many user made missions that are now basically broken, makes me a sad panda..

Edited by Lordprimate

Share this post


Link to post
Share on other sites

I'm sure it will be fine. If they decided to completely drop SQF coding and instead use bananas I don't care. This is an alpha and I'll wait to see what BIS come up with. OK so coding in bananas is a little bonkers but you get my drift.

Share this post


Link to post
Share on other sites

I just seem to be getting complete random frame drops with this build, looking at the same location go from 51fps down to 22 and back to 59 ? also a lot of random pausing.

Share this post


Link to post
Share on other sites
Still runs like crap on an i7 2600. & gtx 560ti, sorry but I have better things to do with my time.

Hey thats cool, but remember its still an alpha. Ive experienced improvements the last few weeks, on an older I5 cpu and 570. They are working on it, and confirmed Nvidia updates. ATI apparently got improvements already.

Share this post


Link to post
Share on other sites

I don't see the reasons behind performance complaints. I ran Arma CO comfortably on a 2500K @ 5.0GHZ w/ GTX670 and do the same with A3. It's all CPU speed.

Example 1: Editor placed units

http://www.youtube.com/watch?v=8sK06uOW0D8

Example 2: 61 player COOP

http://www.youtube.com/watch?v=WBhSXDctY-g

Example of A2CO at max everything (6950 crossfire):

http://www.youtube.com/watch?v=7F7Y6l9RYU8

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×