Jump to content
.kju

All in Arma (AiA) - TKOH/OA/A2/A1 merge with A3

Recommended Posts

Hi , iam intriuged if you had problem with Ponds and other water surfaces when drawn ?

maybe your configs are stopping the problem i have where Water is used from A2 , meaning Ponds and water_surface, this would be interesting if you have found and fixed or it simply works because you bring the old configs .

thanks for your time

Share this post


Link to post
Share on other sites
thanks metacraze, i found it 2 minutes after posting :-P. Still soldier-weapon bug there:

http://cloud-2.steampowered.com/ugc/882978867915813832/BA5BF4D1B2AA6C81BC1B01F06A9A158E96AF74B1/

Got the same problem. It's probably because the config is requiring CA_Anims instead of A3_Anims_F. Maybe. Either way, the solution might be to make sure that they aren't using the Arma 2/OA animations.

Share this post


Link to post
Share on other sites
;2368863']@ metalcraze

I will add defaults for the new parameters and clouds' date=' yet no extensive tweaking by me.

Sakura Chan's will be far better anything I can do anyway. :o

@ twisted

The recoils are currently broken. Will be fixed with tomorrows update. Thanks!

@ zhrooms and Ezcoo

Thanks both of you for the setup guides. Can I add them to the wiki please?[/quote']

You're free to share the guide in any way you want mate :)

Share this post


Link to post
Share on other sites
Thank you for this .kju, works great for me!

I couldn't get it to work with either Steam launch parameters or shortcut because the character limit cut off the end of the startup parameters. So I created a .bat file to bypass the character limit:

Just copy the text in the quote box above to Notepad, replace the paths of Arma with your own Arma paths and save it as yourfilenamehere.bat . (Note: You need the quotation marks around the arma3.exe and -mod= lines if you have any spaces in your Arma paths, e.g. in folder names.) You can now launch your Arma without the annoying startup parameter character limits by clicking the .bat file.

If you want to add custom startup parameters like many do, put them between the Arma3.exe and -mod= lines:

Hope others having the same issue find this useful!

Thanks for that tip, great idea, made a .bat file and put the load details into that.

Just a thought, if I wanted to point to an exterior HDD (for more AI & A2 terrains), would I add that info in the .bat file into that load line ?

There would only be two folders as the terrains are pre-sorted..

@Kju:

Thank you very much for this ‘kju’, its your usual fantastic work. Really looking forward to following your progress and supporting this project..:)

Regards the water, I was using another similar setup I got somewhere, anyway the A3 water was/is used for the A2 islands (underwater swimming etc), will have a look, see where I put it..

Share this post


Link to post
Share on other sites
Thanks for that tip, great idea, made a .bat file and put the load details into that.

Just a thought, if I wanted to point to an exterior HDD (for more AI & A2 terrains), would I add that info in the .bat file into that load line ?

There would only be two folders as the terrains are pre-sorted..

@Kju:

Thank you very much for this ‘kju’, its your usual fantastic work. Really looking forward to following your progress and supporting this project..:)

Regards the water, I was using another similar setup I got somewhere, anyway the A3 water was/is used for the A2 islands (underwater swimming etc), will have a look, see where I put it..

I believe that you can add more stuff by doing so. Haven't tested it myself though, so no guarantee for that :p

I read it somewhere that you can have the A3 water in A2 islands if you don't include the water.pbos from A2 folders. This can be done by eg. creating a modfolder for A3, then copying or creating symbolic links from A2 Addons folder to the modfolder and leaving the pbos related to water out of the modfolder. Then just launch the game with the modfolder, and you should have the A3 water in your A2 islands.

Share this post


Link to post
Share on other sites

Ok, for the animation problem, the only solution is to delete, rename, or move the anims.pbo and anims_e.pbo files in your Arma 2 and Arma 2 Operation Arrowhead directories. Because the animations are defaulting to those instead of the Arma 3 ones.

Share this post


Link to post
Share on other sites
I read it somewhere that you can have the A3 water in A2 islands if you don't include the water.pbos

Thanks , if this is how KJU has done it then the ponds wont be in the Islands i guess , however maybe he has solved it with a config i try and see .

Share this post


Link to post
Share on other sites

Its great diving around the USS Khe Sanh in Utes waters, shame there's no signs of fish life anywhere, bubbles though..;)

I was using this arrangement (YT I think is where it came from), leave what you see in, the rest take out, just these two folders. Seemed to work o.k. I didn’t really use it. Not sure if its advisable to use it with kju's here..

Addons in ‘Arma 2’

http://imageshack.us/a/img545/3127/desktop2013040919581830.png

Addons in ‘expansions’

http://imageshack.us/a/img832/1049/desktop2013040919534088.png

Share this post


Link to post
Share on other sites

@ Thromp

Can you please be more specific. Would some screenshot show what you mean?

@ Ezcoo

What do you mean with "A3 water"?

@ antoineflemming

Your modline seems faulty.

@ ChrisB

Sealife is still to come, as is underwater grass.

Share this post


Link to post
Share on other sites
;2368961']@ Ezcoo

What do you mean with "A3 water"?

The water where you can dive underwater like in A3.

Share this post


Link to post
Share on other sites
;2368961']

@ ChrisB

Sealife is still to come' date=' as is underwater grass.[/quote']

Your a star..

No wait, your better than that, your a 'Superstar' ;):)

@Ezcoo, I've been diving off the coast of Utes, isn't it already A3 water, although to be honest I haven't really bothered with the water around Stratis yet..

Edited by ChrisB

Share this post


Link to post
Share on other sites

@Ezcoo, I've been diving off the coast of Utes, isn't it already A3 water, although to be honest I haven't really bothered with the water around Stratis yet..

Then I might have misunderstood something. There was a discussion somewhere here where people asked how to get the diveable A3 water on the A2 islands, and the answer that seemed to work was to leave the A2 pbos related to water out to get it to work. I haven't tested it myself yet.

Share this post


Link to post
Share on other sites

UPDATE: NM - FM FTW

I'll try to be exhaustive - maybe it'll be obvious to someone else.

I've tried the steam launcher, Play withSix, and a batch file to try AiA, but I still get the same errors: "No entry 'config.bin.tooltipDelay' and "Shaders not valid (mismatch of exe and data)". I've checked and rechecked my paths and files. I have no idea what's wrong.

Here are my paths to everything, taken by right-clicking the exe or directory and copy pasting path right to this post:

Arma 2 - G:\Games\steamapps\common\Arma 2

Arma 2 Operation Arrowhead - G:\Games\steamapps\common\arma 2 operation arrowhead

Arma 2 Operation Arrowhead/Expansion - G:\Games\steamapps\common\arma 2 operation arrowhead\Expansion

Arma 3 - G:\Games\steamapps\common\Arma 3

My directory listings showing locations of required downloads:

Arma3/@AllInArma/addons:

-AiA_yadda.pbo (all 19 files)

-LoadAfteraA3Data_C_PvPScene.pbo

Arma3/@AllInArma/dta:

-AiA_Languagecore.pbo

This is my Play withSix Startup Parameters for Arma 3 Alpha: "-mod=G:\Games\steamapps\common\Arma 2;G:\Games\steamapps\common\Arma 2 operation arrowhead;G:\Games\steamapps\common\arma 2 operation arrowhead\Expansion;G:\Games\steamapps\common\Arma 3;@AllInArma" "-world=empty" -nosplash

My Play withSix switches are all checked (as in Sickboy's screenshot)

The batch file i tried:

echo off

start "" "G:\Games\steamapps\common\Arma 3\arma3.exe" "-mod=G:\Games\steamapps\common\Arma 2;G:\Games\steamapps\common\Arma 2 operation arrowhead;G:\Games\steamapps\common\Arma 2 operation arrowhead

\Expansion;G:\Games\steamapps\common\Arma 3;@AllInArma"

pause 

Also, Steam is Set to Dev Branch.

What the heck am i doing wrong?

Edited by taintmelter

Share this post


Link to post
Share on other sites

Kju,

THANK YOU for making this! After following the instructions on Armaholic to the letter, I was able to load everything up no problem! I also found how to add additional A2 mods by simply extending the command line. This is going to help me troubleshoot my addons to see how they work with the Alpha.

Works like a charm!

Share this post


Link to post
Share on other sites

I'am looking forward to this, because i think Arma never reached his true potential. They should make their whole system more modding friendly anyway. The DayZ Standalone showed that its way possible to make some kind of model kit available and also way more indoor locations and so on and so on. Would be a great thing throw all the already made content togehter and build the best of opportunities.

Share this post


Link to post
Share on other sites

This won't fit in the target line or parameter line.

-nosplash -world=empty -cpucount=4 -exthreads=7-maxmem=2048 "-mod=C:\Program Files (x86)\Steam\SteamApps\common\Arma 2;C:\Program Files (x86)\Steam\SteamApps\common\ARMA 2 Operation Arrowhead;C:\Program Files (x86)\Steam\SteamApps\common\ARMA 2 Operation Arrowhead\Expansion;C:\Program Files (x86)\Steam\SteamApps\common\Arma 3;@AllInArma"

Share this post


Link to post
Share on other sites

^^^Read previous posts: you'll need to either create .bat file or use a launcher such as Six or do like I did and dump/condense all needed files into one addon folder - pretty stupid of me since I could have just Sym-linked them :o

Share this post


Link to post
Share on other sites

Yes my fault I just re-read it however I'm getting a error

No entry 'config.bin.tooltipDelay' error it launches to a black screen then it crashes and gives me the error "Shaders not valid (mismatch of exe and data?)"

I'm using the dev build on steam and no other mods.

Share this post


Link to post
Share on other sites
Then I might have misunderstood something. There was a discussion somewhere here where people asked how to get the diveable A3 water on the A2 islands, and the answer that seemed to work was to leave the A2 pbos related to water out to get it to work. I haven't tested it myself yet.

I have seen other methods of getting A2 content working and yes leaving the water PBO's allows water to work properly in A3. In fact a number of things were left out so that things work a lot better. I would think that doing it this way would lead to a lot of issues.

Share this post


Link to post
Share on other sites

You always bring the big guns! Love this! Have been shoehorning Caa1 into A3 up til now will start working with this!

Great work as always!

Share this post


Link to post
Share on other sites

@ taintmelter and Slendermang

Sorry to hear about your troubles. Unfortunately it is messy to set up.

Can you please post your rpt file.

Share this post


Link to post
Share on other sites

Hello and thanks for the fine work, but does it fix the issue with Arma 2 jets not moving on ground and sinking problems on some models?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×