Jump to content
shay_gman

MCC Sandbox 3 - Dynamic mission creating tool for ArmA 3

Recommended Posts

Not your fault mate, just you was the first to implement it. It just a matter of time. I think it is better to work with the system as at the end someone somewhere will implement it and screw as over. 

 

Yeah, i have no doubt there will be other instances of this throughout the modding community for a while. But as long as the default value for the mode is 2 (for backward compatibility according to bohemia) setting the mode to 1 will cause these issues. So for now i think best practice is to define your whitelists for functions and commands and leave the mode at 2. One day maybe when they decide its been long enough and change the default to 0 then it will be prudent to set the mode to 1 inside your mod if you use remote calls. But i fear this day may never come.

Share this post


Link to post
Share on other sites

I was just wondering if im being stupid or not, but me and my friend are playing on his server but i cant use the mcc console where he can. can someone help?

Share this post


Link to post
Share on other sites

"Just some gun Mods" and "I think" are not very precise xD As you can read in the later posts some mods have caused the mod not working properly after the latest update!

Anyway, I'm not sure if shay already updated MCC. 
Is your friend host/admin on the server? Has the "Access Rights" Module been placed on the mission?

Share this post


Link to post
Share on other sites

If you are having trouble logging in there is a quick hotfix. Put this in your mission description.ext file. 

class CfgRemoteExec {        
       class Functions {
               mode = 2;
               jip = 1;
       };
}; 

Share this post


Link to post
Share on other sites

Were not using any mods anymore but i still cant access the mcc menu. it say wont progress from the mcc login screen.

Share this post


Link to post
Share on other sites

Ohhhhhh, so it works for both but only for one at the time? That's intentional! (Pretty sure, correct me if I'm wrong) 

Share this post


Link to post
Share on other sites

Im unsure but its kinda annoying. we can live with it but if theres a way around that would be great.

Share this post


Link to post
Share on other sites

i have a problem starting MCC ingame since i use the new CBA mod version CBA_A3_v2.2.0.151130 - without this it works, but i need CBA for some Maps - is there any solution ?

Share this post


Link to post
Share on other sites

That is the way it is designed. Only one logged in at a time. Probably why there is a login otherwise why even bother with a login.

 

Im unsure but its kinda annoying. we can live with it but if theres a way around that would be great.

Share this post


Link to post
Share on other sites

Shay,

 

Have a minor bug report. Took me a while to figure out why units were disappearing on me from time to time when I went into MCC. I use CTRL-DELETE to open MCC. Lots of times if / when I had a unit selected in the main screen it will be deleted when I start MCC with CTRL-DELETE. My guess is a simple DELETE key press is still getting through and deleting my previously last selected unit.

Share this post


Link to post
Share on other sites

 

I have a problem with new version of MCC.

Setting:

Eden + ACE + RHS + TFAR + CBA

When i try to hijack unit placed in eden i have such error:

 9:54:17 Error in expression <riable ["MCC_allowed",true,true];

_ok = _targetUnit addEventHandler ["Killed", f>

 9:54:17   Error position: <_targetUnit addEventHandler ["Killed", f>

 9:54:17   Error Undefined variable in expression: _targetunit

 9:54:17 File mcc_sandbox_mod\mcc\general_scripts\unitManage\um.sqf, line 116

When i try to hijack unit placed with MCC i also recieve this error.

Additionaly after such action, MCC position is multiplied in action menu.

---

I forgot to mention that i run MCC in editor preview not in the mission itself.

 

Test it from the mission please.

 

It also happen in mission.

I think i know what is the reason. And the reason is i just press "hijack" without selection of any unit.

Hijacking works without errors only if: i've selected unit in mcc panel AND i've selected unit also in Units area in mcc panel.

I suppose there is a need of some "if" in scripts.

 

Another request to hijacking.

This transition animation between hijacked persons is completely unnecessary. It is just time consuming element.

 

And a request to zones.

I remember i asked you about it however you didn't give me any specific answer. No matter...

Nowadays there is no ability to remove zones. I know they may be reused but there is a moment i have so many of them that management of those zones (usualy moving to the border of the map) is significant part of mission.

It would be splendid if there would be just possibility of remove them.

Share this post


Link to post
Share on other sites

Silola

Was that a typo or does Silola now work on MCC's development too?  :confused: I thought it was still mainly Shay and Spirit?

Share this post


Link to post
Share on other sites

After the last Arma 3 update I can't export objects placed by MCC to clipboard as I used to.... whenever I press Export MCC (and wait for the objects copied to clipboard message) and I try to paste the code into a mission.sqm it seems like the only objects that it copies are markers. I'm running vanilla except for CBA and MCC

Share this post


Link to post
Share on other sites

Any particular reason why using the cargo function in Zeus with MCC or just MCC by itself no longer works ? It was the easiest way to customize equipment loadouts in real time or when making a scenario. :ph34r:

 

I have also noticed that Thelo.

Share this post


Link to post
Share on other sites

It was a typo!!! Post fixed.

 

Was that a typo or does Silola now work on MCC's development too?  :confused: I thought it was still mainly Shay and Spirit?

Share this post


Link to post
Share on other sites

Moon_chilD, on 05 Dec 2015 - 03:50, said:

Hey guys,

I'm searching for the cause of a very nasty and Random bug I have on my MCC Mission Template. (We use that the generate us missions that we then play)

What is happening is that sometimes when a member joints (JIP) he is stuck. They can't move at all. The only thing they can do is look around and respawn. Respawning however does not really help. They just spawn immobilized again. Only rejoining helps occasionally (not always).

This bug is purely random. I have not found a pattern yet.

My guess would be that the Start Location Module could be the cause. I guess that because this module moves the player 1-4 secs after spawning to the location of the flag. (Besides, can one somehow deactivate the spawning of an object? I actually don't want to have a flag standing around in my FOB xD)

The Start Location Module however seems to be necessary to solve HVT Missions since you have to deliver the captured units to the flag pole. Is there any other way to solve the HVT missions without placing down the Start Location Module. (Maybe with a marker or Trigger?)

As I said, I'm not sure if that is the problem. This is just trail and error. It could also be just MCC with other mods or another mod at all.

The RPT-Log doesn't say anything interesting regarding the immobilization whatsoever.

Many Greetings

Moony

 

I've made some changes to MCC start locations which need to be tested. The hostage mission should be changed to allow completion without the need to place a start location.

 

Doesn't seem to work!

Share this post


Link to post
Share on other sites
MCC Campaign Rescue POW

 

I have created a MP COP mission that places the MCC campaign module on Stratis I made a small base with the BI Respawn_West (As I typically do). When the MCC campaign produces a mission where we must destroy some targets and rescue a captive, when we bring the POW back to the base (Respawn_West), the mission will not complete. If I place the MCC Module Start_Location in the same area of Respaewn_West, when any of the West force dies, they are viewing two death/revive screens, one is the BI revive that I added to the mission but in the back ground I can see the MCC select respawn option.

 

These two question may be related but I would like to have the BI revive parameter to be the only thing the player sees, once the timer has run out, the player respawns at Respawn_West or MCC Start_Location.

 

Any help would be apprecaited or maybe a quick PBO so I can open the editor and learn.

 

Thank you

Share this post


Link to post
Share on other sites

Has anyone figured out the login problem on severs? When even the mission restarts it says, "server no longer commander".

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×