Jump to content
Sign in to follow this  
Fetzer

Sound stuttering in surround-sound with gun fire and vehicles

Recommended Posts

I'm using a Logitech G35 headset and every time I go in surround and people are shooting the sound starts to stutter and becomes garbled, same with vehicles. I have tried turning the volume down and turning bass down but nothing fixes it. The only thing that does fix it is when I go out of surround which I don't like. I have tried other USB ports and downloading the latest drivers again but nothing fixes it. Is it me or just ArmA being in Alpha?

Other games work perfectly fine. Also music sounds fine as well so it is only ArmA 3.

Share this post


Link to post
Share on other sites

Not happening for me with a 5.1 surround sound speak set up and no one has mentioned sound problems in the MP games I've played. Are your other games ok?

Share this post


Link to post
Share on other sites
Not happening for me with a 5.1 surround sound speak set up and no one has mentioned sound problems in the MP games I've played. Are your other games ok?

Other games and music sound perfectly fine

Share this post


Link to post
Share on other sites
I'm using a Logitech G35 headset and every time I go in surround and people are shooting the sound starts to stutter and becomes garbled...

I have the same headset and get the same problem when there are multiple weapons firing simultaneously. I have the latest software/drivers for the G35, but I am using onboard audio so maybe thats the problem - though its never posed a problem before on other games with the same number of sound sources.

Share this post


Link to post
Share on other sites

Try going into your audio settings, and increase the amount of samples. You might be hitting the total amount of samples at one time. That could cause it to stop a previous sound to play a new one.

Share this post


Link to post
Share on other sites

I think this is a G35 issue as I am having the same problem. Even with sound samples at max. I have noticed the same problem in Skyrim too. I doubt the Bohemia devs can do much about it and in not confident Logitech will either. I have started to look for another headset.

Sent from my HTC One X using Tapatalk 2

Share this post


Link to post
Share on other sites
I have the same headset and get the same problem when there are multiple weapons firing simultaneously. I have the latest software/drivers for the G35, but I am using onboard audio so maybe thats the problem - though its never posed a problem before on other games with the same number of sound sources.

All USB headsets process their own sounds they do not use any onboard or dedicated cards for processing. Some do have there own external DSP like the turtlebeach AK-R8's.

If you have a decent sound card it is being wasted if you are using USB headsets, you are relying on their software to process the sound for you. As all sound processing is being done in software you are losing CPU processing time.

For reference

Save yourself some pain and buy a set of decent surround headphones that have 3.5mm connectors.

Share this post


Link to post
Share on other sites

I had this problem with G35 too, I found that on Win7 the software that came on a disc with the headset are much better than the latest software ( the gaming software one ) from Logitech website. Also going into your surround settings and turning down the volume of each speaker a couple of notches helps too, even with the software from Logitech website.

Its definitely an issue with the G35, I wish Logitech would have a look at the driver and update it. Another thing I noticed with the G35 is that I couldnt set the sample rate any higher than 48000/16bit. Its a good headset but the drivers just blow.

Edited by insumsnoy

Share this post


Link to post
Share on other sites

I have the Logitech G930 Wireless 7.1 headset, same problem here. With surround sounds on the audio starts to stutter when more than a few things are happening at once.

Turning surround off makes the issues go away.

I found that after I OC'd my CPU the surround sound worked a bit better but still has issues with stuttering so I suspect it's caused by high the CPU usage of ArmA 3 slowing down the sound processing on the headset.

When I get home I'll look for the logitech process in the task manager and try setting it to high priority and see if that helps.

Share this post


Link to post
Share on other sites

No I'm sorry this didn't solve the problem. I tried this driver package and the stuttering still appeared.

Share this post


Link to post
Share on other sites

Is there any fix for this? Tried the 8.45.88 software, but it doesn't fix this.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×