Jump to content
Sign in to follow this  
sold67

Helicopter insertion(Heli pilot doesnt stick to waypoint on detection of enemy units)

Recommended Posts

I have a helicopter insertion working, but once I add some enemy units and the helicopter gets in view distance of those units it freaks out and no longer sticks to the waypoint and wont make any attempt to get back to it! I've tried a few things like setbehavior and disableai, but so far to no avail. I'd like the helicopter not to care if it is under fire etc, any ideas? Any help is appreciated.

Share this post


Link to post
Share on other sites

Thanks so much, it worked! Got a few other problems though, once the helicopter lands at the waypoint/invisible helipad it takes off again before I get the chance to get out, and it also takes too long to land know of anyways I can speed the landing up, and get the helicopter to say stay on the ground for say 5 seconds?

Here is what I have on the landing waypoints on act:

helicopter land "get out"; James leaveVehicle helicopter;

This works if it is AI most of the time, but if james becomes a player it takes off the second it touches down allowing you no time to get out.

Here is what I have on the helicopters init

helicopter flyInHeight 20; this setCaptive true;

Edited by sold67

Share this post


Link to post
Share on other sites

Tried that, but the AI still takes off before I can get out it. On the final waypoint the one after landing I tried putting this in the on act field:

sleep 15; deleteVehicle helicopter2;

Still no luck!

Share this post


Link to post
Share on other sites

this works fine for me, pilot ignores enemies and proceeds to attempt landing regardless.

_waypoint setWaypointBehaviour "CARELESS";

Share this post


Link to post
Share on other sites

I set a helo to land right into heavy fire, and he would keep turning around halfway in. The only thing that seemed to change it for me was.

_unit allowFleeing false

Share this post


Link to post
Share on other sites

I've managed to fix that problem (thanks animal), but the main problem now as soon as the helicopter lands it take off again - moving to the next waypoint - and you get no time to hop out the chopper.

Share this post


Link to post
Share on other sites

Thanks Marker/Dale! Working great part from one small hiccup if I am in a helicopter with AI it only kicks myself out the chopper and not the AI unless I order them to disembark, so nothing massive thanks for all the help.

Share this post


Link to post
Share on other sites

If you want to delete a vehicle and it's AI crew, add this to the last waypoint of the vechile. (Vehilce is named MH9 in this example)

{deleteVehicle _x} forEach (crew MH9)+[MH9];

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×