Jump to content
Sign in to follow this  

Crash on launch: 'Cannot create DX11 device'

Recommended Posts

I get the following error every time I try to launch the game:

'Cannot create DX11 device'

Adapter (NVIDIA GeForce GTX 590) Fullscreen

Resolution 1920x1200, format R8G8B8A8_UNORM, refresh 100 Hz


I have tried both the latest nVidia driver and the latest nVidia Beta driver, with the same result.

I have also tried using various launch option, including -winxp, -nobenchmark which supposedly worked for some people. I have also tried forcing DX9, but no luck.

I have tried lowering the resolution to 1600x1024, but without effect.

I also tried forcing a 60 Hz refresh rate in case that was the issue, but still nothing. Same error message comes up.

These are my specs:

Mainboard : Gigabyte EX58-UD5

Processor: Intel Core i7 920 @ 2666MHz

Physical Memory: 12288MB (6 x 2048 DDR3-SDRAM)

Video Card: NVIDIA GeForce GTX 590


Edited by MikkelRasmussen

Share this post

Link to post
Share on other sites

This is the result of my DXDIAG:


System Information


Time of this report: 3/14/2013, 18:32:09


Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600) (7600.win7_gdr.120503-2030)

Language: English (Regional Setting: English)

System Manufacturer: Gigabyte Technology Co., Ltd.

System Model: EX58-UD5

BIOS: Award Modular BIOS v6.00PG

Processor: Intel® Core i7 CPU 920 @ 2.67GHz (8 CPUs), ~2.7GHz

Memory: 12288MB RAM

Available OS Memory: 12286MB RAM

Page File: 6315MB used, 18253MB available

Windows Dir: C:\Windows

DirectX Version: DirectX 11

DX Setup Parameters: Not found

User DPI Setting: Using System DPI

System DPI Setting: 96 DPI (100 percent)

DWM DPI Scaling: Disabled

DxDiag Version: 6.01.7600.16385 32bit Unicode


DxDiag Notes


Display Tab 1: No problems found.

Sound Tab 1: No problems found.

Sound Tab 2: No problems found.

Input Tab: No problems found.

Should I be concerned by the bit that says: "DX Setup Parameters: Not found"?

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this