Jump to content
Sign in to follow this  
Calat

Cannot create DX11 device

Recommended Posts

2fm0k.jpg

I solved my first problem but know when i try to launch ArmA 3, i have this error :(

My GPU is a Sapphire HD 7850 1Go, my monitor (1280x1024) is connected with a VGA adapter (like this one : vga2dvi.jpg )

My monitor have a refresh rate of 60hz, i think the problem is here... An idea... ? :confused:

...

:smash:

Thank you for all :)

Share this post


Link to post
Share on other sites

reinstall gpu drivers even if you already have latest ones, who knows, try a diff version.

also, try -winxp as a launch parameter.

Share this post


Link to post
Share on other sites

You can try editing your cfg file; In Win7 at C:\Users\<yourWindowsUsername>\Documents\Arma 3 Alpha\Arma3Alpha.cfg back it up first

Find the line that reads

refresh=##;
and replace it with
refresh=60;

Then try also starting Arma3 with -nobenchmark after the edit.

Edit: Otherwise make sure in windows that your card does not allow the 75Hz modes at all, you might need to go into some advanced driver properties/control panel to remove unwanted resolutions/refresh rates.

Share this post


Link to post
Share on other sites
You can try editing your cfg file; In Win7 at C:\Users\<yourWindowsUsername>\Documents\Arma 3 Alpha\Arma3Alpha.cfg back it up first

Find the line that reads and replace it with

Then try also starting Arma3 with -nobenchmark after the edit.

Edit: Otherwise make sure in windows that your card does not allow the 75Hz modes at all, you might need to go into some advanced driver properties/control panel to remove unwanted resolutions/refresh rates.

I have a similar problem(See thread: http://forums.bistudio.com/showthread.php?149158-Crash-on-launch-Cannot-create-DX11-device

I tested your suggestion about setting the refresh rate in the Arma3alpha.cfg file. Didn't solve the problem unfortunately.

Edited by MikkelRasmussen

Share this post


Link to post
Share on other sites
You can try editing your cfg file; In Win7 at C:\Users\<yourWindowsUsername>\Documents\Arma 3 Alpha\Arma3Alpha.cfg back it up first

Find the line that reads and replace it with

Then try also starting Arma3 with -nobenchmark after the edit.

Edit: Otherwise make sure in windows that your card does not allow the 75Hz modes at all, you might need to go into some advanced driver properties/control panel to remove unwanted resolutions/refresh rates.

Arma 3 never launched, so my config file is not complete like you can see:

2fy9Y.jpg

Can you send me the full config file please ? :o

Share this post


Link to post
Share on other sites

Meeh, this suggestion won't work in your case then. Sorry. There are specific adapter associations which would be incorrect if I sent you the cfg file, or anyone else for that matter. Thought this had gone through already.

Share this post


Link to post
Share on other sites

I'm getting the same problem since todays update:

First this:

armaerror01.png

Then this:

armaerror02.png

UPDATE:

After disabling all my Mods I loaded in without issue so it must be one of them not playing with the update.

Edited by El_MUERkO
New info

Share this post


Link to post
Share on other sites

Verify you gamecache file with steam then restart your computer..... worked for me

Share this post


Link to post
Share on other sites

If you have a Nvidia, use the parameter: -maxVRAM=999 in your shortcut or in the steam startup parameters.

Worked fine for a friend.

Edit: Oups, I have not seen that you are on ati.

Try deleting the "Arma 3 Alpha" and the "Arma 3 Alpha - Other Profiles" folder in your document and restart the game.

Also try the verification file as mentioned above.

Edited by matt2507

Share this post


Link to post
Share on other sites

Does not work...

I will install windows 7 family in dual boot

maybe one of my programs is in conflict with ArmA 3 :(

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×