Jump to content
Sign in to follow this  
thevisad

Arma 3 Restarter.exe server monitor

Recommended Posts

thanks for the update, another question though. I see that -nosound is not supported, any way to support turning off sound on the server or is it auto??

Share this post


Link to post
Share on other sites

I think the -nosound param doesn't do anything when you run -server anyway.

Share this post


Link to post
Share on other sites

I dont know why didnt ask this earlier, however, I also do not see it asked any where else.

Is there a way to trick this to launching another -client to use the "headless client" feature??

Share this post


Link to post
Share on other sites
I have fixed the issue where I was logged into steam.

I am now faced with a new issue.

The port is not being used by another server. I have tried multiple different ports. I blacked out the IP for the photo.

http://i.imgur.com/B2myeaO.png

1. is windows firewall off?

2. before starting a server run netstat -na and see what ports are actually in use and listening.

Share this post


Link to post
Share on other sites
I dont know why didnt ask this earlier, however, I also do not see it asked any where else.

Is there a way to trick this to launching another -client to use the "headless client" feature??

Great idea, I was thinking about implementing this as well since I want to run some headless clients. I will add this as a switchable option.

Share this post


Link to post
Share on other sites
Great idea, I was thinking about implementing this as well since I want to run some headless clients. I will add this as a switchable option.

yes please and thank you!!!

EDIT:

just reading and thinking and i realized and wanted to point out incase it slipped by..

If you can add the -noSound and password= to the parameters then when you launch a -client for the HC it will not get started with sound. And if the server is password-ed then you'll need the password= param to get the HC to log in. and maybe -netlog?

Edited by Lordprimate

Share this post


Link to post
Share on other sites
yes please and thank you!!!

EDIT:

just reading and thinking and i realized and wanted to point out incase it slipped by..

If you can add the -noSound and password= to the parameters then when you launch a -client for the HC it will not get started with sound. And if the server is password-ed then you'll need the password= param to get the HC to log in. and maybe -netlog?

I added the -nosound option automatically, since its a server/HC there is no point in sound. I also added the netlog option. I will add the password field next, I have it starting the HC without issues at the moment, its just not connecting to the server properly. Since I am recoding sections, anything else I should be adding support for?

---------- Post added at 00:52 ---------- Previous post was at 00:14 ----------

Ok, Corrected the issue with the client connections and updated the top post with the new settings and the new download for the restarter.

Share this post


Link to post
Share on other sites

what does -connect=localhost do?? I cant Wait to try it Thanks!!!!!!!!

I cannot get the HC to connect to a passworded server .

EDIT: tested with password=.. and with out and with out password=.. the hc can't connect if using a password, I know I am using the the correct password...

Edited by Lordprimate

Share this post


Link to post
Share on other sites

What I would like to see to make your restarter 100% useful for me is a timer= option in the config. This would allow the user to specify timer= [hours/minutes/seconds] (whichever unit of measure you see fit) to have it auto-restart the server after the timer expires. Right now I have to run a separate batch file to kill the arma3.exe after X seconds to perform my server restarts.

Share this post


Link to post
Share on other sites
Download link is dead. Noooooo.

Heh, thats what I get for doing maintenance during the day, its back up.

---------- Post added at 15:16 ---------- Previous post was at 15:02 ----------

what does -connect=localhost do?? I cant Wait to try it Thanks!!!!!!!!

I cannot get the HC to connect to a passworded server .

EDIT: tested with password=.. and with out and with out password=.. the hc can't connect if using a password, I know I am using the the correct password...

I will look into this.

---------- Post added at 15:18 ---------- Previous post was at 15:16 ----------

What I would like to see to make your restarter 100% useful for me is a timer= option in the config. This would allow the user to specify timer= [hours/minutes/seconds] (whichever unit of measure you see fit) to have it auto-restart the server after the timer expires. Right now I have to run a separate batch file to kill the arma3.exe after X seconds to perform my server restarts.

That's pretty much how I do it myself, but I use windows events to process the kill requests. I can look into it, coming from a server that connects to a DB, we never liked doing this, wanting to gracefully shut down the server instead. I will play around with some options tonight.

Share this post


Link to post
Share on other sites

That's pretty much how I do it myself, but I use windows events to process the kill requests. I can look into it, coming from a server that connects to a DB, we never liked doing this, wanting to gracefully shut down the server instead. I will play around with some options tonight.

I agree with you here. With my other servers, I use scripts combined with BEC for proper shut down and restarts, but since BattlEye is not yet enabled with A3A, we're left with little choice.

Share this post


Link to post
Share on other sites

hi,

1st of all iam a Noob and need advice, or i really going crazy.

What is the difference between server/server and server/client ? i need only a Server/Server i think.

We would like to run 2 servers. Clearly, I need 2 servers / server right ?

next problem is, we placed the basic.cfg Files(and server.cfg)

language="English"; 
adapter=-1; 
3D_Performance=100000; 
Resolution_Bpp=32; 
Windowed=0; 
MinBandwidth=157200000; 
MaxBandwidth=813741824; 
MaxMsgSend=92; 
MaxSizeGuranteed=128; 
MaxSizeNonguaranteed=64; 
MaxCustomFileSize=0; 
serverLongitude=-115; 
serverLatitude=36; 
serverLongitudeAuto=-115; 
serverLatitudeAuto=36;

in the profil Directories which was created by the Restarter.ini File.

[Global]

[hngamers_1_stratis]
name=Reality
profiles=hngamers_1_stratis
config=hngamers_1_stratis\server.cfg
cfg=hngamers_1_stratis\basic.cfg
world=stratis
port=2326
cpuCount=2
exThreads=7
netlog=true
server=server
filepatching=false
rankingfile=hngamers_1_stratis\ranking.log

[hngamers_2_stratis]
name=RealityHC
profiles=hngamers_2_stratis
cpuCount=2
exThreads=7
netlog=false
server=client
connectip=127.0.0.1
connectport=2326
password=whatever

the server=client always start. But the 1st server(server=server) do not start. we only get always this Error: " Reality: invalid basic.cfg location: hngamers_1_stratis\basic.cfg..........."

i really need your help !

thx in advance

solved ! same Noob Error like others, wrong cfg Name

Edited by [J4F] Thunder666

Share this post


Link to post
Share on other sites

server=client means this is a headless client, in almost all cases you want to use server=server unless you are an advanced user and will be using a HC on your servers. invalid config usually means you do not have a config file in the folder specified, in your case this would be. cfg="hngamers_1_stratis\"

Share this post


Link to post
Share on other sites

invalid config usually means you do not have a config file in the folder specified, in your case this would be. cfg="hngamers_1_stratis\"

so i know what this means and this is the Problem. We have the basic.cfg File in the specified Folder "cfg=hngamers_1_stratis\".

Therefore I wrote the following.

next problem is, we placed the basic.cfg Files(and server.cfg) in the profil Directories which was created by the Restarter.ini File.

why I still get the error message ?

greetings

Share this post


Link to post
Share on other sites

Hi Guys

How do i stop steam from loading whe i start my server? i have read many post but still getting nowhere with this XD

Thanks

Ben

Share this post


Link to post
Share on other sites

The package contains everything you need for that. Copy everything from the package to the root of your arma 3 folder

Share this post


Link to post
Share on other sites

How does netlog=true work? and where does it save?

Share this post


Link to post
Share on other sites
Any chance to get a restarter.exe for the new arma3server.exe?

Yeah, give me a few and I will make a switch for it.

Share this post


Link to post
Share on other sites

thanks for this BTW very handy before i got my hands on the dedi files :p

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×