Jump to content
dslyecxi

ShackTac User Interface (STHUD, STGI, and more)

Recommended Posts

I'm not sure about anybody else, but the update is not working for me. Same behavior as before I got the updated PBOs.

Share this post


Link to post
Share on other sites

Greetings!

The past week or so after we updated mods on our current repo (unsure what version of Shacktac we ran prior to 1.2).

Sadly now, stances, stamina and the general hud on the top right is hardly visible.

Stances and stamina is completely invisible unless you open your map, then you can barely see it.

The general hud area with weapon information is only active for ~3 seconds when anything happens (like changing gun), and then it fades out again.

 

Any clue how to make it all stick there permanently? I hate not being able to tell my stamina, or what grenades I've equipped. (And looking at my knees to know if I'm crouched or standing is getting wonky :< )

 

Thanks!

Share this post


Link to post
Share on other sites
9 hours ago, serjames said:

apparently updated on STEAM... anyone got a link to a non steam version ?

 

https://drive.google.com/open?id=0B_2zc8eRe8ZTaUVrZF9IMEMyTzQ - Hot from the workshop, served without any artificial flavors or colors

 

I'll take the mirror down when my our favorite hombre foxhound puts it on ArmAholic

Share this post


Link to post
Share on other sites

I deserve more credit....armaholic has been updated almost right after the update.

  • Like 5

Share this post


Link to post
Share on other sites

Thanks to both of you. ! :-)

 

We got it working ok last night. Some cosmetic changes too.

Share this post


Link to post
Share on other sites

The latest patch only works 100% with vanilla maps. For example CUP terrain map + STUI + CBA causes the game still to freeze when the mission is loaded on the following maps.

 

Bukovina

Porto

Desert

 

  • Like 1

Share this post


Link to post
Share on other sites

Same issue here with 1.68. With the STUI set loaded, the game crashes when you press continue from the briefing screen. Seems the crashing happens on all maps for me though.

Share this post


Link to post
Share on other sites
8 minutes ago, Zantza said:

Same issue here with 1.68. With the STUI set loaded, the game crashes when you press continue from the briefing screen. Seems the crashing happens on all maps for me though.

Have you updated your STUI?

Because as I pointed out several weeks ago, the previous version is incompatible with A3's 64-bit platform

Guess what, an update has been released that fixes this

https://www.reddit.com/r/arma/comments/5zt8jr/psa_stui_causes_all_missions_to_crash_on_64_bit/

Next time just subscribe to STUI via Steam and it'll update automatically

Share this post


Link to post
Share on other sites

Can confirm desert is crashing still with the new version. Same point as before the fix.

11:26:51  Mission id: a6bc204f1abd82a1115867cb9fde6a07663854fc

then hang.

 

 

Share this post


Link to post
Share on other sites

Hi,

 

There the possibility to update the STHUD only ? Because with the STUI we can't manage what we want on the HUD (player name or not, azimut or not etc ...)

Share this post


Link to post
Share on other sites

I'm not in need of the group indicators and all the other modules this forces me to install so is there another addon which only provides a small compass in the lower middle of hud, does anyone know by chance?

Share this post


Link to post
Share on other sites
On 17/03/2017 at 4:08 PM, dslyecxi said:

Reporting issues in this thread is generally not helpful, as it's not monitored with any regularity. We have an issue tracker for those sorts of reports: 

https://gitlab.com/shacktac-public/general/issues

 

The reported issue was deleted. does this mean there is a new version out now?

Share this post


Link to post
Share on other sites

Hey guys I'm making a survival mission and STUI is part of our modset and I want to disable the HUD and Group Indicators.

 

Now I've got: STGI_Enabled = false; in the init file and that works a treat. Can anyone tell me if there is a command to disable the HUD?

I tried

 

STHUD_Enabled = false; but it doesn't work.

 

any suggestions?

Share this post


Link to post
Share on other sites

Hopefully it will be on Armaholics, I prefer to get Addons from there, Steam addons gives you less control.

  • Like 3

Share this post


Link to post
Share on other sites

I thought the the current version on Armaholics ( 2017-03-17 ) was still causing a freeze on none vanila maps? will check again.

Share this post


Link to post
Share on other sites

The Armaholic version == Steam version.

So if the Steam version is ok, the same applies to our hosted version.

  • Like 1

Share this post


Link to post
Share on other sites

I tested latest  ( 2017-03-17 ) on a number of none vanilla maps & it seems fine again! Yay! many thanks for all your hard work. :grinning:

Share this post


Link to post
Share on other sites

Where the hell are all the options under the ALT+SHIFT+H menu? Anyone got older version? I was used to turning it off when in zeus, right now its not possible...grrr

Share this post


Link to post
Share on other sites
On 24.3.2017 at 10:07 PM, foxhound said:

No idea why people keep asking for an updated Armaholic page since we, like most times, are fully up to date.

http://www.armaholic.com/page.php?id=29327&highlight=SHACKTAC%2BUSER%2BINTERFACE

 

The problem is that there is another older version online which is causing the freezes and is not up-to-date: http://www.armaholic.com/page.php?id=18949&d=15

Share this post


Link to post
Share on other sites

Do you have a script or something like that that just leaves STHUD like it was before

 

sthud_vehicle_role_icons_1.jpg

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×