Jump to content

Recommended Posts

I seem to be having a problem with the latest update.

Supposedly.. when you die, a black screen fades in and you will be returned to your view showing your soldier lying on the ground and a button to revive (or in the action menu), right?

Well, I'm getting a problem where I'm stuck in the black screen after I died with no respawn option whatsoever. Also, by pressing escape to the menu, you''ll notice you can see through the black screen

and it shows your soldier has already respawned back at the respawn point. You can even move around and fire, but you'll still have the black screen in your way.

Does anyone have any problems like this? I can't seem to find a way to fix it.

On the side note as well, are we suppose to respawn back with default gear from the soldier class that we picked?

Me and my friends are using VAS and whenever we die and spawn back or get revived, we won't have our custom gear.

Share this post


Link to post
Share on other sites
I seem to be having a problem with the latest update.

Supposedly.. when you die, a black screen fades in and you will be returned to your view showing your soldier lying on the ground and a button to revive (or in the action menu), right?

Well, I'm getting a problem where I'm stuck in the black screen after I died with no respawn option whatsoever. Also, by pressing escape to the menu, you''ll notice you can see through the black screen

and it shows your soldier has already respawned back at the respawn point. You can even move around and fire, but you'll still have the black screen in your way.

Does anyone have any problems like this? I can't seem to find a way to fix it.

On the side note as well, are we suppose to respawn back with default gear from the soldier class that we picked?

Me and my friends are using VAS and whenever we die and spawn back or get revived, we won't have our custom gear.

Same problem. The newest version, 9, is just a black screen when you die. You can still shoot a gun, but the screen is all black and the player is dead. Clicking respawn did nothing.

We were using version 8 before, and the revive did work. You were able to come back with the gear you had on you. However, in that version, when you respawned or were revived you were unable to reload and fire your gun even after picking up clips (all your clips were gone as well), hence the reason I updated to the latest version.

Edited by Rickswan

Share this post


Link to post
Share on other sites
I seem to be having a problem with the latest update.

Supposedly.. when you die, a black screen fades in and you will be returned to your view showing your soldier lying on the ground and a button to revive (or in the action menu), right?

Well, I'm getting a problem where I'm stuck in the black screen after I died with no respawn option whatsoever. Also, by pressing escape to the menu, you''ll notice you can see through the black screen

and it shows your soldier has already respawned back at the respawn point. You can even move around and fire, but you'll still have the black screen in your way.

Does anyone have any problems like this? I can't seem to find a way to fix it.

On the side note as well, are we suppose to respawn back with default gear from the soldier class that we picked?

Me and my friends are using VAS and whenever we die and spawn back or get revived, we won't have our custom gear.

I am having similar issues with the newest version, but also having issues when I can revive someone, they no longer have any ammo.

Share this post


Link to post
Share on other sites

it would probably be worth extending this to also check if the person has a MediKit also.

Share this post


Link to post
Share on other sites

Rollback to the Version: 0.9 RC1 (First Page). There aren't any big changes to the latest release. Beside the bugs in that one.^^

Share this post


Link to post
Share on other sites

Hey,

I have encountered a Problem when using the F3 Mission Developement Framework.

When a player gets killed he gets in the "unconscious" state as usual, he can click respawn etc. BUT you can't revive him.

When using the script without it it works perfect.

I have already tried disabling almost every option in the init.sqf aswell as the description.ext

Any advice?

EDIT: Alright, found the Issue myself. had a "RemoveAction" too much.

Edited by mantls

Share this post


Link to post
Share on other sites
Rollback to the Version: 0.9 RC1 (First Page). There aren't any big changes to the latest release. Beside the bugs in that one.^^

Aah okay, 0.9 RC1 works! Thanks! :)

Share this post


Link to post
Share on other sites
Rollback to the Version: 0.9 RC1 (First Page). There aren't any big changes to the latest release. Beside the bugs in that one.^^
Well the problem with that is the link is broken...

Share this post


Link to post
Share on other sites

I have a super newb question :blush: >

How can I change the name of the mission that displays when mission is loading and it shows the map screen in background and the BTC dialog box comes up and it says "UNKNOWN MISSION"

"UNKNOWN AUTHOR"

I've seen other missions where people have used graphics in there along with new mission and author names.

Would i change that in the description.ext by using these parameters:

onLoadName = "Insert short mission name here";

onLoadMIssion = "Insert really short description here";

Author = "Insert your name here";

?? Let me know guys ??

Share this post


Link to post
Share on other sites

I'm going to try "onLoadName"

i.e.

author="Varanon";

OnLoadName = "Point Insertion";

OnLoadMission = "A group of NATO soldiers is tasked with sabotaging a coastal defense.";

loadScreen = "images\loadScreen.paa";

I'm just hoping this replaces the empty BTC dialog box that comes up with "UNKNOWN MISSION"

"UNKNOWN AUTHOR"

Share this post


Link to post
Share on other sites
Well the problem with that is the link is broken...

Anyone have RC1 or know of a fix to this black screen of death issue? The link is broken to RC1 and no updates on this issue.

Forgot to add that this deals specifically with the black screen that a player can not get out of after they die. No mobile spawns, just pretty straight forward.

//SinBad

Edited by SinBad-OTF

Share this post


Link to post
Share on other sites
Anyone have RC1 or know of a fix to this black screen of death issue? The link is broken to RC1 and no updates on this issue.

Forgot to add that this deals specifically with the black screen that a player can not get out of after they die. No mobile spawns, just pretty straight forward.

//SinBad

It's not broken for me.

Share this post


Link to post
Share on other sites
It's not broken for me.

Doh! You are correct, it isn't broken. Just wasn't expecting the page that came up after clicking the link. Thanks for the post, made me check it again.

//SinBad

Share this post


Link to post
Share on other sites
Doh! You are correct, it isn't broken. Just wasn't expecting the page that came up after clicking the link. Thanks for the post, made me check it again.

//SinBad

Oh snap! Yeah, it looked like some random Italian 404 page. I'll try rc1 out when I get the chance. BTW, is there a way to playtest coop/pvp from a single machine, so I don't have to make my buddies playtest scenarios with me?

Share this post


Link to post
Share on other sites

Quick question: Don't have anyone to test right now, but do I NEED to use "respawn = 3;" or does it also work with "respawn = 2;" or even 4?

Share this post


Link to post
Share on other sites

When friendly playable AI was killed. They were respawned.

I set " BTC_disable_respawn = 1; "

Can I set disable respawn to Playable AI?

Edited by Landre

Share this post


Link to post
Share on other sites

just to let you know btc revive does not work with the new update,can anybody help please

it just respawns you back at your start place ,also does not let us keep our kit load out it spawns with the default kits here our kit loadout

_unit = _this select 0;

// Remove original equipment

removeallweapons _unit;

removeallassigneditems _unit;

removeallcontainers _unit;

// Add clothing

_unit addUniform "U_B_CombatUniform_mcam_vest";

_unit addHeadgear "H_Booniehat_mcamo";

_unit addVest "V_PlateCarrier1_cbr";

// Add weapons & grenades

_unit addWeapon "arifle_MXM_F";

_unit addPrimaryWeaponitem "optic_Arco";

_unit addPrimaryWeaponItem "acc_pointer_IR";

_unit addMagazines ["30Rnd_65x39_caseless_mag"' date= 6];

_unit addMagazines ["SmokeShellRed", 3];

_unit addMagazines ["SmokeShell", 3];

// Add items

_unit addItem "FirstAidKit";

_unit addItem "FirstAidKit";

_unit addItem "FirstAidKit";

_unit addItem "MineDetector";

_unit addWeapon "Binocular";

_unit addItem "g_tactical_clear";

_unit assignItem "g_tactical_clear";

_unit addItem "muzzle_snds_B";

_unit addItem "muzzle_snds_L";

_unit addItem "NVGoggles";

_unit addItem "ItemCompass";

_unit assignItem "ItemCompass";

_unit addItem "ItemMap";

_unit assignItem "ItemMap";

_unit addItem "ItemWatch";

_unit assignItem "ItemWatch";

_unit addItem "ItemGPS";

_unit assignItem "ItemGPS";

we call the script sqf by

nul = [this] execVM "loadouts\command\lightninguk.sqf";

look forward to hearing from you

I am running the arma3 alpha version 0.56.104

Share this post


Link to post
Share on other sites

Is it possible to have 2 mobile respawns?

Share this post


Link to post
Share on other sites

I believe BTC Revive is still functioning despite the errors that come up while the mission is loading (errors detail something about Mobile or Vehicle respawn_west).

I've been able to revive other teammates and have been revived myself so I know that part is working.

& we're respawning at our correct respawn point with our custom gear each time too so I don't know why LIghtningUK is having that issue.

Anyways, I hope Giallustio can edit the BTCRevive module A.S.A.P. as I'm sure this is affecting a lot of people.

Share this post


Link to post
Share on other sites

I've had no issue using =BTC= on the latest stable or DEV builds, no script error whatsoever either using -showscripterrors.

Tested without any mods (since some are screwed up with the release changes) and no mobile respawn (never used it) in a MPMission.

Share this post


Link to post
Share on other sites
I've had no issue using =BTC= on the latest stable or DEV builds, no script error whatsoever either using -showscripterrors.

Tested without any mods (since some are screwed up with the release changes) and no mobile respawn (never used it) in a MPMission.

I don't use vehicle respawn either but code for vehicle respawn is within the BTC Revive script and that is what is popping up in the -showscripterrors dialog box. And i don't use ANY other modules besides BTC Revive so......

There are a LOT of people talking about seeing showscripterrors today after updating to 0.56 so if you're not seeing problems - I guess you're not updated to 0.56 . . . yet.

Share this post


Link to post
Share on other sites
I don't use vehicle respawn either but code for vehicle respawn is within the BTC Revive script and that is what is popping up in the -showscripterrors dialog box. And i don't use ANY other modules besides BTC Revive so......

There are a LOT of people talking about seeing showscripterrors today after updating to 0.56 so if you're not seeing problems - I guess you're not updated to 0.56 . . . yet.

People see scripts errors now because since the patch, -showscripterrors is on by default. I've always had it on before so nothing new here. Mostly people are seeing the CBA script errors since CBA is used as a requisite for a LOT of mods. And there are no error whatsoever generated by the BTC revive script I'm using (9.0RC1 I believe) nor any traces of anything related to it in the rpts, client or server side.

If you do get some, try finding them in your .rpt file and posting them, might help.

Share this post


Link to post
Share on other sites

I'm using the 0.9 RC1 and here's a screenshot of the script erors coming up since the new patch although BTC revive seems to be working ok apart from one weird thing (see next).

http://members.westnet.com.au/scott_k/not%20much/107410_2013-05-06_00008.png (1084 kB)

The weird problem is when waiting for a revive the body on the ground keeps popping up and down reloading his weapon over and over... but only if the unit is a team leader. Doesn't do it for other team members or if I make the team leader a squad leader. Any idea why that is? 0_o

http://members.westnet.com.au/scott_k/not%20much/107410_2013-05-06_00001.png (1193 kB)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×