Jump to content
SaOk

[SP/MP] Dynamic Whole Map ArmA3 Missions by SaOk

Recommended Posts

 

Updated the WLT: Amalgamation SP (link above). Strategic and camp locations are now placed to proper locations. Camps have object 3d editor templates used. More corrections to make new units appear. And other tweaks.

im loving it already sweet wargasm :P

Share this post


Link to post
Share on other sites

Love your missions. I do have one question, is there anything I need to change besides making the entire squad playable, to make WLT playable in multiplayer? I have unpacked the .pbo and am able to edit it in the mission editor, I am just unsure what I would have to change. Any help would be appreciated, thanks :)

  • Like 1

Share this post


Link to post
Share on other sites

Love your missions. I do have one question, is there anything I need to change besides making the entire squad playable, to make WLT playable in multiplayer? I have unpacked the .pbo and am able to edit it in the mission editor, I am just unsure what I would have to change. Any help would be appreciated, thanks :)

i would really love to see this i wanna play with so many friends but its nearly impossible atm if someone could do it I'd greatly appreciate it ( iv got no skills in the department to fix it x.x )

  • Like 1

Share this post


Link to post
Share on other sites

Hey.

 

Soak is there a code we can run though the debug console to force capture camps that bugs out and wont be captured? if i remember correctly you pasted a code in this thread a long time ago, but i cannot find it..

Share this post


Link to post
Share on other sites

This should work: :)

{(_x getvariable "Marker") setmarkercolor "ColorBlue";} foreach (nearestLocations [player, ["CampB","CampR"], 90000]);

 SP version cant be converted into MP quickly. Would need to convert the WLA COOP. Sorry but having zero motivation to work on it currently, but maybe some day. Preparing WLT SP update soonish, Should improve bit the performance. Tanoa seem to be even bit heavier for AI than Altis. After long pause with the game, I forgot how quickly the FPS might suddently go down very much. I hope they would work more on it. But they seem to favor very small scale sunday fun with static map. ;) I think it was the best idea to try make own game in UE4 since I dont need to rely on nobody. If it end working bad, its all me. With ArmA3 performance you just need to hope for miracle and wait. Had been doing that 8years already seeing it oscilating better and worse. Didnt expect getting scammed during that loyal dedication. Should never trust BIS, they use people as they like without any responsibility or ethics. Of course there is many nice DEVs too, but the core is very rotten or out of control.

 

But hope to get the WTL update out in near days.

Share this post


Link to post
Share on other sites

Updated the WLT SP. Link in #4122 post. Removed empty vehicles and static weapons/vehicles in camps to improve performance. Instead camps have bit more infantry. Might make CSAT build more guardpost later around their camps. Factories work again on Tanoa to make wanted vehicles.

  • Like 2

Share this post


Link to post
Share on other sites

This should work: :)

{(_x getvariable "Marker") setmarkercolor "ColorBlue";} foreach (nearestLocations [player, ["CampB","CampR"], 90000]);

 

Thanks a bunch Soak!

 

Updated the WLT SP. Link in #4122 post. Removed empty vehicles and static weapons/vehicles in camps to improve performance. Instead camps have bit more infantry. Might make CSAT build more guardpost later around their camps. Factories work again on Tanoa to make wanted vehicles.

 

Awesome, but does that mean that vehicles that a person has collected gets removed as well? since i tend to gather a tank or 2 and stores them at my base camp :D

Share this post


Link to post
Share on other sites

Collected (used) vehicles spawn back normally :)

Share this post


Link to post
Share on other sites

Collected (used) vehicles spawn back normally :)

 

Awesome, i have also ran into a annoying bug.. but it might be caused by the mods i use, i dont know, but either way, each time i die, when i respawn, am no longer hostile to the CSAT/Russian forces (i use the RHS mods), which is very annoying, because i can run up to a hostile, pop him in the leg and he wont do anything :/

Share this post


Link to post
Share on other sites

i seem to have a problem when loading an auto save or a user save either one...

 

the game bugs out and the map displays no tasks / teammates assigned to my squad!

 

is there a debug code to fix this problem ?

 

 

-----UPDATE-----

 

O4k94Gf.jpg

 

6dRfO4y.jpg

Edited by rokeugon

Share this post


Link to post
Share on other sites

Very strange issue. I would verify game files in steam. Right click arma3 -> properties -> local files -> verify catche (not sure if exact, having these in finnish). Also make sure WLA addon is enabled and you have the latest mission file (both from workshop).

Share this post


Link to post
Share on other sites

Very strange issue. I would verify game files in steam. Right click arma3 -> properties -> local files -> verify catche (not sure if exact, having these in finnish). Also make sure WLA addon is enabled and you have the latest mission file (both from workshop).

 

yeah everything is updated and i have the WLA addon enabled via the arma 3 launcher!

 

this issue only appears to happen after loading a save game file after the point when ive build 4 tents and going to destroy the AA for extra supplies...

 

 

also kinda sucks how you cant control the stomper but you can control a darter! 

 

only saying this the now cause i seen you are porting this over to tannoa. and well in order for it to be more enjoyable there it would be best to make improvements and fix alot of issues!

 

also can you please add display models for special structers ? cause its kinda hard to place them with just an invisible model and a wireframe box. especially if you are trying to minimize wasted space!

Share this post


Link to post
Share on other sites

yeah everything is updated and i have the WLA addon enabled via the arma 3 launcher!

 

this issue only appears to happen after loading a save game file after the point when ive build 4 tents and going to destroy the AA for extra supplies...

 

 

also kinda sucks how you cant control the stomper but you can control a darter! 

 

only saying this the now cause i seen you are porting this over to tannoa. and well in order for it to be more enjoyable there it would be best to make improvements and fix alot of issues!

 

also can you please add display models for special structers ? cause its kinda hard to place them with just an invisible model and a wireframe box. especially if you are trying to minimize wasted space!

doesnt seem to happen on tanoa for me :o

Share this post


Link to post
Share on other sites

doesnt seem to happen on tanoa for me :o

 

might need to be a little more specific. :D what doesn't happen to you ?

Share this post


Link to post
Share on other sites

Pretty sure I've read there's an issue with task markers and loading saves on dev branch right now.

This probably isn't a WLA issue but I can't be certain.

Share this post


Link to post
Share on other sites

and by dev branch you mean just the regular game ? cause i dont see any options to opt into a dev only branch of the game

 

unless you mean that the dev branch is the stable open release then yes thats what im on atm!

 

but yeah i really dunno at this point!. seems to work fine in other scenario's but i need to do more testing to figure out exactly whats happening. 

Share this post


Link to post
Share on other sites

Sorry if I wasn't clear.

Tanoa is only available on the Developemwnt Branch or the Preview Branch. Basically, these are versions of the game that allow the user base to try and test the new assets before they officially release on July 11th. These beaches are also a lot less stable and can have bugs not present in the Stable version of the game.

If you haven't opted in to either Developement or Preview, you would be playing on Stable Release Candidate 1.60 and therefore wouldn't have access to Tanoa.

It's on Dev Branch and Preview Branch where I heard tasks can be broken in some cases.

Share this post


Link to post
Share on other sites

Sorry if I wasn't clear.

Tanoa is only available on the Developemwnt Branch or the Preview Branch. Basically, these are versions of the game that allow the user base to try and test the new assets before they officially release on July 11th. These beaches are also a lot less stable and can have bugs not present in the Stable version of the game.

If you haven't opted in to either Developement or Preview, you would be playing on Stable Release Candidate 1.60 and therefore wouldn't have access to Tanoa.

It's on Dev Branch and Preview Branch where I heard tasks can be broken in some cases.

 

ah! well im on stable as shown via the SS that i provided in my previous post!

  • Like 1

Share this post


Link to post
Share on other sites

what your describing

 

well you said it yourself you are playing on the tanoa version. meanwhile im playing on altis! so have you actually played on the altis version ? cause they are 2 different things

 

thats like my saying i have a bug on this game but another person comments saying they have never experienced that but thats cause they are on a different version of the game compared to you!

 

the tanoa version is more recent and up to date than the altis one is. so unless your playing on the altis you cant really say that its not happening to you. when we aren't even playing on the same map

Share this post


Link to post
Share on other sites

well ive managed to fix the problem. however it came at some serious loss. all my squad mates that where all 100 magically died.. ive lost all vehicles that where guarding my main base and now after playing for a little bit and starting to finally get prestige rolling in. my bases keep getting hit because i cant effectively place AI defenses where i would like them to be.

 

@Saok 

 

Please can you consider adding another slider to base building at such high altitudes. adding another slide axis that will allow you to bring the placed object closer to you or further away! because i cant effectivly place anything at such high builds because in order to move things closer to you. you have to click the "Move" UI button and that resets youre altitude slider back to 0 and the problem repeats until you give up and rely purely by luck/ chance!

 

also the AI guards are kinda broke. i was expecting a placement icon sort of like AI turrets. but nothing shows!

 

this will allow for more enriched base building for those like myself that want everything perfect :P also considering AI is dumb, if the base is in a rockey area you want vantage points in a high situated area. but i cant get a turret that high cause i can never see where exactly im place or how high the thing is when i place a large watch tower!

 

also to simplify things for you and to make mostly everyone happy. cant special structures and everything else that does not get removed when you click "Undo obj" be added to the pool please cause you end up placing a special structure incorrectly and you hit undo obj but you find it removes half your base barricades etc ? :S

 

would also help if special structures had visible models so as to see which way they are facing correctly etc!

 

 

i really want to love this scenario but half the time it becomes annoying trying to deal with the problems that ruin the experience and end up moving onto something else or MP! these changes would be a first step in making the game even more remarkable! because due to tanoa being on a rocky volcano type land mass which has alot of hills etc. people will most likely try building and place stuff at high altitudes!

Share this post


Link to post
Share on other sites

I have an enemy guard post I have cleared and I cannot get it to change.  There are no enemies anywhere in the area.  When I go to build I get the error "Enemy guardpost too close, under 250m away".  Is there a way to force this to change?  Kind of like the line of code you have for the developers console to make an enemy base change if it glitches?  This is the second time I have encountered this issue over the past day or two.  Thanks for any help.

Share this post


Link to post
Share on other sites

well you said it yourself you are playing on the tanoa version. meanwhile im playing on altis! so have you actually played on the altis version ? cause they are 2 different things

 

thats like my saying i have a bug on this game but another person comments saying they have never experienced that but thats cause they are on a different version of the game compared to you!

 

the tanoa version is more recent and up to date than the altis one is. so unless your playing on the altis you cant really say that its not happening to you. when we aren't even playing on the same map

yes i play on the altis map too that's why i said that its not happening for me but if it does ill report it right away :)

Share this post


Link to post
Share on other sites

Saok, you need to give us the option to pause the world for things like buying units, managing loadouts or building bases. I also have problem with how quickly the enemy body despawn(so I can't loot them) as well as how closely some patrols spawns out of thin air. It may just be my personal preference but I'd like the AI to materialize at least 2,3km away in open terrain and not disappear until I get at least the aforementioned distance away. It may not be performance friendly to everyone but at least make it an option.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×