Jump to content
SaOk

[SP/MP] Dynamic Whole Map ArmA3 Missions by SaOk

Recommended Posts

High Command should work normally. You can see in UI (as HC groups number) when there is groups available. Its posssible some mod is blocking it. Before there was some weapon resting blocking it as default. All friendly side groups (except air team) that have more that 1 man should appear automatically in HC.

I see the number but on the map I can't control it to tell it where to go they appear on the map the iconish look of the vehicle but no group symbol to tell them where to go

Edited by DarkKing810

Share this post


Link to post
Share on other sites

Hey SaOk,

My Clan and i are enjoying your Map to massive amounts.

However we are rather realisticly based within our members.

So while playing the Map the question came up if it was possible to implement a revive script if it is Btc or any other of the sort.

I tried myself to implement BTC however with no luck.

So im addressing to you now is there any way to Implement a revive function?

Best Regards

Leon

Share this post


Link to post
Share on other sites

Edit: Just discovered my suggestion is already a thing, i somehow missed this news. My bad.

Edited by RhoSigma

Share this post


Link to post
Share on other sites

Thanks, the bis revive (from end game) could be added by editing description.ext. I try to prepare some updates at some point. Will need to update RHS template too in SP to replace green army with insurgents. Working in UE4 takes all time currently, but visiting arma editor sooner or later.

Share this post


Link to post
Share on other sites

Cool, hope you could add some of the newer released maps (Hindukush, Esseker) when providing an updated version in near future :)

Share this post


Link to post
Share on other sites
Thanks, the bis revive (from end game) could be added by editing description.ext. I try to prepare some updates at some point. Will need to update RHS template too in SP to replace green army with insurgents. Working in UE4 takes all time currently, but visiting arma editor sooner or later.

I got the BIS Script working however now while in revive phase the body still seems to port back to the standard Isle, is there a way to work around that?

Additional question. When we are playing the Map we can not seem to access the Arsenal when close to a base sometimes it works sometimes it does not is there a reason?

Edited by Xerbarus

Share this post


Link to post
Share on other sites

Hi! First thanks for this amazing thing you made! I do not know what to call it! A mod! A game! A damn platform! Whatever! It is great!

I wanted to ask about the rhs mode! The green faction is still using vanilla stuff and new rhs update includes the new insurgent faction! It would be great if you add that faction and replace the old green Army!

Another thing is the interface size! I cannot see the interface properly with size set to large or even medium! That is a problem! Thank you for this!

Also This auto rearm feature is a real headache! It makes a whole squad uncontrollable! Please remove it or at-least make it changeable in the options! :-(

Thank you! Keep up the good work!

Share this post


Link to post
Share on other sites

Thanks :), hope to update the rhs template soon. The interface size could fitting if using small UI size. Should rework that too. You can already toggle auto rearm and heal off in shift+1 menu.

Need to check that revive, also the arsenal in camps.

Share this post


Link to post
Share on other sites

Saok something ive only just noticed, why can you never buy or make UAV's either in the menus or at factory's? I wanted Air Support earlier but something discreet and something that i could use to find and lase/bomb targets rather than the gung ho AI who fly in and get immediately shot down and it occurred to me after so long of playing that they aren't available at all unless they spawn in on their own.

Share this post


Link to post
Share on other sites

Is the SP mission incompatible with ACE3? I got shot and couldn't respawn :/

Share this post


Link to post
Share on other sites

It's 4 weeks old. I've been having problems with enemies spawning in groups right in front of me.

Share this post


Link to post
Share on other sites

It probably doesnt work with new mods very well because its not really being worked on atm.

Share this post


Link to post
Share on other sites

The UAVs could be bit not working. Not sure if there was option to buy manned UAV from mil center or call support. That would be definitely one feature to add. ACE3 might conflict with my damage eventhandlers that are used to respawn. That might be impossible to fix unless you can toggle off the damage system in ACE.

Hope to update mission quite soon. Havent been playing anything for over month (expect few hours Witcher 3). Forcing to focus all my energy into unreal engine 4. :) Always hardest part to make project reach something playable state. After that it turns into more fun to work with. Going to get this into steam greenlight voting during fall. After that may have more time for arma too even would be nice to expand the game same way for years (if it gets released). Still not sure what I am doing but throwing ideas/experimental material in and will see how it comes.

Edit: Looking like this currently (more updates in Twitter/Youtube)

Edited by SaOk

Share this post


Link to post
Share on other sites

Hey man! If I want to make any suggestion I say to position SP artillery in camps! Right now they are scattered all over the place! Unguarded and that is not realistic! Also try to add more infantry in the game specially in high command! We can only buy vehicles! This is also not realistic! Apart from that the game is awesome! It can easily be defined as a ARMA 3 strategy game! Real cool!

Share this post


Link to post
Share on other sites

Thanks :) You can command artillery zones in map view also make them hold position. But will try to improve that too. Currently they should appear in nearest captured pier and move to your location. But if there is enemy between they may stop moving. Too many AI units bring FPS quickly down, but somekind of infantry zones could be coming at some point.

Share this post


Link to post
Share on other sites

I do not know about the technical stuff but if it is possible to only spawn AI in 4 or 5 km radius of the player maybe that helps it! For distances more than that you can issue a value to each unit and when they fight each other the side with the highest value wins! And the other side retreats! Both sides also lose some units! This can actually make it less FPS demanding I think! Forgive me for telling you how to do your job but I am really interested in this WLA! It has real potential I believe!

Share this post


Link to post
Share on other sites

Doing that already ;), that is how all sandbox games/modes work - the marked teams on map are just drawn icons and stored data. There is strenght stats array for each vehicle class counting who win, even ammo type have some effect. Then when you get near the marked team, that get spawned following the dynamically changing data. There cant be much AI spawned. FPS drops very quick especially when near bigger villages. Can mostly only wait game updates to improve that. I have probably worked around over 80% of the total editing time on the spawning-deleting loops. In the mission editor it look near empty since all is made from scripts.

Share this post


Link to post
Share on other sites

Small WLA Amalgamation update: RHS Escalation template updated with the new mod insurgents replacing green army.

Share this post


Link to post
Share on other sites

Hi SaOk. Thanks for all your work, this is very enjoyable.

I couldn't find this problem being posted, the "steel car" function doesn't seem to work for me. While it does unlock the car, I cannot turn on the engine in any vehicle.

Share this post


Link to post
Share on other sites

Is there any way to disable the wounded function for AI or alltogether? I seem to find nothing but trouble with it, with teammates refusing to die properly and sometimes me not getting revived but jumping around all willy-nilly.

Share this post


Link to post
Share on other sites

No options in "other settings" menu. Drop boxes for each options are blank. In game construction menu is also blank.

Edited by sirishswar

Share this post


Link to post
Share on other sites

Thanks :)

respawn system can be toggled off in start options. The custom first aid and revive can be turned off in shift+1. Not sure why the engines dont start. Could be some new game conflict.

Having blank options sounds like you dont have latest game version. Verify your files in steam. Right click arma3 -> properties -> few pages right -> verify. Also make sure you have the latest WLA addon (from steam, dropbox or moddb) and rarely some mods may conflict.

Share this post


Link to post
Share on other sites

Absolutely amazing mission. But i am having serious hotkey problems. If i start the map by "restart" or "play", hotkeys work as intended (for example Y to pickup stuff).

But if i start via "Resume" (before i knew about the save system), or via "restart" and then choosing the in-mission save, hotkeys no longer work such as Y to pickup gear.

It is really frustrating. Its like anytime i load any save they stop working.

Share this post


Link to post
Share on other sites
Absolutely amazing mission. But i am having serious hotkey problems. If i start the map by "restart" or "play", hotkeys work as intended (for example Y to pickup stuff).

But if i start via "Resume" (before i knew about the save system), or via "restart" and then choosing the in-mission save, hotkeys no longer work such as Y to pickup gear.

It is really frustrating. Its like anytime i load any save they stop working.

I have a similar issue with the "H" key stopped working for tutorial hints after restarting the mission from a current running session, which I found out is a vanilla issue directly from BI as I could duplicate the issue in vanilla showcases w/o any mods.

But I couldn't duplicate the issue with the Y/Z key. When ever I restarted the mission from a current session (already in the mission itself) and load the mission again(optional) my Y/Z key was still working, unlike the H key.

Maybe it has something to do with your keyboard layout? What keyboard layout/language do you use? Is your Y/Z key positioned where the "H" key is usually positioned on a lot of keyboards?

Qj7lOSJ.png

To circumvent the issue of the loot key stopping to work for you properly, what you can do is go back from your current mission all the way back to the mission selection screen in Arma menu, and restart WLA from there, then load the progress from the ingame welcome screen.

It's a bit inconvenient, but hey at least it's a workaround until this issue has been/can be adressed by either SaOK or BI. :)

(Honestly, in my opinion WLA is not that kind of mission where you want to save-load in frequent intervals anyway.)

On another note, SaOK, I miss ya. Come back please or I'll have to find a way send you a virus or some sort that deletes the Unreal engine on your computer and only gives you access to BI related stuff so we can enjoy new WLA stuff such as coop, WLA on new maps, and all that good stuff :p

Edited by ChuWie

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×