Jump to content
terox

Tutorial: Installation & Configuration of ArmA3 Dedicated Server

Recommended Posts

I would like to ask a question, the owner of the licensed copy of the game Arma 3 can host it on a server that will be able to join and legal and illegal players (genuine and non-genuine players):confused:

* P.S. Sorry for my english):)

Share this post


Link to post
Share on other sites
Any ideas on how to fix the slow downloading of mission files?

Thanks,

Dfyyyy

get a fast FTP Server and the Download goes BOOM!

RE-LOCATING MPmIssions (For example to a dropbox)

To define a different location for your MpMissions, such as a drop box location, carry out the following steps.

Either Move your MpMissions to its new location or just delete it. (Don't leave a copy in the original location)

run cmd tool on your server to create the link, use "" around the directories

example

mklink /J "D:\Games\Arma3\A3Master\mpmissions" "C:\Users\user\Desktop\Dropbox\mpmissions"

Share this post


Link to post
Share on other sites
how can i config battleye for my (insurgency) server

127.0.0.1

Port2302

"Connection failed"

why?

Server seems to running. Port is open, and connection as player is also possible...

edit: Good old Google to the rescue again. I had to specify my proper Battleye directory using this as an extra server startup parameter "-bepath=C:\Games\arma3\battleye"

I'm also having problems trying to remotely connect to my Battleye. People are able to see the server in server list (I seem to have to refresh multiple times before it shows up) and connect to the server fine. I'm assuming all ports are forwarded correctly, I have everything in the Firewall -> Inbound Rules area on my Windows Server 2008 R2, is that the correct area for it? Does anything need to be forwarded for a remote Battleye connection to work correctly?

Edited by USteppin

Share this post


Link to post
Share on other sites

Usually I don't ask for help but...I've read so much about those parameters ( maxsizeguaranteed, minbandwith, ecc ecc ecc ecc ) and each topic I've read talk about this parameter in a different way..

I've passed all yesterday afteroon testing but I haven't find the optimal parameters, I think..

System is:

Windows 2012 R2

i7-4770, 32gb@1600, 2 x intel SSDSC2BW240A4 ( one for os, steam and others things and one only for arma+mods ), 200 mbit dedicated ( tested ); the whole "addons" is running in ramdisk. Whole server is dedicated about that... Ah and I've got another license for HC..

Our clan play almost ( 90% ) coop vs AI, about 20-30 player vs some hundreds AI ( someone spawn near, someone patrol the map around without a target )

I star the server and HC with arma3restarter, cpucount8, exthreads7 and I usually play 2 istances ( 1server+hc private, 1 server pubblic but with those specs ( bought this server yesterday ) I think I will run another private server )

1) HC needs anothers parameters ?

2) What will be the NEEDED and WORKING ( someone here and around told that some value are useless ) parameters for my arma3.cfg to use all my hw/bandwith for the best game?!

After all those tests I really don't understand nothing, I go insane.. :icon_confused:

If someone can help, thanks..

Edited by ramius86

Share this post


Link to post
Share on other sites

Anyone figured out yet how to run dedi and 2 clients on the same machine for mission testing?

Share this post


Link to post
Share on other sites

is there a new command to get the dev changes? Since release "-beta development" returns every time that i have the neweset build but this isn't correct, the Build stands on Stable not on DEV, i don't get any of the Updates since release.

Share this post


Link to post
Share on other sites

... just insert:

loopback=true;

in your server.cfg.

Give your two client instances different names with -names=whatever in client start command line.

(maybe, steam in offline mode, too)

Greets,

Fred41

Anyone figured out yet how to run dedi and 2 clients on the same machine for mission testing?

Share this post


Link to post
Share on other sites
Usually I don't ask for help but...I've read so much about those parameters ( maxsizeguaranteed, minbandwith, ecc ecc ecc ecc ) and each topic I've read talk about this parameter in a different way..

I've passed all yesterday afteroon testing but I haven't find the optimal parameters, I think..

System is:

Windows 2012 R2

i7-4770, 32gb@1600, 2 x intel SSDSC2BW240A4 ( one for os, steam and others things and one only for arma+mods ), 200 mbit dedicated ( tested ); the whole "addons" is running in ramdisk. Whole server is dedicated about that... Ah and I've got another license for HC..

Our clan play almost ( 90% ) coop vs AI, about 20-30 player vs some hundreds AI ( someone spawn near, someone patrol the map around without a target )

I star the server and HC with arma3restarter, cpucount8, exthreads7 and I usually play 2 istances ( 1server+hc private, 1 server pubblic but with those specs ( bought this server yesterday ) I think I will run another private server )

1) HC needs anothers parameters ?

2) What will be the NEEDED and WORKING ( someone here and around told that some value are useless ) parameters for my arma3.cfg to use all my hw/bandwith for the best game?!

After all those tests I really don't understand nothing, I go insane.. :icon_confused:

If someone can help, thanks..

There is no definitive answer to config values for the arma3.cfg.

After 10+ years we are still waiting for this to be explained in detail and a methodology to actually set them correctly

You only have to compare server admin's posted versions of their settings to see there is no consistency at all over the values used.

There are many theories put forward, many different calculations.

I would simply try the following link and take it from there

http://community.bistudio.com/wiki/ArmA:_Tweaking_Tips

(I did link this in the first page of this thread under the section "SERVER OPTIMISATION"

Share this post


Link to post
Share on other sites

Thanks for the reply.. The thing I noticed is that FPS server are always high value but when I began to spawn AI into HC ( both HC and server got over 40 fps ), locally on my client and also others we start loose fps.. More AI, more fps loss.. I spawned 146 groups and 600 AI, 30-35 fps serverside and very low fps locally even if AI are 10 km away ... I think this is only a netcode fault that will be fixed, hopefully...

BTW I can't understand how those valuee are so difficult to understand.. Or yes, I understand, because there isn't ONE and ONLY ONE page where the BI guy who exactly know those parameters write: this is this, 2-3 real example and some full examples...

Edited by ramius86

Share this post


Link to post
Share on other sites

Hi, 2 days ago we stopped being able to query our server, as in both our Game Panel and Gametracker get no response from the server on port 2302.

This is odd as nothing has changed on our end, no windows updates, nor server updates, it just stopped querying, but bizarrely people can still see and join it ingame.

After extensive testing this morning I'm satisfied its not a port or firewall issue on our end. I changed the ports over to use the known working ArmA 2 ones, still no go.

I'm pretty much out of ideas now, and was wondering if anything has changed here recently?

Share this post


Link to post
Share on other sites

According to this post

http://forums.bistudio.com/showthread.php?166635-Servers-not-Responding-to-external-sites

its an engine issue with the game browser

= Memphis007;2531594']It is because some ArmA III servers have migrated from Gamespy 2 query protocol to Gamespy 3. Temporary fix is to switch your server type as ArmA II.

Share this post


Link to post
Share on other sites
Hi, 2 days ago we stopped being able to query our server, as in both our Game Panel and Gametracker get no response from the server on port 2302.

This is odd as nothing has changed on our end, no windows updates, nor server updates, it just stopped querying, but bizarrely people can still see and join it ingame.

After extensive testing this morning I'm satisfied its not a port or firewall issue on our end. I changed the ports over to use the known working ArmA 2 ones, still no go.

I'm pretty much out of ideas now, and was wondering if anything has changed here recently?

According to this post

http://forums.bistudio.com/showthread.php?166635-Servers-not-Responding-to-external-sites

its an engine issue with the game browser

It seems, Gametracker solved the problem :

http://www.gametracker.com/forums/forum.php?site=1&post=342459#post342472

If you switched arma3 to arma2 type, you can switch back. :)

Share this post


Link to post
Share on other sites

Thats seriously ridiculous, and why now. Anyhow thanks, I have posted over at brainless to see if the game panel can be updated.

Share this post


Link to post
Share on other sites

Where can I find the a3.bikey? :)

Warning Message: Files "dta\bin.pbo", "dta\core.pbo", "dta\languagecore_f.pbo", "addons\a3.pbo", "addons\air_f.pbo", "addons\air_f_beta.pbo", ... are not signed by a key accepted by this server. To play on this server, remove listed files or install additional accepted keys.

If it is required, please upload it

If not - what is wrong? :)

---------- Post added at 04:44 PM ---------- Previous post was at 04:38 PM ----------

Nvm found it in the steam folder

Share this post


Link to post
Share on other sites

My ARMA3 Server is running through TCADMIN , and every time it creates a server it automatically has some Random Host name and 64 Slots .

I have looked for a Config file and can not find one to edit it , and even if I found it I am not sure of the command that needs to be put there in order to put the host name I type in TCADMIN and the correct slot number.

If someone could help me willing to help them out in anyway I can even paying or providing them some hosting for there help.

Contact Skype - Adam.Garber6

Share this post


Link to post
Share on other sites

Hello how are you?

I need help in the dedicated server ARMA 3, and configure the server so they can choose the players who want to play mission? by voting or otherwise?

Share this post


Link to post
Share on other sites
Hello how are you?

I need help in the dedicated server ARMA 3, and configure the server so they can choose the players who want to play mission? by voting or otherwise?

In the file that is your equivalent of the Config_Vanilla.cfg as stated in the first post of this thread

You should have the following lines....

// VOTING
voteMissionPlayers 	= 1;					// Tells the server how many people must connect so that it displays the mission selection screen.
voteThreshold 		= 0.33;					// 33% or more players need to vote for something, for example an admin or a new map, to become effective

Share this post


Link to post
Share on other sites
In the file that is your equivalent of the Config_Vanilla.cfg as stated in the first post of this thread

You should have the following lines....

// VOTING
voteMissionPlayers 	= 1;					// Tells the server how many people must connect so that it displays the mission selection screen.
voteThreshold 		= 0.33;					// 33% or more players need to vote for something, for example an admin or a new map, to become effective

when I put the command in the chat # vote missions, it's game over and not see any list of missions to vote

There Config_Vanilla.cfg the file somewhere where it gets the list of missions available?

Share this post


Link to post
Share on other sites

Firstly you will need to be voted in as admin

then once you have admin then you can type into the chat box the following command

#missions

which will then display the current mission list the server has

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×