Jump to content
Sign in to follow this  
sickboy

CBA - Community Base Addons - ARMA 3 Alpha

Recommended Posts

I assume you mean into the mission and not the server?

Share this post


Link to post
Share on other sites

Anyone having issues with CBA_ui_fnc_add?

It seems like I can only register one menu and no more... Once the first has been registrered that one will always be used even tho I edit the .sqf file

Share this post


Link to post
Share on other sites
Yes how do you script it into the mission that the server is run

That's like trying to reinvent the wheel because you don't have the ability to change a tire, move provider to somewhere that allows mods.

Share this post


Link to post
Share on other sites
That's why im asking if there is a way to script it into the server so we don't have to do that.

And that's why i answered that way...as i said,there's no other solution,it's a MOD,not a script that you can integrate in a mission.....

Share this post


Link to post
Share on other sites

CBA A3 Beta 5 brakes saving for me. I had complete trust in this mod, i checked every other mod that i had, and updated them, all was for nothing, the save braking continued and was very frustrating, until I gave a try to the old Community Base Addons version beta 4, it worked flawlessly. Did not expect this mod to brake saves. The mods I use: CBA_A3; A3MP; FA18; WW_AIMENU; VTS_Weaponresting; RecoilFix; ASR_AI3; JSRS2.1; Blastcore

Share this post


Link to post
Share on other sites

Insane` please provide more details:

1) rpt log file after you had the loading problem

2) try without addons except CBA

3) add them back one by one and you will know which one is causing it

Share this post


Link to post
Share on other sites
;2642480']Insane` please provide more details:

1) rpt log file after you had the loading problem

2) try without addons except CBA

3) add them back one by one and you will know which one is causing it

1)I made the stupid thing of disabling logs by -nologs parameter ' date=' all i have is this :

=====================================================================
== D:\Steam\steamapps\common\Arma 3\arma3.exe
== "D:\Steam\steamapps\common\Arma 3\arma3.exe" -high -cpuCount=4 -exThreads=4 -maxMem=4096 -maxVRAM=1023 -nosplash -nologs -world=empty -malloc=tbbmalloc -mod=@CBA_A3;@A3MP;@AIMENU;@Weaponresting;@RecoilFix;@ASR_AI3;@JSRS2.1;@Blastcore

[code]Exe timestamp: 2014/03/09 20:04:13
Current time:  2014/03/12 07:41:27

Type: Public
Branch: Stable
Version: 1.12.115994

Allocator: D:\Steam\steamapps\common\Arma 3\dll\tbb4malloc_bi.dll
=====================================================================

AppId parsing successful. Using appId=107410

Entering off-line mode. Callbacks and content list updates will not work.[/code']

2) I did now, it does not brake the saves on its own, i guess its not compatible with a mod i have and brakes the save loading. Beta 4 works with the mods i have

3) I did that, it stopped breaking when i replaced it with the old CBA beta 4.

The save breaking occurs on the campaign. (I used first mission from the second chapter Adapt)

Edited by Insane`
missing quote sign

Share this post


Link to post
Share on other sites

Thanks for the quick response Insane`!

Unfortunately the rpt details are needed or the one by one test to really see which one is causing.

To clarify: You mean the case when a savegame cannot be loaded at all, or after the loading some feature no longer works?

Share this post


Link to post
Share on other sites
Yes how do you script it into the mission that the server is run

If you just need some basic functions, you can copy them into the sqf script you run in your mission.

If you want the more advanced features, unfortunately they can only be done in a mod.

Share this post


Link to post
Share on other sites
3) add them back one by one and you will know which one is causing it

3) I did that, it stopped breaking when i replaced it with the old CBA beta 4.

No. What kju means is: which of the mods, apart from CBA, is it that gives you "save breaking" with CBA A3 b5 but not with b4?

Also, what exactly do you mean by "save breaking"? What is it that happens (or doesn't happen, if that is the case)?

Share this post


Link to post
Share on other sites

I think he means the problem where after loading a savegame, a mod is not running anymore. STHud does it from time to time at my end (I am not running the SaveGame Mod below ).

This mod should fix that, might give a hint:

http://forums.bistudio.com/showthread.php?172827-Moduload-%E2%80%94-Save-Game-Mod-Initializer

Edited by Old_Painless

Share this post


Link to post
Share on other sites

Funny thing is I applied beta 5 update back, and works *gasp* I don't even ... The thing is i'm not a noob in modding ArmA , I know i have to delete the hole mod folder and not overwrite it, adding any .key and .hpp to the appropriate folders and adding the parameters to the shortcut or enabling in game. The mod did brake my saves (not loading the save at all + deleting/corrupting the file from saving location) , but now it does, and i don't think i did something different then before :| so thanks for your help and sorry for wasting your time.

Share this post


Link to post
Share on other sites

No worries mate. Could it be that you had the problem when you updated to the new CBA and the new 1.12 A3 version?

Share this post


Link to post
Share on other sites
I think he means the problem where after loading a savegame, a mod is not running anymore. STHud does it from time to time at my end (I am not running the SaveGame Mod below ).

The savegame problem with ST HUD, which is not caused by CBA, has been fixed - use the March 2014 (or later) version: ST HUD thread

Share this post


Link to post
Share on other sites

Hi

I'm running a dedicated server and it seems CBA_A3 overrides the ArmA3Profile settings.

The server.ArmA3Profile is set to disable all HUD information, including weapon crosshair and MP statistics, at all difficulty settings (everything is set to 0 in the profile).

Without CBA, it works like a charm.

But when loading CBA (either beta4 or beta5), and CBA alone, we get weapon crosshairs and MP statistics even at elite level.

I'm quite certain this issue arose with the new patch, so my assumption would be that it is a compatibility problem between the patch and the latest CBA version.

However, I haven't found anyone else experiencing the same problem.

Am I doing anything wrong, am I missing something?

Thanks in advance for your help,

Igor

Problem solved: had forgotten -name=XXX in the command line.

Cheers!

Edited by Igor Drukov
Problem solved :)

Share this post


Link to post
Share on other sites

Is there a way to detect bullets near players and differentiate between bullets and other munitions using CBA's XEH's?

Share this post


Link to post
Share on other sites
Is there a way to detect bullets near players and differentiate between bullets and other munitions using CBA's XEH's?

Don't know the answer to this, but you may find Fabrizio's bdetect useful. Bullet detection around units is a big part of what he has done with bcombat in arma 3, if I understand correctly.

Share this post


Link to post
Share on other sites
Is there a way to detect bullets near players and differentiate between bullets and other munitions using CBA's XEH's?

Yes and there are several suppression systems based on this concept of detecting projectiles around the player each frame (using cba_perframeeventhandler or similar): bcombat, tpwcas,ffis, tpw ebs.

Share this post


Link to post
Share on other sites

Hi,

i have a problem with the CBA. With only CBA when I use the parachute if i hit the floor fast (>50 km/h) i explose, without the CBA it s works.

Share this post


Link to post
Share on other sites
Hi,

i have a problem with the CBA. With only CBA when I use the parachute if i hit the floor fast (>50 km/h) i explose, without the CBA it s works.

HI ETBSmorgan, thanks for your report.

This has recently been fixed and will be in the next release of CBA.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×