Jump to content
k3lt

Low CPU utilization & Low FPS

Recommended Posts

I am very frustrated with this title.. The game is unplayable to me.

 

My setup: Windows 10 64bit,16GB memory, FX8350 and GTX1060.

 

It doesn't matter if I choose low or ultra from the graphics settings... the CPU and GPU utilization stays under 30% all the time no matter what.

 

My only hope is they fix it somehow or just wait untill I upgrade my CPU to something which this game likes. Tried even to get a refund for the game.

Share this post


Link to post
Share on other sites
1 hour ago, jkkkm said:

I am very frustrated with this title.. The game is unplayable to me.

 

My setup: Windows 10 64bit,16GB memory, FX8350 and GTX1060.

 

It doesn't matter if I choose low or ultra from the graphics settings... the CPU and GPU utilization stays under 30% all the time no matter what.

 

My only hope is they fix it somehow or just wait untill I upgrade my CPU to something which this game likes. Tried even to get a refund for the game.

It's true that Arma depends heavily on a single core (although not entirely).

So to enjoy good performance, get:

1. fastest CPU you can afford and one with high IPC. AMD CPUs are fast but their IPC is low. However with the upcoming Ryzen that may change that. So I'd wait for the benchmarks (next week?)

2. fast RAM. All games really like fast RAM. A3 likes fast RAM more than most

3. SSD. Get one. Biggest evolution in PC in the last 10 years. Improves responsiveness in every application

Share this post


Link to post
Share on other sites
12 hours ago, domokun said:

It's true that Arma depends heavily on a single core (although not entirely).

So to enjoy good performance, get:

1. fastest CPU you can afford and one with high IPC. AMD CPUs are fast but their IPC is low. However with the upcoming Ryzen that may change that. So I'd wait for the benchmarks (next week?)

2. fast RAM. All games really like fast RAM. A3 likes fast RAM more than most

3. SSD. Get one. Biggest evolution in PC in the last 10 years. Improves responsiveness in every application

 

SSD will not improve the framerate.

Share this post


Link to post
Share on other sites
13 hours ago, jkkkm said:

I am very frustrated with this title.. The game is unplayable to me.

 

My setup: Windows 10 64bit,16GB memory, FX8350 and GTX1060.

 

It doesn't matter if I choose low or ultra from the graphics settings... the CPU and GPU utilization stays under 30% all the time no matter what.

 

My only hope is they fix it somehow or just wait untill I upgrade my CPU to something which this game likes. Tried even to get a refund for the game.

 

Try to follow this instruction for install the latest drivers , than let me know what is your framerate when you are in campaign mode (first mission when you start walking to the base an helicopter is landing in front of you).

 

How to clean install the driver:
1. Download the new driver: http://www.guru3d.com/files-details/geforce-378-72-driver-download.html
2. Download the last version of "Display Driver Uninstaller (DDU)" V17.0.5.4 here: http://www.wagnardsoft.com/content/display-driver-uninstaller-ddu-v17054-released
3. Reboot in safe mode, if you don't know how to do, search in Youtube.
4. Use DDU for uninstall from "safe mode" and reboot
5. Start the Driver installation and select the "Custom (Advanced)" mode 
6. If you don't have 3D glass don't installa the two related components.
7. Don't install "GeForce Experience" if you don't need, if needed download the last version separately because is newer than the version included in the drivers.

Share this post


Link to post
Share on other sites
2 hours ago, Alberello said:

 

SSD will not improve the framerate.

You're right but it will remove stuttering, which for many is just as bad, if not worse.

Reinstalling his GPU drivers is unlikely to solve his performance issues.

They are due to AMD's choice of architecture (many cores, low IPC).

Share this post


Link to post
Share on other sites

I think the situation would be much better if the game could utilize the CPU more. Now around 70% of the CPU is not even used. Other games run just fine but this won't.

Share this post


Link to post
Share on other sites
2 hours ago, jkkkm said:

I think the situation would be much better if the game could utilize the CPU more. Now around 70% of the CPU is not even used. Other games run just fine but this won't.

I think that we all agree with you that we'd like Arma's RV4 engine to be more multi-threaded.

However this problem isn't just with RV4. AMD chose an architecture that favoured more cores than IPC.

This was a bad choice because most games do not have engines that are well multi-threaded.

This is changing however with the new generation of engines.

So we can expect the situation to improve with BI's new engine, Enfusion.

An early version Enfusion is already used on BI's game Take On Mars.

A much more refined version is being test in DayZ.

I expect that an even more refined version, will be used in Arma 4.

In the meantime, please don't blame A3 for AMD's poor choice of architecture.

As these benchmarks indicate, the problem also lies with AMD, e.g.

why is a dual core Intel beating an octo-core AMD by almost 100% when they're operating at almost the same frequency?

CPU_03.png

a3_proz.jpg

 

Gaming_08.png

Share this post


Link to post
Share on other sites

any benchmark result which isn't on 1.68 (from the future) is obsolete by now ...

Share this post


Link to post
Share on other sites
10 hours ago, dwarden said:

un risultato di riferimento che non è su 1,68 (dal futuro) è obsoleto ormai ...

I uninstalled the game as I was advised to do, this has obviously not solved the problem, but I wanted to try the same.
I wonder if it would not be appropriate to make a downgrade of the game and solve the problem that way ...
I can not use my ArmA 3 are lowered because the FPS (30 to 3), angry!

My PC configuration is more than good for any game, only with ArmA 3 I have these problems, absurd!

Share this post


Link to post
Share on other sites

Lets just wait for the 1.68 update now and try again after its released.

Share this post


Link to post
Share on other sites

So, with other words you are saying that we will have a performance boost soon? 

Ha, I've heard that before

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, jkkkm said:

Consente solo aspettare per l'aggiornamento 1.68 ora e riprovare dopo la sua rilasciato.

The problem is to know when it comes out the 1.68? Days, months or years?

Share this post


Link to post
Share on other sites
5 hours ago, M-Owen said:

The problem is to know when it comes out the 1.68? Days, months or years?

Neither. Based on my experience it will be within week or two. So weeks.

Share this post


Link to post
Share on other sites

Tonight another system crash, first FPS low at about 3 and then the game freezes ... unbelievable!

Share this post


Link to post
Share on other sites

same here bro. it would seem things have actually been made 10 times worse. I thought switching to 64bit would fix the fps problems that give this game a bad rep, but on a good day in 32bit  i was able to get up to 70 fps on ultra settings, with the norm being around 30 fps when things started happening. now it would seem the best i can hope for is 15 fps on lowest settings with nothing happening and god knows what will happen when an actual firefight starts... what happened guys???

Share this post


Link to post
Share on other sites

found the problem no idea how to fix it. In the RPT file it says that it is not detecting my GTX 970m. and has reverted to onboard graphics. it would appear that support for a few video cards have slippped through the cracks during development. hopefully they fix this issue soooooooooon.

 

Share this post


Link to post
Share on other sites
4 hours ago, SonterAUS said:

found the problem no idea how to fix it. In the RPT file it says that it is not detecting my GTX 970m. and has reverted to onboard graphics. it would appear that support for a few video cards have slippped through the cracks during development. hopefully they fix this issue soooooooooon.

 

 

I think you have to find the arma3.exe, right click it and select the preferred GPU or something.

Correct me if I'm wrong

  • Like 1

Share this post


Link to post
Share on other sites

was given the answer to this problem by a legend called Cane Toad -

"Try opening NVIDIA control panel and creating a new profile in the "manage 3d settings" tab  for ARMA3_X64.exe.

Worked for me and I had exactly what you guys are describing."

this worked like a charm and i would never have thought of it.

  • Like 1

Share this post


Link to post
Share on other sites
On 17/03/2017 at 5:04 AM, SonterAUS said:

"Try opening NVIDIA control panel and creating a new profile in the "manage 3d settings" tab  for ARMA3_X64.exe.

Worked for me and I had exactly what you guys are describing."

this worked like a charm and i would never have thought of it.

 

Worked also for my notepad. 7 FPS in standard due to native board >> 30 FPS all set to ultra after NVIDIA GTX860M choice in control panel.

Share this post


Link to post
Share on other sites

@ dwarden : you were right,  "... any benchmark result which isn't on 1.68 (...) is obsolete by now ...".

Looks like around 5 FPS loss since 1.68.

 

But in the same time, I am getting huge variations in benchmarks results such as huge FPS drops in YAAB or huge FPS rise on GUI with Steam disconnected. I am also getting extremely high RAM usage, up to 91% out of 8 Go DDR4 on the "Minimum Recommended" candidate I am testing ATM based upon Pentium G4560/GTX 750Ti.

I am also wondering about the impact of last Windows 10 update.

Edited by oldbear
some thoughts after a little sleep

Share this post


Link to post
Share on other sites

let me correct that for you, any benchmark not on performance binary from profiling branch ;)

aka 1.68.141067 or newer 

https://forums.bistudio.com/forums/topic/160288-arma-3-stable-server-168-performance-binary-feedback/?do=findComment&comment=3168204

 

also take in mind that 64-bit binary might not be properly(or at all) detected by drivers for theirs gaming profiles etc.

Share this post


Link to post
Share on other sites

Let me explain this to you, I am getting a minor but significant FPS loss in game since Arma3 1.68 release and last Windows 10 update.

Of course I am speaking about "normal" Arma3 version aka 1.68.140908 every Steam player can get, not about any experimental version.

Share this post


Link to post
Share on other sites

I noticed lower FPS as well with the 1.68. Not much , maybe 3-4 FPS less than 1.66.

 

  • Like 1

Share this post


Link to post
Share on other sites

every steam player can get the performance binary, just switch the branch :)

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×