Jump to content
k3lt

Low CPU utilization & Low FPS

Recommended Posts

11 minutes ago, Vasily.B said:

Guys i finally found good and working solution (at least for me) - disable all maxmems, cpu counts, leave only hyperthreading checked (if your CPU can use it). I had 15 fps Boost, just like game have been unlocked somehow.

Could you show actual benchmark that this i what caused it? Also what mission, players,  etc etc. I have some doubts that it's actually the disabling of those commands that made you gained it.

Share this post


Link to post
Share on other sites
9 hours ago, Vasily.B said:

Max mem is LIMITING max memory usage, removing parameter is removing limit.

If you were using =maxmem=2047 or lower, then it was indeed limiting the memory usage because limit it currently 3071.
Also defining cpucount will override enableht, so you can't use them at the same time. So by removing these wrong parameters might actually improve the performance.

  • Like 1

Share this post


Link to post
Share on other sites

and as neat surprise, profiling branch performance binaries got support for hugepages ;) (logically the 64-bit binaries will benefit the most)

https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-performance-binary-feedback/?do=findComment&comment=3130011

 

while I may try to get 64-bit the same, I can't promise that it will be until after holidays

(I may try some performance binaries for DEV branch magic spell in next 48 hours)

  • Like 5

Share this post


Link to post
Share on other sites

Revert to 32-bit setting. The FPS increase is huge. Itreid both and have much more FPS on 32-bit.

Share this post


Link to post
Share on other sites

helpme how to fix my problem

ı did last year no problem played but now look this photo help me

 

3 gb ram

amd radeon hd 7800 3gb

64 bit pc windows 10

 

LOW VİDEO SETTİNGS MENÜ 300 FPS GAME 10 - 5 FPS

Terrain problem

 

PHOTO: l3Ddzk.jpg

Share this post


Link to post
Share on other sites

Arma 3 just tends to run bad in general IMO. However, the 64 bit update should improve performance significantly.

Share this post


Link to post
Share on other sites

I would not count on it mate.

The thing with Arma is not RAM usage its more the fact it dont utilize the CPU well the cores.

I am hoping that with the 64bit version it uses the CPU more to its advantage but lets see.

 

I realy want Arma to improve in performance its the only reason I just cant be bothered to play it any more.

The FPS is terrible even on a monster rig.

Share this post


Link to post
Share on other sites
28 minutes ago, stk2008 said:

The thing with Arma is not RAM usage its more the fact it dont utilize the CPU well the cores.

I am hoping that with the 64bit version it uses the CPU more to its advantage but lets see.

 

I can't see any difference in cpu usage with the 64bit, which is no surprise since 64bit doesn't have anything to do with how an application utilizes cores.

A lot less stutters though, because of more stuff in RAM and less hard drive usage.

Share this post


Link to post
Share on other sites

Yeah I assumed it would not help oh well hopefully when/if arma4 comes they will actually move to a better engine in stead of strapping more stuff to an all ready struggling engine :(

Share this post


Link to post
Share on other sites

Today I opened a ticket service on the official website, it's frustrating to play with the anxiety that can happen suddenly fell from 50 to 3 FPS. I do not know if the development team is already working on the problem, but I hope they do everything to solve. The same problem was also found on other PCs with different configurations from mine.

Share this post


Link to post
Share on other sites
9 minutes ago, M-Owen said:

Today I opened a ticket service on the official website, it's frustrating to play with the anxiety that can happen suddenly fell from 50 to 3 FPS. I do not know if the development team is already working on the problem, but I hope they do everything to solve. The same problem was also found on other PCs with different configurations from mine.

 

Share this post


Link to post
Share on other sites
2 hours ago, HeroesandvillainsOS said:

 

the problem is not solved yet?

Share this post


Link to post
Share on other sites
On ‎3‎/‎6‎/‎2013 at 1:26 AM, looter said:

Might also be worth playing with the "-cpuCount=#" launch parameter.

 

Parameters do nothing

Share this post


Link to post
Share on other sites

As I see this problem exist so many years...and no patch no fix.I can't understand why they release so many extra features in a game with so many software problems which make it unplayable and don't start working on Arma 4 earlier...on a new engine perhaps or something...They make intermediate stances for the soldier and they don't make a game which mods can load automatically...load-unload-load-unload...server is full : unload and load the other server's mods....

 

The sure thing is that Bohemia likes us very much for buying the game anyway...

 

 

Edited by koumparos

Share this post


Link to post
Share on other sites
On 11/2/2017 at 8:36 PM, HeroesandvillainsOS said:

 

 

Edited by M-Owen

Share this post


Link to post
Share on other sites

I am very sorry for what is happening, I have always had faith in the Bohemia Interctive team, it seems strange that they have not yet identified the problem and fixed with an update. We realize that the game has become not playable even with the most powerful graphics cards, it would be nice if someone answered the BI team to discussion and give us some more precise information. Thank you

Share this post


Link to post
Share on other sites
47 minutes ago, M-Owen said:

I am very sorry for what is happening, I have always had faith in the Bohemia Interctive team, it seems strange that they have not yet identified the problem and fixed with an update. We realize that the game has become not playable even with the most powerful graphics cards, it would be nice if someone answered the BI team to discussion and give us some more precise information. Thank you

You mean CPU, right? 

  • Like 1

Share this post


Link to post
Share on other sites
You mean CPU, right? 

...also and especially CPU, I spent a lot of money to update me on the PC, to play ArmA 3 is getting very frustrating, but we know that the problem is not hardware.

Inviato dal mio SM-G925F utilizzando Tapatalk

Share this post


Link to post
Share on other sites

I play from about one month basically at Arma3 & Battlefield1.

On my old PC hardware, more than 4 years old, Arma 3 was almost unplayble so I decided to build a new PC with a SLI configuration because after looking for a lot of benchmarks I discovered that this two games scale perfectly on multi-GPU configurations.

Unfortunately after the build and some tests I discovered that the framerate (FPS) are very good only in single player mode.

I play only in multiplayer, so I notice that in the center of the city and when is a lot of action the FPS drops down to 45 in some cases and CPU is at 30% and both GPU use drop down to 35% too...

When I am in the base or out of the city I can play up to 110 FPS or more.

 

The situation vary from server to server, but most of them drop down below 60 fps in this kind of situations described before.

 

I hope in the future version of the game can improve this performances, maybe in the next 64bit RC?

 

My system: 

Nvidia drivers 378.72
Windows10 x64, Asus Rog Maximus IX Apex, i7 7700k @4.9GHz, 2x GTX 1080 SLI, 32Gb G.Skill F4-3200C14D-32GVK 14-14-14-34-2N , AOC AGON AG271QG 165Hz

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×