Jump to content
k3lt

Low CPU utilization & Low FPS

Recommended Posts

So you get 80-90 with how many AIs involved? If you have a big fight in the city you get 80-90 FPS?

I'm talking singleplayer

Share this post


Link to post
Share on other sites

Im sorry im not allowed to post direct Links yet.

forums.dayzgame.com/index.php?/topic/180112-possible-performance-bug-found-howto-fix-it/#entry1853874

This is part of the Key to fix this mess!

Geometry and Texture Loading needs to get a seperate Thread!

Try for yourself, Same performance on 2 core and 3 core restriction. The engine is only using 2 Cores, all the other load is generated by your OS scheduling the work on the unused cores.

I have spend Hours&Days with this.

We need a Costum Thread Allocator! This is the Key.

Share this post


Link to post
Share on other sites

It spreads the work across all cpu cores/threads, but it still doesn't utilize more than 2 cumulative cores/threads worth of cpu. You can watch it peak (and watch your gpu usage tank when it happens). I've never seen a cpu usage benchmark for this game (or arma 2) that doesn't appear to have a hard cap at ~ 2 cores worth of total usage. Which then causes the GPU to have to wait around. On top of it being a dual core engine (at best), it also seems terribly inefficient (or buggy as hell) in the way it executes its tasks. It seems to especially have a hard time with "objects" (which probably 80+% of the content rendered on the screen gets classified as an "object").

For years they've played the avoidance game on this issue. And, they seem to prefer absolute vagueness (when they actually do say anything) with regards to it. Which (I think, rightly) should make you suspicious of their future intent. I'd actually gain back a little respect for them if they were just straight up about what is either incompetence, or an inability or lack of desire to address it meaningfully... say what it is, and why they won't fix it. At least shoot straight with the customer base about it. All we really ever get on this issue is the occasional carrot dangle, which ends up amounting to nothing... or, the occasional sarcasm/condescension. If there is something they can be a smart ass about, they will respond... If you attempt to provide some sort of meaningful feedback about the issue (with no guidance from them, mind you) it generally seems ignored.

Bohemia was well-positioned to get ahead of the coming competition and position this franchise for the long-term. Instead... they will realize (in my view) that they have dug their own grave (or will be playing major catch up in a market they have had to themselves for the better part of a decade) in the next 2 years or so. In my opinion, they've been content to rely on niche, rather than realize the full potential of the genre. Competition is coming...

Personally, I'd enthusiastically take a thinned out game built on a solid foundation (which would offer much more potential to modders), rather than one built on an obsolete one that is so easily stretched to the breaking point (be it thin or full of content).

Click through, and read all the dev posts in just this thread... it's pretty telling, in my opinion.

Share this post


Link to post
Share on other sites

Hello, everyone.

Can please anyone tell me, is this even possible to run ArmA 3 with decent FPS while I have following settings:

CPU: i3 540 with 2 cores and 4 threads. (3.07GHz)

RAM: DDR3 7GB with NB frequency of 2128MHz

VideoCard: NVIDIA GeForce GTX 650 2GB

Motherboard: MSI H55M-P31 (MS-7636)

In SP, game runs fine on High settings yet like with the others, in MP I have stable 15-18FPS, which is really frustrating. >__>

Share this post


Link to post
Share on other sites
Hello, everyone.

Can please anyone tell me, is this even possible to run ArmA 3 with decent FPS while I have following settings:

CPU: i3 540 with 2 cores and 4 threads. (3.07GHz)

RAM: DDR3 7GB with NB frequency of 2128MHz

VideoCard: NVIDIA GeForce GTX 650 2GB

Motherboard: MSI H55M-P31 (MS-7636)

In SP, game runs fine on High settings yet like with the others, in MP I have stable 15-18FPS, which is really frustrating. >__>

As far as I know, if your single player runs "fine" (what is that exactly, by the way; like above 40fps?), but much worse in MP, like 15-18 fps - then everyone on that server will have about the same frame rate, whatever their setup is.

In that case the client fps is dictated solely by the server.

Edited by Greenfist

Share this post


Link to post
Share on other sites
(what is that exactly, by the way; like above 40fps?)

Yes, it's jumps between 36 and ~48. Sometimes higher, sometimes a tiny bit lower. It's just a play with the game settings and launch parameters + amount of AI and particles during the mission.

Share this post


Link to post
Share on other sites

Ah well. That's it. Uninstalled Arma 3, taking a break. Getting tired of this now. The feedback tracker have had the same top-voted ideas/problems since the alpha.

Awsome priorities.

Share this post


Link to post
Share on other sites
Ah well. That's it. Uninstalled Arma 3, taking a break. Getting tired of this now. The feedback tracker have had the same top-voted ideas/problems since the alpha.

Awsome priorities.

On the 20th Win comes out I believe? By then I'm going to play through the entire campaign and then take a break me too, I think.

Give it a year... maybe thing will be better, maybe they won't.

Share this post


Link to post
Share on other sites

well u lasted longer than me any way I uninstalled arma 3 ages ago.

as said most voted problem and they ignore us where is this performance blog we was told about.

this is arma 2 all over again but much worse if you lot hink it will be fixed it wont i know for sure because this happened in arma 2 they said they could not fix it due to engine limitations.

Its nice how we get devs in here to answer us on this matter......oh wait we dont there ignoring it because they have no idea what to do to fix it :(

Ah well. That's it. Uninstalled Arma 3, taking a break. Getting tired of this now. The feedback tracker have had the same top-voted ideas/problems since the alpha.

Awsome priorities.

Share this post


Link to post
Share on other sites

Same for me... uninstalled this game LONG ago, same with my entire clan and friends. Seems to be the only solution to this problem.

Share this post


Link to post
Share on other sites

I have been looking at the devbranches changelogs for months and sadly there are hardly any changes regarding optimization :( Just unneccessary zeus content. And performance just keeps falling with every patch

Share this post


Link to post
Share on other sites
I have been looking at the devbranches changelogs for months and sadly there are hardly any changes regarding optimization :( Just unneccessary zeus content. And performance just keeps falling with every patch

Thats right, since last 1-2 patches specially when i am in an AttackChopper and shooting EnemyVehicles (hardest wierd issues when bullet hit a MSE3 Marid or Kayman) my framerate is dropping from ~80FPS to !!!!!!!! 1-2 FPS !!!!!!!! but only for the time when the Shells hits the Enemy Vehicle, after that the frames are rushing back to usual. (My Rig u can see in my signature)

I have a ton of years knowledge about PC´s and Gaming and the whole area around it but i´ve never had such annoying and frustrating phenomen like that.

Anyone else are missing some frames, or did the Illuminatis stolen my frames ^^ ?

Share this post


Link to post
Share on other sites
I have been looking at the devbranches changelogs for months and sadly there are hardly any changes regarding optimization :( Just unneccessary zeus content. And performance just keeps falling with every patch

Singleplayer performance isn't falling anyways. HDAO was a great optimization.

I've been turning my settings higher and higher which may hint some slow improvements.

Share this post


Link to post
Share on other sites

SP performance is still about the same as it has always been for me...

Good in rural areas on an empty map (or limited to small infantry encounters) with good GPU usage and great fps. Urban areas can and do crap it out. Several Bohemia made showcase missions crap it out. Encounters that start to involve more infantry and/or armor crap it out. The 2nd campaign release... I didn't make it past the first mission b/c it was 17-24 fps and stuttery as usual, once I got off the beach. MP is worse, but SP has never been "ok" for me, as pretty much anything beyond rural areas, and small infantry encounters begin to choke. If I just wanted to play tiny little rural infantry encounters, there are plenty of other games out there for that. SP performance (for me) going back to Arma 2 has never been very good on the whole, and never what I would consider worthy of the size and scale of the series or maps.

Share this post


Link to post
Share on other sites
Thats right, since last 1-2 patches specially when i am in an AttackChopper and shooting EnemyVehicles (hardest wierd issues when bullet hit a MSE3 Marid or Kayman) my framerate is dropping from ~80FPS to !!!!!!!! 1-2 FPS !!!!!!!! but only for the time when the Shells hits the Enemy Vehicle, after that the frames are rushing back to usual. (My Rig u can see in my signature)

I have a ton of years knowledge about PC´s and Gaming and the whole area around it but i´ve never had such annoying and frustrating phenomen like that.

Anyone else are missing some frames, or did the Illuminatis stolen my frames ^^ ?

such issue would need detailed repro / video and also is it 1.12 or 1.13 dev?

Share this post


Link to post
Share on other sites

It´s on the actual dev Version, i might would believe it starts with one of the pre last patches, but i am not sure. For me it looks like there is too much PhysX going on, to much particles flying around when a Kayman explodes. This would be plausible due the continous stuttering. I will try to make a video till Friday.

Share this post


Link to post
Share on other sites
such issue would need detailed repro / video and also is it 1.12 or 1.13 dev?

Such issue would need qualified Devs to solve.

Are you serious? Do your job, we paid you already. Damn it...we are not your testers team. You got the hint - now go and check it yourself. Its easy to reproduce...as most of the reported bugs and issues. Only problem is that you dont care or listen to your customer...

And for what a detailed report if you continue to ignore it?

Unbelievable....

Edited by Duke49th

Share this post


Link to post
Share on other sites

@duke49th, your response is quite rude, what makes you think i not already tried to replicate his problem and to no avail ? ...

contrary to your opinion, i read this and other threads on daily basis to actually collect such problems ...

Share this post


Link to post
Share on other sites

Maybe a Bis develloper can explain that performances are not only the fact of the client but are the result of the couple Server/client.

Edited by Mariodu62

Share this post


Link to post
Share on other sites
@duke49th, your response is quite rude, what makes you think i not already tried to replicate his problem and to no avail ? ...

contrary to your opinion, i read this and other threads on daily basis to actually collect such problems ...

I cant name the reported bugs right now, without taking a look into the bug tracker. But there are certain serious bugs/issues reported many month ago and still not resolved.

But you guys have time to add more content and fix silly bugs/issues that nobody cares about. For example the color of the fishing nets.

Beside that there are bugs that are in since 2001 from OFP. 13 years and no fixes.

Before you spend 500.000 $ or € for a contest you better should spend the money for more devs.

There are many very good modders turning the back on BI already coz of your (not ur personal maybe..but the company BIS) ignorant bevahiour to fix the most important issues before developing more content or functions that brings more bugs or difficulties to bug fixing.

You wonder why Im rude? Because I spend money for 13 years now for products which every single of them didnt pass a quality that other developer (if that would be their software) would call a beta. Hardly a beta. A very much buggy beta....

I dont know who exactly is responsible for that. But it pisses me off.

Then I read someone who paid the game and wants to play shall now record a video, make a detailed repro and so on. It is not his job. He paid for the product...not for doing your job.

You also have to keep in mind that many players buy hardware just in the hope to have better performance..and will be dissapointed. So it is not only ~45€ that many customer paid. Not rarely people spend hundreds of Euro just to play this game...and you slap them with your actions...or better call it inaction.

Edit: Again..Im talking to the company BI if I say you...but you are one of the devs..so..in some point of view I taalk also to you.

Edited by Duke49th

Share this post


Link to post
Share on other sites

Yes but that stuttering issue i posted is not MP, its on Singleplayer. In this case its easy to reproduce. And i am not the only one with this problem, so its not my PC or missing files.

Share this post


Link to post
Share on other sites
After today's patch... still all the same issues. No noticeable change or improvement. No surprise.

U mean the stable version Patch? It´s a little bit disappointing, i mean what is wrong with this Engine, in my opinion it cant be that Multi-GPU Systems of the newest gen has such issues when it comes to the Frames per second. When the game would have the optics of Crysis i would understand it....

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×