Jump to content
Sign in to follow this  
AustinAtSt

Wierd Little Bird glitch. Anyway to fix?

Recommended Posts

Setup:

A camera follows 3 little bird helicopters on route to an LZ, randomly start spazzing out. This only happens when in camera mode and not player mode.

Video:

http://youtu.be/YMOs57ZuLJU

Solution? Mod error? General game glitch??

Also while im here, what's the new script for **soundFading since the original doesn't work anymore?

Share this post


Link to post
Share on other sites

Sometimes cameras become really jerky with moving objects. I'm not sure why. That's my experiences anyhow, maybe someone else has a solution for both of us.

Share this post


Link to post
Share on other sites

I'm not sure right now, but I vaguely remember to having fixed this using a game logic in the past.

Attaching a logic, and then attaching the cam to it, instead of the heli.

Something like this:

_center = createCenter sideLogic;
_group = createGroup sideLogic;
_logic = _group createUnit ["Logic", [0, 0, 0], [], 0, "NONE"];
_logic attachTo [_littleBird, [0, 0, 0]];

_camera attachTo [_logic, [0, 5, -1]];

Share this post


Link to post
Share on other sites

[quote name=sxp2high;2287794

Attaching a logic' date=' and then attaching the cam to it, instead of the heli.

Something like this:

_center = createCenter sideLogic;

_group = createGroup sideLogic;

_logic = _group createUnit ["Logic", [0, 0, 0], [], 0, "NONE"];

_logic attachTo [_littleBird, [0, 0, 0]];

_camera attachTo [_logic, [0, 5, -1]];

Ill deff give this a go. I would put the mission file but it requires too many specific mods. And ill also see if this fixes the "jerky" camera as well.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×