Jump to content
Sign in to follow this  
eagledude4

Strange glass

Recommended Posts

I don't really know how to explain it other than a grainy/static effect that distorts anything behind the glass.

I tried uvmapping, and also removing the material.

http://i109.photobucket.com/albums/n60/eagledude4/light_zps16895453.png (321 kB)

Could this be a lighting issue or could it be because I applied a texture as well as a material containing a texture to the same face, and they're conflicting?

texture merging enabled: yes

Lighting and shadows : normal and shadow enabled

glass.paa size: (not used for material)

128x128

material:

surfaceInfo="ca\data\Penetration\glass.bisurf";
ambient[]={0.40000001,0.40000001,0.40000001,0.40000001};
diffuse[]={0.40000001,0.40000001,0.40000001,0.40000001};
forcedDiffuse[]={0,0,0,0};
emmisive[]={0,0,0,0.40000001};
specular[]={1,1,1,0.40000001};
specularPower=32;
renderFlags[]=
{
"NoAlphaWrite"
};
PixelShaderID="Glass";
VertexShaderID="Glass";
class Stage1
{
texture="#(argb,8,8,3)color(0,0,0,0.1)";
uvSource="none";
};
class Stage2
{
texture="UltRP_Skins\env_co.paa";
uvSource="none";
};

Edited by eagledude4

Share this post


Link to post
Share on other sites

env_co.paa - responsible for the reflection of the glass, is not glass texture. Do as advised [APS] Gnat.

Share this post


Link to post
Share on other sites

Using that material with my glass texture has the same effect.

I also tried using my reference model's texture and rvmat that I know for a fact shows correctly, so I don't think this is a texture or rvmat issue, maybe lighting? I don't think the glass itself is the issue, but how things are rendering behind it.

stupid forums converting my image tags to url tags:

http://i109.photobucket.com/albums/n60/eagledude4/light_zps16895453.png (321 kB)

Edited by eagledude4

Share this post


Link to post
Share on other sites

moderator - please delete this post. thx

Edited by Yac

Share this post


Link to post
Share on other sites

Same issue I'm afraid. Would you be willing to take a look at my model?

EDIT: while editing a different model, I experienced the same occurance. Using the glass_ca that you provided with both with and without the glass rvmat, geometry stops being rendered or becomes distorted while looking through the glass.

Edited by eagledude4

Share this post


Link to post
Share on other sites

i have another advice

do not use Photoshop plugin

save to TGA than save to PAA using BIS tools

except advice above which is of course accurate, and of course this glass have to be set as said above by RobertHammer

Share this post


Link to post
Share on other sites

do not use Photoshop plugin

Using the OLD Photoshop plug-in ?! ..... surely not !

Thats definitely the way to get messed up textures.

Share this post


Link to post
Share on other sites

@RobertHammer: No I didn't, I don't even know what that function does :P

@vilas: I didn't use any plugins as I did not create the texture myself.

I'll try rockethamer's suggestion and hopefully that resolves this issue.

EDIT: Works, thanks RH

http://i109.photobucket.com/albums/n60/eagledude4/window2_zpse712fa9e.png (211 kB)

Edited by eagledude4

Share this post


Link to post
Share on other sites

So the issue resolved - Do not forget to delete the link to your file

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×