Jump to content
Sign in to follow this  
highhead

Multi-Session Operations v4.5 released

Recommended Posts

As for crashing, we've not had any crashes with beta_Build_101334. We've run Reshmaan for nearly 3 weeks, restarting the server every 2 days or so to clear things up. Generally it's been very stable with only the odd bit of scripts screwing up from time to time, but then we run a lot of mods so it's to be expected.

I have had CTD issues as well. It's not very consistent however when it happens it tends to create a deadzone where any other players that enter that area will crash. Previously, the issue stopped coming up when the beta patch was run on the server but not the clients. With the CBA changes though that's no longer an option.

Edit: Nevermind, I resolved my issue. Since I redid my servers .bat file I've been launching the wrong arma2oaserver.exe

Edited by Fadi

Share this post


Link to post
Share on other sites

Chaser98, PDB is off by default. Just leave the settings in params for PDB "off".

Fadi, We dont run into crashes, but If you still have crashes with latest beta please send the crashdump to Dwarden.

Frosties, for detailed PDB support please join us in MSO Skype Channel (just PM me your skype username)

enjoy

Share this post


Link to post
Share on other sites

Please answer guys, using ACE.

On my friends dedicated server I can use logistics demand, on my friends hosting from desktop server I can use logistics demand, then when I host off myself I can't and I know it's not a setting, I even used same slot as the one that worked! Please someone answer this. Logistics demand is real important to me.

Edit: Just tried 4.5 and Logistics Demand was on there but went back to 4.55 and it was gone, my friends were using 4.55 :/

Still need a answer!

Edited by Zaksle75

Share this post


Link to post
Share on other sites
Please answer guys, using ACE.

On my friends dedicated server I can use logistics demand, on my friends hosting from desktop server I can use logistics demand, then when I host off myself I can't and I know it's not a setting, I even used same slot as the one that worked! Please someone answer this. Logistics demand is real important to me.

Edit: Just tried 4.5 and Logistics Demand was on there but went back to 4.55 and it was gone, my friends were using 4.55 :/

Still need a answer!

Hi,

TUP_Logisitics only works on a dedicated server (also local dedi works fine), and you need an ACE Radio (PRC-117,119 f.e.) to call it in.

Which mission are you trying by the way?

Enjoy

---------- Post added at 08:27 ---------- Previous post was at 08:24 ----------

Can someone also tell me how to increase how much bots we can recruit, 7 isn't enough.

support/modules/rmm_recruitment/dialog.hpp --> just increase "{!isplayer _x} count (units player) < 6)" to whatever you want

hope i could help!

HH

Share this post


Link to post
Share on other sites

Yeah someone told me bout the Ai recruit, and the thing with logistics is that the HOST can't use it. But clients to you can.

Share this post


Link to post
Share on other sites
Yeah someone told me bout the Ai recruit, and the thing with logistics is that the HOST can't use it. But clients to you can.

->> Changed for upcoming version! TUP Logisitics can then also be requested as HOST.

You can change (isServer) to (isDedicated) in support\modules\TUP_Logistics\main.sqf on Line 65, if you want to do it before (quite simple).

Enjoy!

HH

Edited by highhead
so many spelling errors..... pff....

Share this post


Link to post
Share on other sites
Make sure you've dropped your old db schema and imported the latest one included in the PDB folder. There were quite a few changes to the db in the uplift to 4.55

Im using MSO20121110.sql wich was the one we had before, cannot seem to find a newer SQL ?

Share this post


Link to post
Share on other sites

In my RAR file with MSO 4.55 it is still called MSO20121110.sql and dated 10th of November?

Downloaded the file from the file page on dev-heaven just now.

Share this post


Link to post
Share on other sites

That'll be the correct one for the version you are using. If it's not working, double check the locations and setup etc again and try dumping the schema and reloading it.

Share this post


Link to post
Share on other sites

Hi guys. i'm looking to increase the max unit recruit value by player . so far, after browing in every file in rmm_recruitment i found that :

class Transmit : CUI_Button {

text = "Request";

w = CUI_Box_W;

y = CUI_Row_Y(2);

h = CUI_Row_DY(0,1);

action = "if ({!isplayer _x} count (units player) < 6) then {(group player) createunit [tup_recruit_classes select (lbCurSel 1), [player, 50] call CBA_fnc_randPos, [], 0, ""FORM""];};";

};

that 's it right ?

Share this post


Link to post
Share on other sites
->> Changed for upcoming version! TUP Logisitics can then also be requested as HOST.

You can change (isServer) to (isDedicated) in support\modules\TUP_Logistics\main.sqf on Line 65, if you want to do it before (quite simple).

Enjoy!

HH

In the PBO or the base code folder?

Edit: How can I change it? Can you give me short step :D?

Edited by Zaksle75

Share this post


Link to post
Share on other sites

So I've made an alternate version of MSO where the FOB is at the South airfield, but for some reason dumbass AI pilots like to just land and sit there all day. How can I stop jets from spawning?

Share this post


Link to post
Share on other sites
So I've made an alternate version of MSO where the FOB is at the South airfield, but for some reason dumbass AI pilots like to just land and sit there all day. How can I stop jets from spawning?

In the parameters of the mission theres a thing called like Air Traffic and you can set it's intensity and / or disable it.

Share this post


Link to post
Share on other sites
That'll be the correct one for the version you are using. If it's not working, double check the locations and setup etc again and try dumping the schema and reloading it.

Ive re-done everything but still cannot get past the Please wait setting up client..

Tried looking in the logs, but no logs is started so that leave me thinking that @ArmA2net isnt started properly?

Database.txt is in every location i could think of...

The database is fresh

Have no idea how to proceed or how to troubleshoot.. :(

Share this post


Link to post
Share on other sites

Database.txt should be in <users\*yourname*\AppData\local\arma2mysql>

make sure the info in it is correct,

mysql,arma,127.0.0.1,3306,arma,arma

mysql, - correct all ready leave

arma, - the name of your database in mysql workbench

127.0.0.1,3306 - internal ip address of database

arma, - the mysql username you setup

arma - the password associated with the username above

Share this post


Link to post
Share on other sites
Database.txt should be in <users\*yourname*\AppData\local\arma2mysql>

make sure the info in it is correct,

mysql,arma,127.0.0.1,3306,arma,arma

mysql, - correct all ready leave

arma, - the name of your database in mysql workbench

127.0.0.1,3306 - internal ip address of database

arma, - the mysql username you setup

arma - the password associated with the username above

Yeah has this changed since 4.4? I swear I was able to put the database.txt into the root arma directory last time... the issue being if it has to go into the AppData\local\arma2mysql folder then I need to create a new user for each instance of MSO running on the server. Is there a way to have it look where the arma2OAserver.exe file is first?

Share this post


Link to post
Share on other sites
Yeah has this changed since 4.4? I swear I was able to put the database.txt into the root arma directory last time... the issue being if it has to go into the AppData\local\arma2mysql folder then I need to create a new user for each instance of MSO running on the server. Is there a way to have it look where the arma2OAserver.exe file is first?

Yes - see here.

Share this post


Link to post
Share on other sites
Well, I guess what would be interesting is that the server is limited to 50FPS, which I guess sets a limit on the potential clock cycles available to the AI scripts. So having the AI managed by the HC on some of your spare cores might result in even better AI performance.

It would certainly be interesting to hear how the game played when all 6 cores were contributing, which is obviously what would happen if you ran client/dedi server/HC on your PC.

For a little while I experimented with giving the client and server cpu settings in the startup eg 2 cores each, and also with setting process affinity, however I have found the best performance to be just leaving them alone.

I am going to try...just got to figure out how to do it! and then i will let you know!:) Does anybody has a MSO mission that support HC that i can use? Please.

Thanks!

Edited by Grillob3

Share this post


Link to post
Share on other sites

Why is the Ai so stupid in this mission, especially in base.

P.S. Talking bout Zargabad and Takistan.

Share this post


Link to post
Share on other sites
Yes - see here.

Thanks Axek.. perhaps I don't have the latest version or something.. will try again.

I am going to try...just got to figure out how to do it! and then i will let you know!:) Does anybody has a MSO mission that support HC that i can use? Please.

Thanks!

I do but it's for MSO 4.4 not sure if there is a more recent version that is 'released'

Why is the Ai so stupid in this mission, especially in base.

P.S. Talking bout Zargabad and Takistan.

Stupid AI (all jokes aside) are usually caused by low server FPS

Share this post


Link to post
Share on other sites
Why is the Ai so stupid in this mission, especially in base.

P.S. Talking bout Zargabad and Takistan.

What are you talking of? Friendlies? Fr enemies we get requests all the time to make em less deadly...

Overall:

AI behaviour is not directly mission related... its regular ArmA2-AI, and we did not mod that. If enemies are too "soft" for you then turn up your skill settings, play at veteran and not as cadet, and use ASR AI or ZEUS AI.

Enjoy

HH

---------- Post added at 09:50 ---------- Previous post was at 09:30 ----------

Hi Grillob!

I suggest you join us in MSO Skype Channel as you are very active and we can assist you better! Fling me a PM and ill add you!

We can send you the latest GIT develop branch, that fully supports HC for each of the MSO modules! So you can switch whatever you need to on the HC only by switching on params on mission-start! Setting up a HC has never been easier!

For all of you waiting for the upcoming release: BIS is in the final phase of 1.63 patch (delayed already) and there will be many improvements for server performance and mandatory fixes for headless client usage that are not in official 1.62 patch yet. So expect the new release almost together with new BIS patch!

You are all welcome to use latest MSO DEV branch on GIT (with beta patch), in the meanwhile!

Enjoy!

HH

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×