Jump to content
Sign in to follow this  

Arma 2 & OA Freezing every 3-5 seconds - the return of the bug no one solved

Recommended Posts


I bought Arm2 and Arma2 CO with the intention of playing it + DayZ.

However, i encounter a problem: screen freezes from menu to game every 3 seconds, making it unplayable.

I have snooped around on the Great Internet and saw that some people experience the same issue, without finding a similar pattern in the rigs.

What annoys me is that no one seems to have discovered anything about this, every little trick that has been tried has failed yet (cannot post links because postcount is too low :()

I have an old computer but it *should* run the game finely, even with very low graphics. I of course tried downgrading the graphics, etc. No luck as of now.

My computer:

Core 2 Duo E 8200 @ 2.66Ghz

MB: P35-DS3

Mem: 4096GB DDR2

GC: HD6770 1GB

Vista 32bits

Any ideas ?

Thanks a lot

Share this post

Link to post
Share on other sites

What about your Hard disk? how many rpm? did you try to defragment it? any programs running in the background? malware etc tested?

Driver up to date? how is the game running without mods?


Thanks for the answer. My HD is a Samsung SpinPoint T - HD321KJ - 320 Go 7200 RPM, i defragmented it, used ccleaner, tried with ou without gamebooster, antivirus off etc. Video drivers are the latest.

The problem is the same on Arma 2, OA and DayZ.

I'm reading here and there that Arma2 is highly demanding CPU-wise. Maybe i should try overclocking ? I'm really out of options, mainly because i'm bad at computers.

Share this post

Link to post
Share on other sites

I think you have a problem with PowerPlay in your system. Google for "how to disable powerplay" or look this


1. Open CCC

2. Unlock and Enable Overdrive if they aren’t already.

3. Go to Options/Profiles/Profiles Manager. Create a new profile. Under composition make sure “ATI Overdrive†is checked. Save and Close, DO NOT ACTIVATE.

4. In windows go to: C:\Users\{yourusername}\AppData\Local\ATI\ACE\Profiles (you will need to have “show hidden files†turned on for this)

5. Open the xml document with the name of the profile you just created (notepad is fine)

6. Change the values of the Clock and Memory speeds to look like this

<Feature name="CoreClockTarget_0">

<Property name="Want_0" value="your 3D GPU speed" />

<Property name="Want_1" value="your 3D GPU speed" />

<Property name="Want_2" value="your 3D GPU speed" />


<Feature name="PowerControl_0">

<Property name="Want" value="0" />


<Feature name="MemoryClockTarget_0">

<Property name="Want_0" value="your 3D VMEM speed" />

<Property name="Want_1" value="your 3D VMEM speed" />

<Property name="Want_2" value="your 3D VMEM speed" />


<Feature name="CoreVoltageTarget_0">

<Property name="Want_0" value="Voltage need for 3D" />

<Property name="Want_1" value="Voltage need for 3D" />

<Property name="Want_2" value="Voltage need for 3D" />

7. Save and close. Go back to CCC and activate the profile you just created.

8. Run game and see if this helps you.

PS. download GPU-Z to see your 3D GPU and VMEM speed and Voltage in 3D

Share this post

Link to post
Share on other sites

I won't overclock.

Dual Core should be fine, ArmA won't use more than two cores (or net very much).

Even if it is not the non plus ultra - I was even able to play on a Pentium 4 2800Mhz with 1.5GB 400 Ram and X1900 Pro.

Did you try to lower all settings - and line them up afterwards more and more to find the more ideal settings?

Share this post

Link to post
Share on other sites

Thanks for both your answers!

Being bad at computers i tried the 'no powerplay' thingie but all i managed was crashing my computer (i might have done something wrong), but the lead was good, i'll try to do it properly.

For Snowsky, yes i tried downgrading my settings to the point i thought i was playing a 90's FPS, but the problem stayed the same.

I'll try to do again the 'no powerplay' thingie in a more proper way. For now I am fairly annoyed I cannot play this awesome game.

I'll update with more info whenever I can. Thanks to all !

Share this post

Link to post
Share on other sites

Manufacturer and model of your 6770 is....

Share this post

Link to post
Share on other sites

GPU-Z is showing Bus Interface PCI-E 1.1x16. Your HD6770 1GB is PCI-E 2.1x16. This may be the cause of your issues. I know your card is backwards compatible with bus interface, but it all depends on your motherboard. Check if there is a bios update for motherboard.

Is this your motherboard http://www.newegg.com/Product/Product.aspx?Item=N82E16813128059. Sounds like you have got a hardware compatibility issue. I'd suggest geting a newer motherboard. And please don't post silly things like "all my other games work fine".

Edited by Flat4ej20

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this