Jump to content
Sign in to follow this  
marshy

Arma 2 CO - reinforcements has stopped working help?

Recommended Posts

So i decided to try installing DayZ i installed it using six updater i think thats what it is called then in a rage of not being able to get it to work and wanting to play the normal CO i unisalled Six updater and deleted the @DayZ files in the folder now when ever I try to launch the game and play multiplayer i get an error "reinforcements has stopped working" I have no idea what to do at all i was perhaps think of just uninstalling Arma 2 and Arma 2 operation arrow head (I launch the game In Arma 2 CO btw). Can anyone help me? I have the steam version btw thank you in advance!

Iv also install the beta patch which is need to play DayZ I think that may be the problem but Arma 2 and Arma CA doesnt work at all when trying to play multiplayer

Marshy

Edited by marshy

Share this post


Link to post
Share on other sites

Same problem here. Had to update to beta version 95054 to play DayZ now when I try to unload the beta to play on a v1.60 version I get the same error.

Share this post


Link to post
Share on other sites

I get this problem as well. It says Arma 2 reinforcements has stopped working and when I look at the problem details it says the following.

Problem signature:

Problem Event Name: BEX

Application Name: ArmA2OA.exe

Application Version: 1.60.87.580

Application Timestamp: 4ef2c80b

Fault Module Name: DSOUND.dll

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 4efe0255

Exception Offset: 000046c8

Exception Code: c0000417

Exception Data: 00000000

OS Version: 6.1.7601.2.1.0.768.3

Locale ID: 1033

Additional Information 1: c7b6

Additional Information 2: c7b6ab383ee417a5f04e7848aead0fca

Additional Information 3: 26a9

Additional Information 4: 26a9562c70fb80df38d5edece59a822c

So I am assuming it is something with the dsound.dll file, but that is in my folder so it is not like it is missing, rather there is a problem with the actual file. I've already uninstalled and re installed to no avail.

Share this post


Link to post
Share on other sites

bump! still looking for a fix i am re installing it right now to see if i can fix it

Share this post


Link to post
Share on other sites
I get this problem as well. It says Arma 2 reinforcements has stopped working and when I look at the problem details it says the following.

Problem signature:

Problem Event Name: BEX

Application Name: ArmA2OA.exe

Application Version: 1.60.87.580

Application Timestamp: 4ef2c80b

Fault Module Name: DSOUND.dll

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 4efe0255

Exception Offset: 000046c8

Exception Code: c0000417

Exception Data: 00000000

OS Version: 6.1.7601.2.1.0.768.3

Locale ID: 1033

Additional Information 1: c7b6

Additional Information 2: c7b6ab383ee417a5f04e7848aead0fca

Additional Information 3: 26a9

Additional Information 4: 26a9562c70fb80df38d5edece59a822c

So I am assuming it is something with the dsound.dll file, but that is in my folder so it is not like it is missing, rather there is a problem with the actual file. I've already uninstalled and re installed to no avail.

if the problem IS the "DSOUND.dll" then you should try deleting it, after i saw that i deleted that .dll file from the ArmA 2 OA folder, the game ran just fine, maybe is this the solution to this problem that started stalking the other people ever since the relase of ArmA 2?

Share this post


Link to post
Share on other sites
if the problem IS the "DSOUND.dll" then you should try deleting it, after i saw that i deleted that .dll file from the ArmA 2 OA folder, the game ran just fine, maybe is this the solution to this problem that started stalking the other people ever since the relase of ArmA 2?

Where might I find this dsound.dll? I have done some research and it is for a mod called ACRE? I never downloaded this so, I don't know if I would have it.

Share this post


Link to post
Share on other sites

I have just recently installed the 95099 beta patch from six updater to play DayZ. I can access dayZ just fine but when I opened ArmA2OA in steam and tried to join a multiple player game such as "takastani life rpg," then I get the Arma2: reinforcements has stopped working... error. I know it's probably something related with the latest beta patch because I could play both just fine before the patch. While I am still able to access dayZ, i just can't play any ArmA 2 multiple player games. I also did not see the dsound.dll file in my ArmA 2 OA directory. If someone find a fix, I could use some help! thanks all

Edited by theAei

Share this post


Link to post
Share on other sites
I have just recently installed the 95099 beta patch from six updater to play DayZ. I can access dayZ just fine but when I opened ArmA2OA in steam and tried to join a multiple player game such as "takastani life rpg," then I get the Arma2: reinforcements has stopped working... error. I know it's probably something related with the latest beta patch because I could play both just fine before the patch. While I am still able to access dayZ, i just can't play any ArmA 2 multiple player games. I also did not see the dsound.dll file in my ArmA 2 OA directory. If someone find a fix, I could use some help! thanks all

I'm in this exact same situation. I've tried everything.

Share this post


Link to post
Share on other sites

Played DayZ just fine, when when I tried to launch game without beta-patch for an Insurgency session, Reinforcements stopped working.

This helped me get up and running again:

"Hitman0956": delete your beta version

"Hitman0956": install 94876 beta version o

"Hitman0956": download http://www.battleye.com/download.html

"Hitman0956": v1.11 / v1.60 / v1.61.94876 BE Client for Windows (32-bit) - MD5: 6c3fc9824f0f7a548fcbac0171b14c65

"Hitman0956": replace it with old file in C:\Users\%USERNAME%\AppData\Local\ArmA 2 OA\BattlEye\

Not sure what to do when I have to play DayZ again, but atleast I got to play some Insurgency.

Edited by Dallas

Share this post


Link to post
Share on other sites

Yeah I thought I fixed it, but all deleting that dsound.dll file did was let me start up ARMA2 OA and CO. I can't join any multiplayer games or servers but DayZ works just fine when I launch it.

Share this post


Link to post
Share on other sites

I have the same exact problem it happened with one of the past 2-3 beta patches my clan server is running beta patch 95054 and I have this problem now. I didn't have it before 95054 I've tried higher beta patches nothing works even with a clean install of arma 2 CO. Dayz still works perfect but arma 2 missions like insurgency wont run I crash as soon as I start to load into the server from lobby. Oddly enough ace mod works still but vanilla arma 2 just wont go. I've tried to delete the soundd.dll or w/e it was but no luck.

Share this post


Link to post
Share on other sites

edit: for those with my problem below:

https://dev-heaven.net/issues/37100

mamersmann 5 days ago

found a fix, deleting the BEClient.dll in Appdata/Local/arma2oa fixed the error messages popping up

This works! Can play on 1.6 servers. I suggest renaming that file to .old, though...

--------

I have the same problem, except it is the BeClient.dll that is causing the crash. Am using the latest beta 95208 for DayZ, core OA is 1.6 Steam version, running combined ops, game crashes with this error after joining a game of Warfare and picking sides, loading in. I'm not using any mods right now just trying to get into any Warfare game. Have tried replacing the BE files but it still crashes. Have tried creating a BattlEye folder in the main OA directory, still crashes.

As far as I was aware, the beta patch does not overwrite the core game files, is this true or not? (It's not an RC).

Edited by Harmonica

Share this post


Link to post
Share on other sites
Yeah I thought I fixed it, but all deleting that dsound.dll file did was let me start up ARMA2 OA and CO. I can't join any multiplayer games or servers but DayZ works just fine when I launch it.

haven't tried joining online, i usually play the editor on ArmA (like everybody else) so i cant tell if its only you or this is normal after deleting dsound.dll

I'm in this exact same situation. I've tried everything.
I have just recently installed the 95099 beta patch from six updater to play DayZ. I can access dayZ just fine but when I opened ArmA2OA in steam and tried to join a multiple player game such as "takastani life rpg," then I get the Arma2: reinforcements has stopped working... error. I know it's probably something related with the latest beta patch because I could play both just fine before the patch. While I am still able to access dayZ, i just can't play any ArmA 2 multiple player games. I also did not see the dsound.dll file in my ArmA 2 OA directory. If someone find a fix, I could use some help! thanks all

you guys above me, kuponk and theaei, cant actually complain about that since you guys are using BETA-patches, if you guys dont want any problem, try using stable patches

Where might I find this dsound.dll? I have done some research and it is for a mod called ACRE? I never downloaded this so, I don't know if I would have it.

ArmA 2/ArmA 2 OA main folder (if you have a Steam version, its inside Steam/Steamapps/Common)

Share this post


Link to post
Share on other sites

Go to your arma 2 oa folder > open Expansion > open BattlEye and run the uninstall.exe

Go to your arma 2 folder > open BattlEye and run the uninstall.exe (if it isn't there, don't worry about it)

Run the game with (the beta should still be installed - doesn't matter what one)

Try to join a server - you should get stuck at either Loading or Wait for Host - this is normal

Close the game and go back into your arma 2 oa folder > Expansion and delete the beta.

Download and install beta patch 94700

It will ask you to install BattleEye, do so.

Go into your arma 2 folder > go into BEsetup and run the .exe

Go back into your arma 2 oa folder > Expansion> beta and copy the BattleEye folder (DO NOT CUT OR DELETE IT - YOU ARE MAKING TWO COPY'S OF IT).

Paste the BattleEye folder in the main arma 2 oa directory.

Open arma 2 oa and join a NORMAL arma game.

Share this post


Link to post
Share on other sites

I came here to find this thread because I'm experiencing the same issue.

Up until a few beta patches ago I played both DayZ and then Arma2, Operation Arrowhead multiplayer servers. Not sure what patch caused the issue because it was only tonight that I tried to go play some multiplayer.

I am getting the same crash as described here.

I am also very low knowledge level when it comes to this type of thing, and not sure how to do some of those fixes that have been described.

If I wait and just play DayZ, will an upcoming beta patch or full patch fix the issue?

Thanks.

Edited by Slyder73

Share this post


Link to post
Share on other sites

Does anyone have any knowledge of this or better up to date on what is being worked on for a fix?

Thanks.

Share this post


Link to post
Share on other sites

I am also experiencing the same issue. I don't play DayZ, but I installed the most recent beta patch and since then I can no longer play online. A huge percentage of the players in my community are also having this issue. We were hoping it was being fixed today while Gamespy was down, but no dice.

BI, any idea as to when a hotfix will be released so we can all go back to playing?

Share this post


Link to post
Share on other sites

Registered to post that me and a bunch of players are getting this very same problem - any clues on fixes would be fantastic.

Cheers

EDIT - Everyone in my group except one (5 in total) is experiencing this. Hmmmmm.

Edited by Jimieus

Share this post


Link to post
Share on other sites

Yeah I have the BEClient.dll thing. I delete it but then the game just recreates it, so I continue to get the error. Really?

Any way to make it stop creating the BEClient.dll?

Share this post


Link to post
Share on other sites
Yeah I have the BEClient.dll thing. I delete it but then the game just recreates it, so I continue to get the error. Really?

Any way to make it stop creating the BEClient.dll?

Reinstall battleeye client so it recreates the right one.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×