Jump to content
Sign in to follow this  
tpw

TPWC AI suppression system

Recommended Posts

What general AI mod or mods works best with TPWC_AI?

I really want AI to stop staring directly towards an enemy without shooting and I'd very much like to make them take cover behind stuff.

Any suggestions?

In my humble opinion it's SLX, just using SLX AI features alone with no other mods, AI move very quickly to cover when fired upon, impressive to watch at times, the problem is they don't stay there, probably what Fabrizio was talking about earlier... Anyway adding this script to the mix they drop, think about it for a bit then move to cover.

The only problem I see with this script on it's own is if I fire at them from an elevated position they drop and get suppressed but they do not move to cover, therefore it's easy pickings as before... My testing isn't the greatest though, me as a machinegunner on the hill in desert and group close to drill buildings.

When using tpw suppress alongside slx they do cool things, I get tpw doesn't want to add other functions, ala ai super mod.. but duck and move to cover go hand in hand.

I also use Ace but being a new fan off the mod I have no idea what it brings to the mix in terms of ai behavior, in relation to this disscusion anyway.

Edited by Katipo66

Share this post


Link to post
Share on other sites

Get BIS to fix the findCover command, then it should be easy to implement, without writing walls of code in it's place.

While you're at it request the IncomingFire EH from VBS as well, I'm sure tpw would like it :D

Share this post


Link to post
Share on other sites
Get BIS to fix the findCover command, then it should be easy to implement, without writing walls of code in it's place.

That must be a beast to fix as I remember hearing about that from solus ages ago. Is there a ticket for it?

Share this post


Link to post
Share on other sites

Here's 2.06 beta, with a few nice under the bonnet changes but no major changes to functionality.

Changelog:

  • Added ability to configure whether units will flee when morale/courage drops too low.
  • Improved visual debugging code, shows black balls for fleeing units, and markers on map (thanks Fabrizio_T).
  • Code has been modularised, each function is compiled from its own sqf.
  • Courage does not drop so rapidly under fire (should lead to less premature fleeing).

2.06 beta: http://filesonly.com/download.php?file=135TPWC_AI_SUPPRESS_206.zip

Share this post


Link to post
Share on other sites

Dear TPW, I wanted to ask if there's a way to fix the Debugging balls mode?

i had the Debug on 0, and it keeps having red balls Above everyone, regardless of suppresion.

thanks.

Share this post


Link to post
Share on other sites
Dear TPW, I wanted to ask if there's a way to fix the Debugging balls mode?

i had the Debug on 0, and it keeps having red balls Above everyone, regardless of suppresion.

thanks.

What version are you using mate? I just tried 2.06 with tpwcas_debug = 0 in the hpp and there are no debug balls showing. The entire debug module simply doesn't run if tpwcas_debug = 0.

Please make sure you update your tpwcas_ai_sup.hpp in userconfig.

Share this post


Link to post
Share on other sites

Yea Thank you very much TPW,

i just double checked and appearently the version over the six updater is 1.01, someone should update it.

i updated the TPW AI Suppresion to 2.06 Beta and it works just fine, thanks alot for this awsome mod!

Share this post


Link to post
Share on other sites

Thanks for that. Development is moving so fast that it only takes a week for a version to be horribly out of date. I will get in touch with Sickboy shortly.

Share this post


Link to post
Share on other sites

I've been taking a look at the array for pistols and SMGs. I've added:

"10Rnd_9x39_SP5_VSS",
"20Rnd_9x39_SP5_VSS",
"10Rnd_B_765x17_Ball",
"20Rnd_B_765x17_Ball"

...to prevent the VSS/VAL (which fires a heavy subsonic round) and Skorpion SMG from suppressing.

A quick query - does increasing the size of the array affect performance? I only ask because if you add:

"ACE_17Rnd_9x19_G17",
"ACE_33Rnd_9x19_G18",
"ACE_30Rnd_9x19_S_UZI",
"ACE_20Rnd_765x17_vz61",
"ACE_20Rnd_9x39_S_SP6_OC14",
"ACE_20Rnd_9x39_B_SP6_OC14",
"ACE_20Rnd_9x39_S_OC14",
"ACE_20Rnd_9x39_B_OC14",
"ACE_20Rnd_9x39_SP6_VSS",
"ACE_10Rnd_9x39_SP6_VSS",
"ACE_64Rnd_9x19_S_Bizon",
"ACE_30Rnd_1143x23_B_M3",
"ACE_25Rnd_1143x23_S_UMP45",
"ACE_25Rnd_1143x23_B_UMP45",
"ACE_30Rnd_9x19_S_MP5",
"ACE_40Rnd_S_46x30_MP7",
"ACE_40Rnd_B_46x30_MP7",
"ACE_15Rnd_9x19_P8",
"ACE_15Rnd_9x19_P226",
"ACE_13Rnd_9x19_L9A1",
"ACE_15Rnd_9x19_S_M9",
"ACE_20Rnd_9x18_APSB",
"ACE_20Rnd_9x18_APS",
"ACE_8Rnd_762x25_B_Tokarev",
"ACE_12Rnd_45ACP_USP",
"ACE_12Rnd_45ACP_USPSD"

...you get instant ACE compatibility! :D

Share this post


Link to post
Share on other sites

Hi CMcD

Performance will probably be impacted by about 0.000000000000001%. I'd say go ahead with it!

Share this post


Link to post
Share on other sites

@TPW

RamBoRaideR and I are working together and we wanted to add your suppression mod to our servers to make it more realistic and all but those debugging balls won't go away even when I turn the debug off. To make matters worst I removed the mod

and the userconfig folder from my server and the balls came up out of no where. I have the mod disabled and everything and the balls just showed up. I used the mod and not the script by the way. On another note, I ran an operation with my unit today (even with the balloons on) and the enemy were actually being suppressed. Everyone had red balls over there even the enemy. The color didn't change but they were suppressed. Everything worked fine it's just that the balls have to go bro.

Share this post


Link to post
Share on other sites

Yes, Appearently they now Randomally Pop up, when me And Johnson tested the new 2.06 the balloons didnt come up, but once another member joined they suddenly popped up.

also, they keep on showing up even if the mod is not active on the server.

awaiting reply.

Share this post


Link to post
Share on other sites
@TPW

RamBoRaideR and I are working together and we wanted to add your suppression mod to our servers to make it more realistic and all but those debugging balls won't go away even when I turn the debug off. To make matters worst I removed the mod

and the userconfig folder from my server and the balls came up out of no where. I have the mod disabled and everything and the balls just showed up. I used the mod and not the script by the way. On another note, I ran an operation with my unit today (even with the balloons on) and the enemy were actually being suppressed. Everyone had red balls over there even the enemy. The color didn't change but they were suppressed. Everything worked fine it's just that the balls have to go bro.

So as per RamBoRaideR, are you using 2.06 or not? Sorry mate, the balls won't be removed from the code just because you don't like them, they are very useful for debugging and training.

If you'd read the 1st post or a few pages of this thread you'd know that the mod is really an SP mod, and MP and server behaviour and performance simply cannot be guaranteed at this stage. Fabrizio and Ollem are working on it...

Share this post


Link to post
Share on other sites
So as per RamBoRaideR, are you using 2.06 or not? Sorry mate, the balls won't be removed from the code just because you don't like them, they are very useful for debugging and training.

If you'd read the 1st post or a few pages of this thread you'd know that the mod is really an SP mod, and MP and server behaviour and performance simply cannot be guaranteed at this stage. Fabrizio and Ollem are working on it...

Yes, we are using 2.06.

---------- Post added at 12:21 ---------- Previous post was at 12:19 ----------

Also TPW, the problem isnt that the Red balloons are showing up, the problem is that debugging mode wont turn into 0, as the balloons always come up regardless of what we choose over the parameters.

ALSO, another problem is that right now, after we installed your mod, when we want to take it off and play without it, the balloons stays over our heads instead of disappearing.

Share this post


Link to post
Share on other sites

Hi guys. Based on your earlier threads, you initially tried to run 1.01, which only has the red debugging balls. If 2.06 is ruinning you will see green, yellow, red and black balls depending on unit status.

Might it be that the TPWCAS 1.01 mod is still running? I know nothing about MP servers, but can't imagine why if you have removed 2.06 it keeps showing up. How much will it piss everyone off if you reboot?

Share this post


Link to post
Share on other sites

MP server doesn't currently work 100% - some features may work, but other features not at all.

E.g. not all bullets shot by players are detected and processed.

I'm working on it and do make some good progress.

No guarantees, but lets say I'm very optimistic and do hope to have some more news by tomorrow evening.

Share this post


Link to post
Share on other sites
Hi guys. Based on your earlier threads, you initially tried to run 1.01, which only has the red debugging balls. If 2.06 is ruinning you will see green, yellow, red and black balls depending on unit status.

Might it be that the TPWCAS 1.01 mod is still running? I know nothing about MP servers, but can't imagine why if you have removed 2.06 it keeps showing up. How much will it piss everyone off if you reboot?

My guys are understandable. It wasn't an issue but the dots were gone for at least 45 minutes when I took the mod off and then all of a sudden boom red balloons. I just shut down the server for a couple of minutes and restarted maybe that will help.

Share this post


Link to post
Share on other sites
Hi guys. Based on your earlier threads, you initially tried to run 1.01, which only has the red debugging balls. If 2.06 is ruinning you will see green, yellow, red and black balls depending on unit status.

Might it be that the TPWCAS 1.01 mod is still running? I know nothing about MP servers, but can't imagine why if you have removed 2.06 it keeps showing up. How much will it piss everyone off if you reboot?

A. We dont want to see the debugging balls at all.

we've put 0 on debugging mode and the balls still showed up, we rebooted the server several times,

the balls now appear both when the mod is off and on, is there a way to fix it other then formatting the whole server computer?

Share this post


Link to post
Share on other sites

The debug balls showing continously is one of the issues with dedicated server at this moment. If youi don't like the balls you better remove mod uintil we released an MP compatible version. Hopefully within a few days from now. After remove and restart balls should be gone.

Share this post


Link to post
Share on other sites
A. We dont want to see the debugging balls at all.

we've put 0 on debugging mode and the balls still showed up, we rebooted the server several times,

the balls now appear both when the mod is off and on, is there a way to fix it other then formatting the whole server computer?

I don't want you to see them either, but you need to tell me what coloured balls you are seeing. I'm not asking to be a pain in the arse. If they are only red, then it's a problem with 1.01 persisting. If they are green/yellow/red/black, then it's a problem with 2.06.

I take it you are trying to run this on a dedicated server? Are you sure there's not a script lying around in a mission directory somewhere? Have you only ever tried the addon version? Can you do a search for "tpwc" on the server. I don't know much about servers but they can't magically run code that isn't there. Have all your players rebooted their clients? TPWCAS does set variables on the player which might be persisting.

And if you do manage to track down the problem, please tell me what you did, and please don't immediately try to run it again. We are hopefully not too far from a true MP and dedi solution.

---------- Post added at 22:35 ---------- Previous post was at 22:31 ----------

Maybe they should only get a courage drop if nearby allies are killed?

Good point. I will look into that. They already get a greater skill reduction if nearby casualties, so we can tie the courage into that.

Share this post


Link to post
Share on other sites
Great update - better than ever!

Fabrizio's hint is lurking in the current addon version, however. :p

Thanks CMcD. You got me yet again with the bloody hint. Had a 1 sneak in instead of a 0! Will be fixed next release...

Share this post


Link to post
Share on other sites
Save all the files in scripts into your mission directory (or wherever you'd like really).

Call it with: null = [] execvm "tpwcas.sqf", in your init.sqf or in the init of any object on the map. You only need to call it the once.

That is wrong. Since tpwcas.sqf calls for call compile preprocessFileLineNumbers "tpwcas_mainloop.sqf"; you have specified that the scripts are in the missions root folder! They have to be places directly into the missions folder or it will not work.....................................................................

My tip for you is to put the scripts in a folder called tpwcas\*SCRIPTS GO HERE* and then add that path to all scripts when they call for the other scripts. This way it will work and the mission makers wont have seven extra scripts in the root mission folder.

This is how it has to be done now:

missions\Co@04killtime10\*tpw scripts go here*

This is better:

missions\Co@04killtime10\tpwcas\*tpw scripts go here*

Just thought I should give a heads up before people start to unpack the script version and complain that it doesnt work,

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×