Jump to content
Sign in to follow this  
jcmomo

Video Setting Lock Cannot Go Above Normal for Video Memory

Recommended Posts

As the title says, I can't put video memory or texture settings past normal, BUT I have 1gb video memory, 8gb ddr3 ram, and yes the video card is well over the standards to play ArmA2. Please help!

Edited by Dwarden
resolved problem

Share this post


Link to post
Share on other sites

-Reset the config to the standard configuration > restart the game and try again.

-Remove (don't delete) the config folders (all Arma2 folders) from the "my documents folder" (if A2 is not running) > restart and try again

-If all fails just edit the C:\Users\Lars\Documents\ArmA 2\ArmA2.cfg

-Install or reinstalled the video drivers (or reset all its config)

-Good Luck!

Share this post


Link to post
Share on other sites

Mostly a GPU/driver/windows/faulty VRAM detection problem. Update everything to latest (also directX 9).

Then try different GPU drivers.

Share this post


Link to post
Share on other sites

Same problem here + Texture flickering after 5 minutes gameplay!

Game is up to date, new installation with newest patch 1.60 is installed.

No problems with other games (Crysis 2, Dead Space 2, Allan Wake,...)

My system:

-Windows 7 Ultimate + SP1

-Nvidia Driver v295.73 WHQL

-Intel Core2Quad i7-2700K @ 3,50 GHz

-3GB DDR3 RAM

-EVGA GeForce GTX 580 / 3GB

(not Overclocked)

Edited by brzozowsky

Share this post


Link to post
Share on other sites

Try different video memory settings in the graphic settings ingame.

Share this post


Link to post
Share on other sites
Try different video memory settings in the graphic settings ingame.

I have reinstall windows 7 and the game, newest drivers. Game update to 1.60.

I can change the settings VIDEO MEMORY and TEXTURE DETAIL only to NORMAL or LOW. See image below.

And after 5 minutes gameplay i have Texture flickering in gameplay. After 10 minutes the game crash to desktop.

http://brzozowsky.bplaced.net/wp-content/uploads/2012/02/screen_1.jpg

My Graphic card:

http://brzozowsky.bplaced.net/wp-content/uploads/2012/02/screen.jpg

Edited by brzozowsky

Share this post


Link to post
Share on other sites

Also 3d interface same as interface size.

Did you update directX9?

Share this post


Link to post
Share on other sites
Also 3d interface same as interface size.

Did you update directX9?

I have changed Interface Resolution and 3D Resolution to 1680x1050.

DirectX is updatet to newest. Same problems.

And here is a short video of GUI and Texture Flickering in game:

http://youtu.be/BwWIOGNwWRw

Share this post


Link to post
Share on other sites

Thanks for help, guys! Here are the files:

- userName.ArmA2OAprofile

- arma2oa.cfg

- arma2oa.rpt

- arma2OA.bidmp

- arma2OA.mdmp

- DxDiag.txt

Download: http://brzozowsky.bplaced.net/wp-content/uploads/2012/02/Arma2OA.rar

I use this commands on the Arma2OA.exe to start: -nosplash -cpucount=4 -exThreads=7 -mod=@CBA;@LittleBirds;@JSRS1.4

I have tested it without this commands, but i have the same problems.

Share this post


Link to post
Share on other sites

Started up ArmA 2 OA, today for the first time in a while.

Before deleting the .cfg and profiles I could only get the video memory to show LOW. Afterwards I'm stuck on normal. The only thing that really changed since I last player was an additional 4gb of RAM added (8gb total).

Share this post


Link to post
Share on other sites
Thanks brzozowsky. Here are the files and values of a friend of mine with a GT580 on Win7:

http://www.filedropper.com/arma2oae

Compare them with your setup and adjust your system.

Why not point the problems here in this thread so others that might have similar issues could maybe find a solution without downloading and comparing files (which probably even aren't accessible for a infinite time period anyway)?

Share this post


Link to post
Share on other sites

See #3 - why this is the case he still has to find out. Nothing anyone else can magically predict.

Share this post


Link to post
Share on other sites

Thanks for the files, PvPscene!

With the files are the "Very high" Video Memory and Texture Quality enabled (or visible). But if i change the settings to low, the high settings are locked (invisible) again.

I have try this changes:

1. Reinstall Arma2 & Arrowhead (Update 1.52)

2. Reinstall Arma2 & Arrowhead (Update 1.59)

3. Reinstall Arma2 & Arrowhead (Update 1.60)

4. Reinstall Nvidia Drivers 285.62 WHQL

5. Reinstall Nvidia Drivers 295.73 WHQL

6. Disabled the VGA Onboard in BIOS and deactivate the Onboard VGA drivers in Windows. (Only the Nvidia card as Primary VGA adapter, no second VGA)

Problems are the same!

...and its not a classic texture flickering in game (with GUI flickering), its looks like a fast switching between LOW settings and MEDIUM settings, see short video.

http://youtu.be/XftMd9ePW10

(sorry my englisch)

Edited by brzozowsky

Share this post


Link to post
Share on other sites

Just to make it clear - this is your key issue:

localVRAM=2147483647;

nonlocalVRAM=1297432576;

arma detects your VRAM size faulty. 2 GB instead of your 1.5 GB (per GPU core).

the basic question is why it works for people with a very similar system (GPU, OS, GPU, driver) and not for you (and some others)

Share this post


Link to post
Share on other sites

Yes, this is it. I have try to delete the *.cfg file or enter the VRAM manualy: localVRAM=3072000000; (for Nvidia GTX580 with 3GB RAM)

But when i start the game and change anything in the settings, the localVRAM jump back to 2147483647.

My next step is to remove the game, and install the free arma2 version for testing.

Share this post


Link to post
Share on other sites

to adjust the values doesnt work. arma writes only in the file, it does not read them.

you could try to search for post from Suma on the matter (VRAM). i think he gave some hints what to do on faulty detection.

there are also some CIT tickets about it.

Share this post


Link to post
Share on other sites

@brzozowsky please run DXDIAG again and tell us value from display tab -> Approx. Allocated Memory : xxxx

Share this post


Link to post
Share on other sites
@brzozowsky please run DXDIAG again and tell us value from display tab -> Approx. Allocated Memory : xxxx

Hey! This is it! Thanks! It shows me only 175 MB?

I thing this has to do with the VGA Chip on Mainboard. (Is disabled in BIOS)

But how i can change this value? Is it possible?

dx_image.jpg

Share this post


Link to post
Share on other sites

For now only way to fix this problem is to take out 1 stick of system memory. Reason for that is THIS M$ bug.

Share this post


Link to post
Share on other sites

i swear there was released beta-hotfix for upcoming SP2 (either as candidate hotfix or final but non-public)

i'm trying find it but for some reason i keep failing (yet i have burned into my memory there is one)

(note: there was also another DXdiag fix which solved the DX10 vs DX11 detection (bug was that it reported only DX10 on DX11 card))

Edited by Dwarden

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×