Jump to content
Rydygier

HETMAN - Artificial Commander

For HAC users: What is the maximum number of simultaneously used by you Leaders?  

63 members have voted

  1. 1. For HAC users: What is the maximum number of simultaneously used by you Leaders?

    • Only one
      18
    • Two
      9
    • Three
      15
    • Four of them
      0
    • Five
      6
    • Six
      0
    • Seven
      12
    • All eight!
      0


Recommended Posts

Hmm. First link is not opening, second returns error 404.

sorry the link was dead for me also so I re edited above post. OFpec seems to be offline.

I uploaded norrins demo, & sent you a pm.

I found this script some time ago from this post: http://forums.bistudio.com/showthread.php?86092-Spawning-civilians

Edited by MadM0nkey

Share this post


Link to post
Share on other sites

I downloaded mission, that you PM me. It is only that script demo. In usual circumstancies I need the exact same mission, that generates reported issue to reproduce it, not a demo of the script used in the troublemaking mission. But anyway tested this demo. It is, as I suggested. Rectangle, dark markers are moved out of the map few seconds after mission start also on pure vanilla A2 CO 1.62. No HAC around, no anything else. Just demo. So it is not related to HAC. As mentioned, I do not know this particular script, how it is working, what is doing etc. so best would be to ask about this issue author of that script.

EDIT

Checked that respawn patrol script. Inside UPS code found such lines:

// show area marker 
_showmarker = if ("SHOWMARKER" in _UCthis) then {"SHOWMARKER"} else {"HIDEMARKER"};
if (_showmarker=="HIDEMARKER") then {
//_areamarker setMarkerCondition "false"; // VBS2
_areamarker setMarkerPos [-abs(_centerX),-abs(_centerY)];
};

Seems, that moving markers out of the map is UPS' way to hide them. Strange method. Anyway, according to the code, this shouldn't affect patrol routes, as initial marker positions seems to be remembered first. Anyway, seems also, that for keeping markers on place string "SHOWMARKER" must be passed to the UPS code as one of the execVm arguments. No time to test it deeper, that much I can do. I suggest to ask author. Norrin or Kronsky, I guess?

Edited by Rydygier

Share this post


Link to post
Share on other sites

Seems, that moving markers out of the map is UPS' way to hide them. Strange method. Anyway, according to the code, this shouldn't affect patrol routes, as initial marker positions seems to be remembered first. Anyway, seems also, that for keeping markers on place string "SHOWMARKER" must be passed to the UPS code as one of the execVm arguments. No time to test it deeper, that much I can do. I suggest to ask author. Norrin or Kronsky, I guess?

ahaH! so it's old UPS scripts that was doing this. and all the time I thought it had to be your brilliant script *inserts foot in mouth*

well then, that makes my issue here with HAC a mistake on my part & sorry for this.

HAC is a really impressive script, and I really appreciate you taking time away from whatever your working on to help me figure that out.

I guess I can have a look into this old UPS script & maybe update it + work out some conflicting bugs.

I want to Recommended to others to try HAC along with:

- norrins ai patrol & respawn using UPS as an ai patrolled insurgency in towns.

- Demonized Single Player - respawn [script] from here: http://forums.bistudio.com/showthread.php?121814-Single-Player-respawn-script

it's an endless sandbox of fun!

<edit>

ok so I edited this older UPS script and this should fix it.. rather then moving the markers it simply hides them.

// show area marker 
_showmarker = if ("SHOWMARKER" in _UCthis) then {"SHOWMARKER"} else {"HIDEMARKER"};
if (_showmarker=="HIDEMARKER") then {
   //_areamarker setMarkerCondition "false"; // VBS2[color=#0000ff]
{_areamarker setMarkerAlphaLocal 0} foreach ["East_WP1","East_WP2","East_WP3"] [/color][color=#000000]//added code[/color][color=#ff0000]
//    _areamarker setMarkerPos [-abs(_centerX),-abs(_centerY)]; [/color]//disabled code
};

Edited by MadM0nkey
solved thanks to Rydygier

Share this post


Link to post
Share on other sites

Most probably. Even now some people are working on such version indepedently. I haven't A3 yet, but heard, that even this version except some its elements is functional under A3. Can't tell when, but it should come to arma 3 with full potential, possible even some new stuff basing on new possibilities of A3, if I figure out something.

Meanwhile is probable HAC 1.45 for A2 with more fixes related to 1.63 beta patch and some other small fixes.

Share this post


Link to post
Share on other sites

Sadly it doesn't work for me in arma 3 :(

Great good work with the script mate, must have took ages to do it :)

Share this post


Link to post
Share on other sites

So perhaps someone, who made HAC working under A3 could help?

HAC 1.0 took me a month. This was almost 2 years ago, including 1.5 year of development and 0.5 of maintenance. Of course not continous, there was long pauses. In summary I guess it took several months of work.

Edited by Rydygier

Share this post


Link to post
Share on other sites
So perhaps someone, who made HAC working under A3 could help?

HAC 1.0 took me a month. This was almost 2 years ago, including 1.5 year of development and 0.5 of maintenance. Of course not continous, there was long pauses. In summary I guess it took several months of work.

Please, someone help up Rydygier, we definitely need HAC in Arma3. One of the greatest pieces of scripting anywhere.

Share this post


Link to post
Share on other sites

:) Thanks, but help is called for Denco, who couldn't launch A2 HAC on A3, while some others could, as I heard.

I'll start work on A3 HAC when I get A3. I have some reasons to wait a bit more before I do so, that's all.

Share this post


Link to post
Share on other sites
Please, someone help up Rydygier.

I know that both myself and Zorrobyte have been in contact with Rydygier with a view to working together on getting HAC into Arma 3. Rydygier has already posted a link to Zorrobytes repo in the first post of this thread. Here is the link to the repo:

https://bitbucket.org/zorrobyte/hetman-artificial-commander/get/master.zip

I also have a repo which is separate because I am working on a template system that requires some files and folders to be in different places. That repo is available here:

https://github.com/vigilvindex/arma_3_hac_module/archive/master.zip

As it stands, HAC is currently working in Arma 3 pretty much as is, all that has been changed are a few class names and some of the old Arma 2 marker names to Arma 3 equivalents. There are classnames outwith the library embedded in the code that will still need updated for things like artillery, smoke etc. The use of the MP framework will also have to be replaced with the new Arma 3 BIS_fnc_MP, until this is done human players will not receive orders from HAC commanders. However AI will still receive orders so HAC effectively works already, given the few issues mentioned above.

The best thing for HAC in Arma 3 will be when Rydygier gets a copy of Arma 3. ;D

Share this post


Link to post
Share on other sites

Thank you mate. I will try this as soon as I find some free time :)

Share this post


Link to post
Share on other sites

The best thing for HAC in Arma 3 will be when Rydygier gets a copy of Arma 3. ;D

He lives in a place where dial-up is still a thing, so he needs a physical dvd or a Steam backup.

Edited by Lucidity

Share this post


Link to post
Share on other sites

Yep. Limited and weak radio net connection does not allow me too much. So I'm waiting for end of "X GB patches" era, in other words for something more... complete than A3 in current state, and for box version available after that to avoid any big downloads. And perhaps for lower price. Current prices of the "fresh release" games I found significant exaggeration in Poland. Better to wait for something more patched and cheaper.

Share this post


Link to post
Share on other sites
:) Thanks, but help is called for Denco, who couldn't launch A2 HAC on A3, while some others could, as I heard.

I'll start work on A3 HAC when I get A3. I have some reasons to wait a bit more before I do so, that's all.

Ah, ok, I misread that.

Share this post


Link to post
Share on other sites

HAC 1.45 released.

Changelog:

- further fixes due to "undefined variable" RPT error message in CO 1.63;

- small fix for better work with spawned groups;

- corrected name of BB object representation in the manual.

Share this post


Link to post
Share on other sites
Guest

Thanks a lot for informing us about the new version mate :cool:

New version frontpaged on the Armaholic homepage.

===================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

How can I help? If its leagel to send a copie of backup from steam via usb and snailmail I will send it to you. everytime a patch comes. I love what you do and this is a small tooken of what feel I owe the creator and founder of HetMan. so pls explain.:confused:

Share this post


Link to post
Share on other sites

Thanks a lot, as always, Foxhoud. :)

Meltedping! It's good to read you again. :) I do not know, what exactly is legal and what technical possible, but for sure currently traditional mail/courier indeed is an only way to get large data for me. Thanks for the offer, someone offered same thing me earier, it is really heartwarming. However there are also other reasons, why I'm delaying getting own A3, that I mentioned earlier. Good news is, no promises, but probably it is matter of about month, six weeks or so, when I move to a different location, where I usually spend whole Winter. Then I'll have access to the unlimited internet connection, even if still slow. After that things around A3 HAC should go forward. It is anyway only question of time and patience. :)

Share this post


Link to post
Share on other sites
How can I help? If its leagel to send a copie of backup from steam via usb and snailmail I will send it to you. everytime a patch comes. I love what you do and this is a small tooken of what feel I owe the creator and founder of HetMan. so pls explain.:confused:

As far as I can tell, it's legal. I found this link on the subject http://www.tomshardware.com/forum/13507-13-steam-back-file-talki

Share this post


Link to post
Share on other sites

I just bought OA just to play your mod (even though I already own Arma 3! ) , but I am getting an error trying to run it. After setting up the mission and using preview I get about 20 seconds later the error " script topics.bik b not found".

Any ideas? Google didn't turn up with anything on it.

I found topics.bikb in the script version of the addon, but I am trying to run the addon version.

I have no experience with Arma mods, do I need to put the scripts in the scripts version somewhere for the addon version to find them? I also tried to add a mission object that initiates the script version and put the script version in the missions folder, but that does not work either.

I need to find a easy guide on how to install these.

Edit:

I changed to trying the documents folder option and dropped the script files in my mission folder there, now the AI is spamming the chat with "HAC 1.45 is here". An improvement but nothing else yet :D

Edited by Infyra

Share this post


Link to post
Share on other sites

You bought a game because of my mod? Wow. That is what I'm calling a compliment... :) But do you have full A2 CO or OA standalone? HAC needs CO 1.62 or above, I think. In fact never tried to launch it on OA standalone.

For sure both versions should work fine. Both was tested without such problems. Script and addon version are separate things. If you use one, other is not needed at all. So if you run Arma 2 with HAC addon, do not copy any HAC scripts into mission folder and especially do not launch init code for them. And if you use script version, play without the addon. Perhaps try to launch one of the included demo mission with addon version to check, if problem will occur for them too.

Anyway, if you upload somewhere troublemaking mission and give me a linkt to it, I'll gladly check that mission for you.

Edited by Rydygier

Share this post


Link to post
Share on other sites

Thanks for the quick answer, I experimented a bit more and found the problem I think. I haven't gotten the MoD version to work, but I made the script version work. I used a trigger with the initializing text nul = [] execVM "RydHQInit.sqf"; and it seems it kept spamming this and restarting the script. I changed to a waypoint and now it works!

I have both A2 and OA, but I bought both of them standalone so I am not sure how it is different from Combined Operations, I can start all maps from the game now.

Again, thanks for the quick answer!

Share this post


Link to post
Share on other sites

Great then. I have a theory, that this spamming with trigger may be because trigger is set to be activated repeatedly instead of once? If so, then script was activated again and again about twice per second until CPU will choke... :) Waypoint is possible way, but you can try also simplier - put same code into init field of any unit on map (be sure, this code is only in one place at once to avoid multiple init. "HAC 1.45 is there" message should be displayed once only).

Edited by Rydygier

Share this post


Link to post
Share on other sites

This Exact same Script topics.bik b not found is happening to me. In fact I registered an account to specifically tell you about it.

It didn't occur with version 1.44 and it appears to be present in the Addon version of HAC as well as the script but both are failing to start for me.

I lack the knowledge to go edit whatever in the addon or script is causing the error but the file is present in the mod/script, yet it's failing to realize it.

Just thought i'd report that i'm having the same problem with 1.45.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×