Jump to content
Sign in to follow this  

Constant Crash To Desktop after 5 Minutes

Recommended Posts

OK, I'm getting the same CTD described by drdavid in his thread. I'm going to try windowed mode too. I noticed that my GPU was at 72C and the temp dropped immediately I used task manager to kill the program. If several people are getting this on default settings, maybe someone should look at it?

I'll spend a whole day testing and report back tomorrow.


Second day, after testing:

Windowed mode crashes too. I turned down all the graphics options to minima. While it took longer, almost 9 minutes, the program still CTD'd.

The crash leaves the TOH icon on the taskbar (Win 7), with the sound still running. TOH is still active, because I can press ESC and the sound stops. Pressing ESC the second time resumes the sound. Taskmanager reports the App running and using CPU resource, albeit at a much lower level than normal. So this can be classed as a Graphics Crash.

CPU useage is unbalanced (I have 4 at 2.5GHz), with CPU 1 at 95% on the TOH main menu (!). CPU 4 picks up some 50% load, a small amount on 2 and 3, but it is CPU#1 that is doing all the work, along with the GPU. More effective use of mutiple CPU's might lower the load on the GPU.

I'm running an NVidia GTX 285, so I installed and ran the NVidia Monitor. This reported idle GPU temp at 42C. I ran TOH in windowed mode, only to the main menu. This immediatley lifted GPU temp to 74C, close to the maximum limit for most GPU's. TOH is still running with everything turned down, and only at the main menu.

To put this into perspective:

X-plane 10 runs at 62C, everything turned up, no crashes.

FSX runs at 67C, everything turned up, crashes sometimes.

Fast framerate FPS games run at about 60C, no crashes.

All other graphics apps I have run at between 48 and 60C, no crashes.

Something in TOH is really thrashing the GPU. In most other sims, the framerate dictates graphics settings, so a natural process occurs with a user turning down video settings to obtain an acceptable, and playable, framerate. I seem to be hitting the graphics limits in TOH without being able to turn it all down to a level that allows gameplay.

The game is worth the effort, amibtious as it is, if we can find the problem.

It's also easy to say that users should simply add more grunt to their systems, but this adds significant costs that people can't afford and will restrict sales to those with high-end systems. It's obviously in BI's interests to access a wider audience and market.

My current situation is that a 2.5 G Quad CPU, 4G RAM and a GTX 285 with 1G RAM is simply not enough to run TOH with settings at minimal. Besides the fact that the minimal settings mean I'm looking at pretty average, jaggedy graphics and a poor framerate.

The manual states system requirements as:

• OS: Windows XP or Windows Vista

• CPU: Intel Dual-Core 2.4 GHz or AMD Dual-Core Athlon 2.5 GHz or


• GPU: NVIDIA GeForce 8800GT or ATI Radeon 4850 with Shader

Model 3 and 512 MB VRAM or faster

• RAM: 2 GB

• HDD: 17 GB free space

• DVD: Dual Layer

This is not correct.

My system exceeds all the required basics specified by the manual and I can only run the game for a max of five minutes, risking damage to my graphics card.

I'm running many other sims and I've been running flight sims for over 25 years, probably since before some of the developers were born :-).

It's no use adjusting graphics settings, I have everything at its lowest settings.

Obviously, this problem does not occur with all users, or there would be a serious revolt... but it looks as if I am not alone.

Any ideas or help please?

Share this post

Link to post
Share on other sites

Hi there, thanks for your elaborate report! You should be able to run the game fine at those specs, so let's see what else can be going on.

First to get an obvious candidate out of the way: you are using the latest HW drivers?

Secondly: we are soon releasing Patch 1.03, which includes both stability fixes, and also the option to try different memory allocators as advanced option. A Release Candidate for this patch has been released, but carefully read the warning please.

More effective use of mutiple CPU's might lower the load on the GPU.

Sidenote: I believe there are some posts in the A2 / OA forums explaining why task manager profiling of cores is not an accurate method of determining the game is utilizing multi-core effectively.

Share this post

Link to post
Share on other sites

Any ideas or help please?


this thread is simply cross-posting the same exact question there as here. You didnt get an answer there, because the answers were already in the thread, which apparently you didn't read.

My current situation is that a 2.5 G Quad CPU, 4G RAM and a GTX 285 with 1G RAM is simply not enough to run TOH with settings at minimal.


This is quite simply untrue. I run SLI gtx 275, which has less Vram available (896, Vram doesnt stack) and I run the game at a mix of normal, High, and Very High, however the screenshot is from v1.02.86094 and I am using the 1.03 RC now.

first, lets decrease the crash frequency



... please search for TakeOnH.cfg in the Documents/Take On Helicopters folder' date=' and change AToC=7 to AToC=0.


now, lets recover from that Graphics crash in case it happens again.

-Ziggy-;2058697']if your game drops to desktop but you can still hear the game' date=' press and hold LEFT SHIFT and press NUMPAD MINUS, then release both and type


bear in mind, L SHift and minus DOES NOT OPEN a console, but after you type flush, you may notice the screen flash and 'flush activated' appear briefly.

Edited by [DirTyDeeDs]-Ziggy-

Share this post

Link to post
Share on other sites

DirTyDeeDs, thank you for the detailed reply, and my apologies to Admin for starting another thread. As the previous one had become mixed, I wanted to focus on this issue.

Some progress:

I updated the NVidia drivers, as they were the only ones out of date after a thorough check. Testing with the new drivers gave the same results, after the same time.

Then I downloaded patch 1.03. Although I still had repeated CTD's after a few minutes, the FLUSH command prevents the CTD. (As you outlined above). In fact, so long as I repeat this every few minutes, I am able to run the game indefinitely! (Wow - I must admit, I love it now that I can play it - great piece of work!)

(Note that I was not able to get a result from this on version 1.02, or after a CTD.)

BTW, task manager does not give accurate information about multi-core functions, that is true, it does show a binary view of application load, in that an app using 90% of a CPU while other CPU's are at very low values is an indication of unevenly distributed CPU loading. CPU load distribution is not a Win7 function, in that Win 7 will not automatically load share, individual applications need to be compiled for even load distribution.

Soooo, the SHift - flush command clearly is a workaround and directly addresses the issue. (Is this a garbage collection problem in VRAM?) If you have a number of users with this issue, then you can reasonably expect us to enter SH-flush every few minutes on a temporary basis.

As this workaround shows what the problem is, is there a permanent fix? A suggestion might be to hard code a flush function?

Thanks again for taking the time to reply! I'm going to run TOH and see how Tom is doing, I'll pop back later!

Share this post

Link to post
Share on other sites

There are a few other things you can try...

1. Try playing with the Video Memory setting - try it on each one from low to very high and default.

2. Make sure PiP and Cloud details are off.

3. Make sure Antialiasing is off.

4. In c:\users\username\My Documents\Take On Helicopters, rename TakeOnH.cfg to TakeOnH.bak and run the game again. This will recreate the config file. I have had problems before in Arma that have been solved by getting the game to recreate this file. When you run the game first time after renaming this file, you will need to readjust your video settings in game.

5. Also, as Ziggy said, you should edit this file with notepad and change ATOC=7 to ATOC=0.

6. Try setting the shadow detail to low - I believe that this shifts the processing of the shadows from the GPU to the CPU (although this may just be a slanderous rumour!).

Share this post

Link to post
Share on other sites

Many problems stem from the TakeOnH.cfg not being set right.

My advice is to ensure that when you close the game down and check it has registered your new settings you made in the game, im not sure it always does them all correctly under certain circumstances.

its in mydocs\toh (or other if you changed ingame name from default), in addition i noticed i had to copy my profile from the Take On Helicopters to my Thromp profile inside Take On Helicopters Other Profiles, when i noticed pip would not enable .

also if your having problems ,never shut game down maxed out , because when it loads the initial island and shows the cutscene ,it will take a long time to load if settings maxed out . personally i shut down with view distance etc minimal .

Share this post

Link to post
Share on other sites

Thank you Thromp and Jedra for taking the time to reply. I'll try all you said and report back!

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this