Jump to content
Sign in to follow this  
vektorboson

CWA 1.99 Bug reports

Recommended Posts

I've tried CWA 1.99 just a second ago; it seems that the Radio command has a bug (0-0-9 and 0-0-0).

The radio commands 0-0-9 and 0-0-0 are always there and they lead to the target menu.

Share this post


Link to post
Share on other sites

Same thing. Many of the radio commands seem to be mixed and some of them don't even appear to be working.

Also, the new promised getMove command doesn't seem to be working.

Edited by Rellikki

Share this post


Link to post
Share on other sites

We're having problems with pistols - unable to move with pistol in hand.

Edited by Ferenczi

Share this post


Link to post
Share on other sites

watching the thread, please report just new / broken things :)

not the not yet fixed ones , thx :) for that is A1, A2, OA, TOH, A3 :)))))))

Share this post


Link to post
Share on other sites

Tried with placing a mod folder inside of the CWA directory and launched with

-nosplash -mod=nameofmodfolder

I was happy to see it worked without apparent problem, and i noticed that there is no handgun bug and no radio bug.

So those handgun and radio bugs are certainly located in the default CWA config and resource files from the CWA bin\ directory, as the mod i tried use its own version of those files.

Share this post


Link to post
Share on other sites

I guess this is a documentation mistake:

- Changed: createMarker function now works only local

There is no createMarker-function at all (and I guess there won't be, would be nice anyway).

I guess the enum-values in the config.bin and resource.bin are wrong and we therefore have those command menu-bugs (and pistol-bug).

Other than this: The loading performance seems to have improved, it starts almost instantly (even vanilla OFP:R doesn't start that fast) :)

EDIT: Further testing: "getMove" does not exist, but "AnimChanged"-event handler does work.

Edited by vektorboson

Share this post


Link to post
Share on other sites

I must be blind, but i can't find where it puts the "userinfo.cfg" and the user saved missions ? (Win 7).

Share this post


Link to post
Share on other sites

Oh yee who did not play OFP...

In OFP and now CWA, user profile data is stored within the root installation folder rather than anywhere else. So in this case, you'll find your user profile data under:

...\Bohemia Interactive\Arma Cold War Assault\Users

Share this post


Link to post
Share on other sites
Oh yee who did not play OFP...

In OFP and now CWA, user profile data is stored within the root installation folder rather than anywhere else. So in this case, you'll find your user profile data under:

...\Bohemia Interactive\Arma Cold War Assault\Users

Mmm... nope, not for me. For OFP, yes, but no "users" folder" in CWA.

Share this post


Link to post
Share on other sites
Mmm... nope, not for me. For OFP, yes, but no "users" folder" in CWA.
It could also be in the virtualstore: C:\Users\<user>\AppData\Local\VirtualStore\Program Files\Bohemia Interactive\Arma Cold War Assault\Users

Share this post


Link to post
Share on other sites

I started the Hostage Rescue coop mission and the game gave a "rus_vlajka_texture.pac" not found error.

Share this post


Link to post
Share on other sites
I started the Hostage Rescue coop mission and the game gave a "rus_vlajka_texture.pac" not found error.

Same error here when playing that mission online, the russian flag texture i think.

Share this post


Link to post
Share on other sites

Installed only CWA 1.99 - did not updating old OFP 1.96 (must search for the good'ol game box!!).

Found some bugs:

Radio menu and commands are a bit messed up

new/wild radio commands appear

Observed:

in editor place a group + yourself as group leader

click "0"

you will see two new/wild radio commands

"9 India" with submenu "0 More"

"0 Juliet" with submenu "1 No target" and "0 More"

Expected: no such radio commands!

doubles in /buggy radio command

Observed:

in mission click "5" you will get

2x "5" radio commands

"5 Where are you?"

"5 Report Status"

now click "5" and your charcter will say "Roger"

Expected: "Where are you?" and the proper answer from AI team/groupleader

Mission "Flashpoint"

- AI crashing helicopter into the tree

- AI group (player) going the wrong way - they should attacking Morton from the left side (on the road close to the sea)

- attack helicopters circling above enemies without attacking them (trigger to open fire issue?)

Share this post


Link to post
Share on other sites
From what i read, Seven is basically Vista improved, so this may apply for you :

http://forums.bistudio.com/showthread.php?t=69433

It could also be in the virtualstore: C:\Users\<user>\AppData\Local\VirtualStore\Program Files\Bohemia Interactive\Arma Cold War Assault\Users

Thanks guys, that's it ! (and you can click on "compatibility files" while looking at the game folder).

Share this post


Link to post
Share on other sites

Every time I restart the game my difficulty setting in the mission editor reverts to Veteran, and I have to play a mission on Cadet for it to go back.

I play on Cadet because it allows you to change all the difficulty settings to your liking.

Edit: Scratch that, issue is in OFP 1.96 too. :p

Edited by Zipper5
Non-issue

Share this post


Link to post
Share on other sites

Thanks for bug reports.

Radio and pistol bug are acknowledged and we are working hard on fixing it asap.

There seems to be some major problem in core config that caused these two problems but could be related to some other animation issues.

Share this post


Link to post
Share on other sites

If you have a problem with the pistol animation - advice is: razbinarte CONFIG.BIN using the program BINview, open it and add to the top:

enum {DestructNo,DestructBuilding,DestructEngine,DestructTree,DestructTent,DestructMan,DestructDefault};

enum {ManPosDead,ManPosWeapon,ManPosBinocLying,ManPosLyingNoWeapon,ManPosLying,ManPosHandGunLying,ManPosCrouch,ManPosHandGunCrouch,ManPosCombat,ManPosHandGunStand,ManPosStand,ManPosNoWeapon,ManPosBinoc,ManPosBinocStand};

enum {CPDriver,CPGunner,CPCommander,CPCargo};

enum {UnitInfoSoldier,UnitInfoTank,UnitInfoCar,UnitInfoShip,UnitInfoAirplane,UnitInfoHelicopter};

enum {ManActStop,ManActStopRelaxed,ManActTurnL,ManActTurnR,ManActTurnLRelaxed,ManActTurnRRelaxed,ManActReloadMagazine,ManActReloadMGun,ManActReloadAT,ManActReloadMortar,ManActThrowGrenade,ManActWalkF,ManActWalkLF,ManActWalkRF,ManActWalkL,ManActWalkR,ManActWalkLB,ManActWalkRB,ManActWalkB,ManActSlowF,ManActSlowLF,ManActSlowRF,ManActSlowL,ManActSlowR,ManActSlowLB,ManActSlowRB,ManActSlowB,ManActFastF,ManActFastLF,ManActFastRF,ManActFastL,ManActFastR,ManActFastLB,ManActFastRB,ManActFastB,ManActDown,ManActUp,ManActLying,ManActStand,ManActCombat,ManActCrouch,ManActCivil,ManActCivilLying,ManActFireNotPossible,ManActDie,ManActWeaponOn,ManActWeaponOff,ManActDefault,ManActJumpOff,ManActStrokeFist,ManActStrokeGun,ManActSitDown,ManActSalute,ManActBinocOn,ManActBinocOff,ManActPutDown,ManActMedic,ManActTreated,ManActLadderOnDown,ManActLadderOnUp,ManActLadderOff,ManActLadderOffTop,ManActLadderOffBottom,ManActGetInCar,ManActGetOutCar,ManActGetInTank,ManActGetOutTank,ManActTakeFlag,ManActHandGunOn,ManActN};

old problem = old solution

Share this post


Link to post
Share on other sites

I found a bug. Posted it before but I'll do so again due to posting it in the wrong section, the noob I am:o

Dear friends,

As you guys might know, BIS released ArmA: Cold War Assault yesterday. It is a newly patched Operation Flashpoint: Cold war Crisis + Resistance, released due to the 10 year anniversary. Since there isn't really a forum dedicated to it yet, I decided to put it here.

Now, the next may sound a little bit funny, but I'm having performance issues with this game. My specs are:

System: Windows 7 Home Premium 64-BIT

GPU: GTX480

RAM: 8GB

Processor: Intel i5-760

I can set all settings to high, However, when I set both visibility to 5000 and Texture quality to Very High, the game stalls immediately. I tried doing it 3 times, all causing a stall. Heck, after the last attempt I wasn't even able to pass the opening screen, forcing me to fully reinstall the game again.

Now I'm writing this, I'm having a vague memory that I've had this problem a while ago installing CWC on my relatively modern computer as well. Am I literally overkilling its capabilities?

Thanks in advance,

(PS: Note that I am extremely happy about this launch. It wasn't necessary for my part, but its good to see homage being payed to such a legendary game that changed the gaming industry big time. If there's no solution you won't see me bragging)

EDIT:

I think I've found the problem. When I wrote the above I didn't actually start a mission yet due to the problems already occuring in the options screen. After I fixed that issue with the re-installation, and trying to run a SP mission, I was returned to desktop with the following issue:

Out of Reserved memory (16.384 KB)

Code Change Required (current limit 524.288 KB)

Total free 449.687KB

Free Blocks 694, Max free size 8846 KB)

Note that I have 8Gb of RAM memory. I've also tried various settings for the pagefile, with no positive results.

I also noticed that ArmA: Cold war Assault calls my processor a 'Intel Pentium Pro SSE 2803.3MHz" and it claims it has only 1.024 MB of RAM memory.

Is there a chance that the application isn't able to recognize my 8GB RAM, recognizing it as 8MB instead (8846 KB free size)?

I hope you guys can look into it, I recon in may be a problem for guys with high performance computers.

Edit: I got it running now, I'll try to locate the specific problem that is causing this error

Edited by ubermachtig

Share this post


Link to post
Share on other sites

I can set all settings to high, However, when I set both visibility to 5000 and Texture quality to Very High, the game stalls immediately. I tried doing it 3 times, all causing a stall. Heck, after the last attempt I wasn't even able to pass the opening screen, forcing me to fully reinstall the game again.

When you say "Texture quality" to Very High, are you not in fact setting the Terrain quality to Very High ?

Because, if it is "Terrain", never set it to Very High, there's no computer that can run that game at Terrain "Very High" in a playable state during a mission.

Especially with a very huge view distance (5000 is a very lot, too much, as OFP campaign was set with 900 view distance in mind, you're going to have lot of problem with some events triggering too early in mission with such high view distance)

Set Terrain at maximum to Normal or Low to have the game running best.

I also noticed that ArmA: Cold war Assault calls my processor a 'Intel Pentium Pro SSE 2803.3MHz" and it claims it has only 1.024 MB of RAM memory.

For the wrong CPU detection, the OFP preferences had the same problem.

But the memory detection in CAW preference is a new bug, on my 2gb memory it only detects 1024 memory, the OFP preference detect my 2gb correctly

Oh and while i think about it, is -nomap integrated in the new executable or do we need to continue adding it to our shortcuts when wanting to avoid out of memory problems when using big addon packs ?

Edited by Sanctuary

Share this post


Link to post
Share on other sites

What about the bugs of v1.96, that are still present in v1.99? Are we allowed to report those, too?

I would rather see those fixed, than new features added.

Share this post


Link to post
Share on other sites
What about the bugs of v1.96, that are still present in v1.99? Are we allowed to report those, too?

I would rather see those fixed, than new features added.

watching the thread, please report just new / broken things :)

not the not yet fixed ones , thx :) for that is A1, A2, OA, TOH, A3 :)))))))

There's your answer.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×