Jump to content
Sign in to follow this  
wolffy.au

Multi-Session Operations v3.4 is released!

Recommended Posts

This is what Arma 2 should have been out the box.

Congratulations Wolffy.

I just hope you get the support and attention, as this could be massive.

Share this post


Link to post
Share on other sites
Mission: ACE on Takistan

Version: 3.4

Developer(s): Swordsman & ?

Required Add-Ons: CBA, ACE, ACEX (optionally ACEX_RU)

I took the liberty of fixing this mission (just need to point init lines to the new script locations). It's ACE/ACEX only using the old template so there's a BAF group as well if people prefer British. Working copy is here:

http://www.mediafire.com/file/u14v8kel4p7fs7g/ace_mso_3-4.Takistan.pbo

Edited by friznit2

Share this post


Link to post
Share on other sites

Thx m8s!

Please Provide feedback if possible! I took care on server performance and it never went below 20 fps without tcells and sheperds.

Guidance

Ps: nice fritz! another version to go! hooraaa

Edited by highhead
Forgot something

Share this post


Link to post
Share on other sites
Introducing....

Mission: BAF/USA vs TK_GUE on Qom Province

Version: 3.4

Developer(s): Tupolov, Wolffy.au

Required Add-Ons: CBA (optionally BAF)

http://www.2shared.com/file/lPbhjcpI/baf-usa_mso_3-4tup_qom.html

New features in MSO 3.4 now automatically create keypoint locations for Qom Province, making the terrain fully MSO compliant.

Enjoy!

Regards,

Tupolov

Oh dear god, I had a lot of fun with this map and mission last night. The planes were a nice touch but I guess as soon as I jumped into one 5 APCs appeared all around a 2km radius.

I really like the way the terrain was done to give good cover even on vast treeless grounds.

Share this post


Link to post
Share on other sites

Great mission man.

However the ACE on Takistan does not work right at all. You can't load anything into a vehicle or move anything around to actually set up an FOB.

That "fixed" version also didn't work.

Share this post


Link to post
Share on other sites

Thanks for fixing that mission, much appreciated.

For the ACE missions, I disabled R3F Logistics as ACE has its own Logistics system.

Does that solve your problem?

Share this post


Link to post
Share on other sites

The ACE logistic system works but it's not a viable solution.

You have no way to actually angle any of the materials needed to build an FoB. The only way to get a bunker or sandbag wall to a desired location is to hook it up to a helo and have it fly it to the location and drop it perfectly while a person is already at the FoB position to unload the equipment, somehow not killing him in the process.

Basically, you need to re-implement the R3F Logistics for it to be useful in an ACE mission.

Edited by Wasdie

Share this post


Link to post
Share on other sites

Hey Kolmain,

just tried -> Link works for me, downloaded it (after waiting a few secs on megaupload) and unpacked it again. Gimme ya eMail-adress and i mail it to you if it still doesnt work for ya, m8!

guidance

Share this post


Link to post
Share on other sites
Basically, you need to re-implement the R3F Logistics for it to be useful in an ACE mission.

It almost sounds like you're telling me what to do... :)

Two things you can do.

Log a feature request with ACE asking them to change how logistics work.

Secondly, you should be able to re-add R3F Logistics yourself. Just add the folder and change the modules.hpp. The guys here or on Skype should be able to help, if you ask nicely. :)

Share this post


Link to post
Share on other sites

It's really very easy to re-enable the R3F Logistics module (assuming of course you know enough to depbo the mission and look in the support modules folder). In fact that's the beauty of MSO - it's completely moduler so you can pick and choose which bits you want to implement in your mission or even create more modules of your own.

Anyway, if I get a moment later today I'll update that 'fixed' ACE-MSO to include R3F log, since it actually works fine alongside ACE. Please keep the feedback coming!

Share this post


Link to post
Share on other sites
Sheperds and Terrorist cells are disabled for better performance but you can enable it easily.

Has anyone else experienced a performance improvement turning off Shepherds and/or Terrorist Cells?

Share this post


Link to post
Share on other sites

Maybe its just an improvement on my custom maps but i think it happens to others as well! With tcells and sheperds on i get fps drops to 1-3 fps! without it i get a minimum of 20 fps, even with many patrols "enabled/uncached". Sheperds tend to bug on some locations and i see the sheperds spawning at 20 feet height and falling down on the ground dead, but the spawnings wont stop and after a while i have a whole zoo running on the same spot, with hundrets of animals - looks really cute :)! I couldnt reproduce it clearly, otherwise i would have already postet a ticket. I will keep on it and provide feedback! In the meanwhile i decided to disable it so ppl can play the lingor and poda missions without fps drop!

Guidance

---------- Post added at 13:22 ---------- Previous post was at 12:27 ----------

another thing, need your help on this m8s!

Could you please try to reproduce this!

In stock baf_mso_3-4.chernarus.pbo

with CO server

and CBA i can replicate the following:

- Move to City of your choice (i chose a city on coastline).

- Watch Civis spawning (the single ones, not the traffic)

- Let em go around a bit

- count all civi-units with debug mode (was 101 civis at my last try)

- Move around 2000 mtrs away from it (i went to the sea, so not many units spawn)

- wait a bit (10-20 secs)

- count all units again (was 40 when i counted then)

- move back to the city

>>>>>> At this point there are no Civis spawning anymore. I waited over 10 minutes and counted units all the time, but they were not spawning again. Only saw 1 civi stuck in a house. Also related to this BIS issue: http://dev-heaven.net/issues/11603 i have loads of errors like *Cannot load sound 'ca\dubbing\global\radio\female01\cz\veli.wss'* in .rpt File - maybe its related, dunno.

Its working fine in Takistan clean OA version.

It doesnt happen to the civ air/sea/regular traffic, enemypop and other modules as far as i see.

Does anyone of you guys can confirm this?

Its bad since it seems like a "once spawned and then gone" issue to Town-Civis and players who connect later wont see the nice civis move thru the towns anymore.

Have fun guys, in the meanwhile!

Dave

another edit: could it be that they are deleted (I dont think its your maths wolffy :))

"MSO-2767.63 CEP Caching # 83/90 Cached Groups -25/218/13 Active/Suspended/Cached Units"

Edited by highhead

Share this post


Link to post
Share on other sites
Has anyone else experienced a performance improvement turning off Shepherds and/or Terrorist Cells?

Not tried running without TCells and Sheps, but will give it a go and see what happens.

We did turn off crb_flies and Sandstorms after the last major performance hit, but haven't really given it a thorough test since so can't say empirically whether it's made any difference yet.

Share this post


Link to post
Share on other sites

So where are the files to build a mission? All I can find from the dev-heaven link is the zip with the pbo'd missions.

Share this post


Link to post
Share on other sites

You have to depbo one of them using your favourite pbo tool and have a play around.

Edit: re-enabled the R3F Logistics module in the ACE Takistan version for people who want to test with ACE (and some BAF) only. Everything else is enabled other than the Revive & Tyres, which conflict with ACE modules (and sea traffic - that pond in the north can't hold many boats).

http://www.mediafire.com/file/u14v8kel4p7fs7g/ace_mso_3-4.Takistan.pbo

Edited by friznit2

Share this post


Link to post
Share on other sites

Ok :) Would be nice to have some kind of template so you know you'll have every folder you need, but no problem!

Share this post


Link to post
Share on other sites

It's still very much in Dev, but I'm sure if you poke one of the team on Skype they'd be more than happy to talk you through it. Have a browse through one of them - you'll quickly see how it's put together (that one I linked above is about as vanilla as you can get, albeit with ACE implemented)

Share this post


Link to post
Share on other sites
It almost sounds like you're telling me what to do... :)

Two things you can do.

Log a feature request with ACE asking them to change how logistics work.

Secondly, you should be able to re-add R3F Logistics yourself. Just add the folder and change the modules.hpp. The guys here or on Skype should be able to help, if you ask nicely. :)

Yeah I figured that all out. Sorry if it sounds like I'm telling you how to build your mission. I didn't mean that. I'm just saying with the current ACE logistics systems, FoBs will be very difficult to build.

Share this post


Link to post
Share on other sites

You could always place the construction module on a truck or a container to be flow out to the FOB. Then you can place your things even easier.

Share this post


Link to post
Share on other sites

I have ZoneKillers build module (which is a Construciton variation) and long term I'd like to be able to pack a container or truck with equipment and have the construction module use the contents in its listing.

If anyone is interested in pursuing this for me, please let me know.

Share this post


Link to post
Share on other sites

friznit2, i tested the updated mission (http://www.mediafire.com/file/u14v8k...4.Takistan.pbo). If made a few rounds on takistan with a heli, and my dedicated server fps dropped to 3-4. With the other takistan mso missions, i get minimum 9 Fps, and after a while it goes up again to around 15Fps (but not on the updated one, there it stays on the minimal 3-4FPS). Is this becouse of ACE, or is something broken?

Share this post


Link to post
Share on other sites

It's likely because every MSO module is enabled in that mission - quite a few people have reported severe performance issues and we're still trying to nail down exactly what's causing it. You could try disabling some of the ambient modules and/or Terrorist Cells, that seems to mitigate the performance issues somewhat.

Also, I thinked I missed the construction module. I saw the mod folder but haven't played with it in game yet. Am I meant to have placed a physical object down somewhere?

Edited by friznit2

Share this post


Link to post
Share on other sites

Yes, performance has significantly dropped in the last month or so. I am testing as we speak and hope to have an update by Sunday.

Also, I thinked I missed the construction module. I saw the mod folder but haven't played with it in game yet. Am I meant to have placed a physical object down somewhere?

Yeah, there is a test mission that has it.

I think its something like:

this setVariable ["Construction", true];
this setvariable ["cnstrct_supplies",10000];

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×