Jump to content
Sign in to follow this  

Arma2 OA freezing after installation in new SSD

Recommended Posts

I recently installed an Intel X25M 120GB as a dedicated gaming drive. I have not (yet) installed Windows on it, but simply partitioned it as a simple volume to see if there are any performance enhancements before re-doing everything.

So, FSX is dramatically improved, as is A2OA - when it runs. Almost invariably, the game freezes while loading a mission, or during a mission, usually early on. No error messages. Sometimes it unfreezes if I alt-tab out for a while, but not usually. The only cure generally is to kill it in the task manager. This has happened with self-created missions, Planned Assault-created missions, and stock scenarios. This did not happen when the game was installed on my convential HDD.

Current system and game version: Core i7 870, 8GB RAM, GTX 570, Windows 7 Home Premium 64-bit, latest Nvidia drivers (266.58), game build 1.57.76815, legitimate boxed copies of Windows and Combined Operations.

Here's what didn't work: The drivers my video card shipped with, reinstalling the game to the drive, changing permissions, running it as an administrator, various graphics options. I have monitored CPU and GPU temps and they are all normal

My RPT file usually has this "Item str_disp_server_control listed twice

Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 0)! MoveName: kia_uaz_cargo02

Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 1)! MoveName: uaz_cargo02

Error loading control bin\config.bin/RscTitles/SplashMeridian4/Text_Meridian4/" stuff, but from what I can tell searching online, it's unrelated...maybe?

Any ideas, or important info I forgot to include? Thanks!

Share this post

Link to post
Share on other sites

Hi warsaw, I was having the exact same problem on my X25-V 40GB until I followed this guide and used the intel SSD tool box software.

Seems it's a common SSD problem and nothing to do with the game.

Here's a link to the optimization guide:


And the Intel SSD toolbox:


Things I did were:

Selected high performance power plan

Disabled Indexing

Enabled Write Caching and Checked the "Turn off Windows write-cache buffer flushing on the device" setting

Disabled Defrag

Disabled System Restore

Disabled Superfetch

Disable Prefetch

Ran the System Configeration Tuner and Intel SSD optimizer in the Intel Toolbox software.

Hope this is of some use to you.

Share this post

Link to post
Share on other sites

Thanks, xiaogoufu. I will definitely look into that, because as far as I can tell, the problem strictly has to do with the fact that Arma2OA is running off an SSD rather than an HDD.

I installed vanilla Arma 2 onto the SSD and it was as unstable as the expansion, patched or unpatched. I reinstalled the latest patched version of Operation Arrowhead onto my HDD and it runs stably. I copied the whole thing over to the SSD and it runs somewhat reliably, but still freezes periodically.

I checked RPT files from running identical missions from both installs, and they were exactly the same.

The installs appear to be identical, other than some different Windows permissions/objects, which I would think might make it not run at all, but not run erratically. So, as you suggest, it might be something in how the SSD handles what's stored/installed on it.

Thanks again for the insight, much appreciated!

Share this post

Link to post
Share on other sites

Hmmm...I tried a bunch of what you suggested, but it hasn't cured the problem. I still appreciate the ideas, since they should otherwise help optimize my SSD.

It's not as severe as I initially thought - the freezes are rarer, and they usually don't last...it unfreezes after a while, and most of them are during loading and exit, almost never during gameplay. It's definitely an annoyance, but to be able to run this amazing piece of software fairly smoothly and quickly - I can live with it for now.

It's still puzzling why it's happening. I disabled hyperthreading on the dubious hypothesis that the CPU was getting tangled up making extra threads to deal with the faster access to data from the SSD, but, not surprisingly, my half-baked idea didn't seem to be correct. Monitoring the CPU shows that it does not appear to be getting overworked or overheated, so I don't think it's a CPU issue.

Share this post

Link to post
Share on other sites

Ohh that's really too bad that none of that worked for you.

I also forgot to mention that I changed the drive access mode in BIOS from SATA IDE to AHCI mode (sorry long before I even thought of putting ARMA2 on there)

as it's recommended for SSD drives to run in this mode for some of the added features like NCQ and hot swapping capabilities.


Not sure if you can change each drive to AHCI individually (your hardware is a lot newer than mine, socket 775 motherboard here) but I had to change all my drives at once including my windows

install drive which meant changing some registry settings as per this microsoft article (which I did) or doing a full re-install.


Anyway good luck again, that's all I can think of sorry!

Share this post

Link to post
Share on other sites

I am using an OCZ Vertex 2 60GB but I haven't tried any games on it yet, I like to keep the spare 25GB free as opposed to fill with crap. I can't test as I am using Steam for most of my stuff which wouldn't ever fit on a small SSD.

I can confirm that turning all windows crap off that messes with your drive should help.. tried any other games working fine on SSD? Maybe try America's Army 3 on steam, see if that works?

Share this post

Link to post
Share on other sites

Thanks for the replies. As far as I can tell, the SSD is configured correctly - superfetch and defrag turned off, optimized with the Intel SSD Toolbox, etc. It's just strange that it's totally stable running off my HDD and a little freeze-prone running off the SSD. And identically unstable in 3 different types of installations I tried - a straight install off the DVDs, an install that's just a copy of the HDD Bohemia Interactive folder, and one where all the AddOns .pbos were moved to the SSD and symlinked.

DCS: Black Shark, Flaming Cliffs 2, and FSX all run fine off the SSD.

At least once it's running, it will generally run stably for an extended time, so the problem is more of an annoyance than a game-wrecker.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this